Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

[SOLVED] T430 goes straight to PXE when booting

T430-T490, T530-T590 Series
Post Reply
Message
Author
Harmagonia
Posts: 4
Joined: Sun Jul 31, 2022 1:27 am
Location: Reno, Nevada

[SOLVED] T430 goes straight to PXE when booting

#1 Post by Harmagonia » Sun Jul 31, 2022 1:45 am

I have been using my Thinkpad for about two months now and one day it ran out of battery completely and when I plugged it in and started it, it wouldn't boot into the SSD I put in it and would only go into the Intel Boot Agent. When it tries to do that it gets the error "PXE-E61: Media test failure, check cable" and then it exits to the boot menu where my SSD does show up but when I click on it the screen just goes black for a second and then goes back to the boot menu. I tried resetting the BIOS to default and putting the SSD to the top boot priority but it still doesn't go into it and always goes to the boot agent. I plugged in a thumb drive with arch linux on it and that booted and when I mounted the SSD all my data was there, so I'm not sure what happened.
Last edited by Harmagonia on Sun Jul 31, 2022 10:47 pm, edited 1 time in total.

dr_st
Admin
Admin
Posts: 9421
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: T430 goes straight to PXE when booting

#2 Post by dr_st » Sun Jul 31, 2022 7:36 pm

Welcome to the forum. :)

It is possible that the boot sector on the SSD was damage or the boot partition was somehow marked inactive.

Is there a Legacy/UEFI option in the BIOS of your T430? I believe there should be. Have you tried the various settings there?
Thinkpad 25 (20K7), T490 (20N3), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad

Harmagonia
Posts: 4
Joined: Sun Jul 31, 2022 1:27 am
Location: Reno, Nevada

Re: T430 goes straight to PXE when booting

#3 Post by Harmagonia » Sun Jul 31, 2022 8:55 pm

I know I have an EFI sector on my SSD and how would I figure out if it was damaged. I ran one of the built-in disk checkers and it said that the disk was fine. There is UEFI and legacy options I tried both and with UEFI it goes straight to the boot menu instead of starting the Intel Boot Agent.

dr_st
Admin
Admin
Posts: 9421
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: T430 goes straight to PXE when booting

#4 Post by dr_st » Sun Jul 31, 2022 9:33 pm

What OS is on that SSD?

There are options to do a boot sector / boot partition repair via the installation media of the corresponding OS.
Thinkpad 25 (20K7), T490 (20N3), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad

Harmagonia
Posts: 4
Joined: Sun Jul 31, 2022 1:27 am
Location: Reno, Nevada

Re: T430 goes straight to PXE when booting

#5 Post by Harmagonia » Sun Jul 31, 2022 9:37 pm

I'm running arch linux

dr_st
Admin
Admin
Posts: 9421
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: T430 goes straight to PXE when booting

#6 Post by dr_st » Sun Jul 31, 2022 9:39 pm

I do not have first hand experience with that, but there are some guides online that can get you started, e.g.:
https://www.jeremymorgan.com/tutorials/ ... rch-linux/
Thinkpad 25 (20K7), T490 (20N3), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad

Harmagonia
Posts: 4
Joined: Sun Jul 31, 2022 1:27 am
Location: Reno, Nevada

Re: T430 goes straight to PXE when booting

#7 Post by Harmagonia » Sun Jul 31, 2022 10:42 pm

That got it to work, thanks a bunch. :D

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T430-T490 / T530-T590 Series”

Who is online

Users browsing this forum: No registered users and 10 guests