Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Issue with Intel 6300 WiFi card in my T430

T430-T490, T530-T590 Series
Post Reply
Message
Author
sktn77a
Senior ThinkPadder
Senior ThinkPadder
Posts: 2056
Joined: Thu Apr 29, 2004 9:44 am
Location: Chapel Hill, NC

Issue with Intel 6300 WiFi card in my T430

#1 Post by sktn77a » Sun Feb 11, 2024 3:46 pm

Yes, I know she's an old boat but my T430 meets all my needs.  I updated the stock Intel N-2200 2x2 wifi card to an N-6205 card with no issues.  I eventually updated to an N-6300 3x3 card (all of these cards were Lenovo FRUs).  The Thinkpad has all three antennas for the 6300 and range/speed is good.  However, since moving to the 6300 card, it is extremely slow to come back online after waking from sleep compared to the 2x2 cards.  Anybody know what's going on here?
Keith
(Formerly 600E, T21, T30, T40, T41, 2xT42, 2xT61p, T420, 2x Ideapad K1)
(Currently 4xT430, 2xT460, H520S, M910q, M920q, M70q)

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 23932
Joined: Mon Sep 18, 2006 5:17 am
Location: Loch Garman, Éire

Re: Issue with Intel 6300 WiFi card in my T430

#2 Post by RealBlackStuff » Mon Feb 12, 2024 1:36 am

My T440p with Intel AC-7260 has the same problem.
After it has fallen asleep it can take up to 3 minutes(!) to reconnect to the internet.
So to avoid 'sleeping' I have an online radio station (Classic FM) running all the time, but with the sound muted as and when needed.
My wife's X250 with AC-7265 does not have that reconnect problem.
Both machines run W7.

EDIT:
This is what I had:
Control panel>Device manager>Network adapters>AC-7260>Properties>Power management>UNticked Allow the computer to turn off this device to save power
Control panel>Power options>Change plan settings>Change advanced power settings>Wireless adaptor settings>Power saving mode>Plugged in: Maximum performance

As an experiment, I have made another power settings change:
Control panel>Power options>Change plan settings>Change advanced power settings>PCI Express>Link state...>Plugged in: Off
This, because my AC-7260 is a PCIe card.
Let's see what happens.
Lovely day for a Guinness! (The Real Black Stuff)
But I actually prefer Murphy's from Cork!

sktn77a
Senior ThinkPadder
Senior ThinkPadder
Posts: 2056
Joined: Thu Apr 29, 2004 9:44 am
Location: Chapel Hill, NC

Re: Issue with Intel 6300 WiFi card in my T430

#3 Post by sktn77a » Wed Feb 14, 2024 3:01 pm

Thanks RBS. Yes, I think you're right, it may be something to do with the power saving (although why it should only occur with one of the three cards, I don't know). I'll mess around with that and report back.
Keith
(Formerly 600E, T21, T30, T40, T41, 2xT42, 2xT61p, T420, 2x Ideapad K1)
(Currently 4xT430, 2xT460, H520S, M910q, M920q, M70q)

sktn77a
Senior ThinkPadder
Senior ThinkPadder
Posts: 2056
Joined: Thu Apr 29, 2004 9:44 am
Location: Chapel Hill, NC

Re: Issue with Intel 6300 WiFi card in my T430

#4 Post by sktn77a » Sun Mar 10, 2024 11:20 am

Well, changed some of those settings and it made a small difference but not really significant. Debating now whether to go back to one of the 2.4GHz cards.
Keith
(Formerly 600E, T21, T30, T40, T41, 2xT42, 2xT61p, T420, 2x Ideapad K1)
(Currently 4xT430, 2xT460, H520S, M910q, M920q, M70q)

TPFanatic
Senior ThinkPadder
Senior ThinkPadder
Posts: 2313
Joined: Thu Jul 30, 2015 11:29 pm
Location: Boston, Massachusetts

Re: Issue with Intel 6300 WiFi card in my T430

#5 Post by TPFanatic » Sun Mar 10, 2024 5:58 pm

A card malfunctioning or failing is within the realm of possibility. I've encountered some 5100 and 6205 acting up, replacing them is easy enough.

6205 and 6300 are very close in performance, sometimes I feel like the 6205 is superior as it is a newer generation than the 6300. 6205 replaced the short-lived 6200. 6300 was the last 3 antenna Intel card, it was hardly better than a 2 antenna anyway.

ZaZ
Moderator
Moderator
Posts: 4736
Joined: Fri May 13, 2005 1:33 pm
Location: Minnesota

Re: Issue with Intel 6300 WiFi card in my T430

#6 Post by ZaZ » Sun Mar 10, 2024 10:16 pm

Could try booting to Linux to see if it exhibits the same symptoms.
ThinkPad L14 - 2.1GHz Ryzen 4650U | 16GB | 256GB | 14" FHD | Win11P
ProBook 470 G5 - 1.6GHz Core i5 | 16GB | 2.2TB | 17" FHD | Mint

xiphmont
Junior Member
Junior Member
Posts: 303
Joined: Wed Apr 07, 2010 2:46 pm
Location: Jaffrey, NH
Contact:

Re: Issue with Intel 6300 WiFi card in my T430

#7 Post by xiphmont » Wed Apr 17, 2024 2:43 pm

The 6300 family is known to have a nasty firmware bug that Intel hasn't fixed (card was desupported long ago) and there's no fixing it in the software driver either. The 63xx has always been a dog.

Almost any other card, even older ones, are better choices as they'll actually work reliably and not cause random corruption. That third antenna isn't worth it.

SKA
Freshman Member
Posts: 116
Joined: Fri Dec 16, 2011 9:50 pm
Location: Bangkok, Thailand

Re: Issue with Intel 6300 WiFi card in my T430

#8 Post by SKA » Fri Apr 19, 2024 12:02 am

Hi !

Great to hear from you, Sir !

Can you recommend Atheros card for old Thinkpads like T61P, T/W500, T/W530, W700, W701 ?

Thanks
SKA

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 23932
Joined: Mon Sep 18, 2006 5:17 am
Location: Loch Garman, Éire

Re: Issue with Intel 6300 WiFi card in my T430

#9 Post by RealBlackStuff » Fri Apr 19, 2024 12:45 am

Atheros AR9380 a.k.a. AR5BXB112.
Lovely day for a Guinness! (The Real Black Stuff)
But I actually prefer Murphy's from Cork!

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T430-T490 / T530-T590 Series”

Who is online

Users browsing this forum: Heemag and 8 guests