Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

X230t beeps twice and blank screen

X230-X280, X390 Series
Post Reply
Message
Author
BannerMast
Posts: 2
Joined: Sat Feb 11, 2023 10:12 am
Location: Shanghai, China

X230t beeps twice and blank screen

#1 Post by BannerMast » Sat Jan 27, 2024 3:18 am

Hello, while changing the screen of my x230t, I broke something, because now it won't boot properly at all. it still does the 1-3-3-1 beeps if I dont include any ram or cmos or anything else, but when I do include ram and connect to the charger the first time it beeps once and has a blank screen, with subsequent attempts getting two short beeps and the screen lights up to a blank when I retry without unplugging my x230t. I read that both single beep and double beep means that the motherboard is dead but I still want to cling onto hope. Furthermore, I found that the motherpoard still is responsive as when I press f1 it reacts with a beep and I can blindly change things. However the screen is still blank so idk anything I do. Im thinking of using an external monitor tomorrow to further test things, but are there any suggestions for what else I can do? the last thing I want is to replace the motherboard as i7 motherboards for x230t are pretty expensive

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 23762
Joined: Mon Sep 18, 2006 5:17 am
Location: Loch Garman, Éire

Re: X230t beeps twice and blank screen

#2 Post by RealBlackStuff » Sat Jan 27, 2024 4:50 am

You possibly blew the backlight fuse.
Check both fuses F1 and F2 near the LCD connector on the motherboard.
They are both 3A/32V/Fast, such as ERBRD3R00X.
Measure with a multimeter for continuity.
Solder a new fuse on top of the old one is the easiest way.
Lovely day for a Guinness! (The Real Black Stuff)
Lenovo: X240, X250, T440p, T480, M900 Tiny.

PS: the old Boardroom website is still available on the Wayback Machine
.

BannerMast
Posts: 2
Joined: Sat Feb 11, 2023 10:12 am
Location: Shanghai, China

Re: X230t beeps twice and blank screen

#3 Post by BannerMast » Sat Jan 27, 2024 4:13 pm

RealBlackStuff wrote:
Sat Jan 27, 2024 4:50 am
You possibly blew the backlight fuse.
Check both fuses F1 and F2 near the LCD connector on the motherboard.
They are both 3A/32V/Fast, such as ERBRD3R00X.
Measure with a multimeter for continuity.
Solder a new fuse on top of the old one is the easiest way.
I don't have a multimeter, and I don't think my housing contract would allow me to solder at home, so I guess I'll have to ask a computer repair shop to check it out. I'll update when I can.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X230-X280 / X390 Series”

Who is online

Users browsing this forum: No registered users and 32 guests