Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

X230 Shuts down when changing video Driver from VGA/Intel device appears missing

X230 and later series specific matters only
Post Reply
Message
Author
niche
Posts: 15
Joined: Sat Feb 23, 2019 7:23 pm
Location: Egham, Surrey

X230 Shuts down when changing video Driver from VGA/Intel device appears missing

#1 Post by niche » Sat Feb 23, 2019 7:37 pm

Hi,

I have an X230 that I dropped breaking the case, so I got a new base unit and carefully moved everything across. It worked fine except when starting up the Thinkpad shut down when entering the "normal" video screen (Win 7 - so blue default).

After trying lots of different things (software) , I refreshed the OS using vanilla Win 7 on a spare drive and the install goes fine - I added all drivers and the device boots fine, until I add the Intel HD 4000 video driver. I noticed also that there is no "video hardware" in the device list needing the driver update - only the stock VGA adapter is displayed.

I've also tried a couple of Linux distros but they fail on setup - crashing out.

I'm guessing i'm somehow managed to damage the hardware but I can't see where/how.

Does anyone have any suggestions please?

Many thanks in advance for any pointers. The screen works fine in VGA, I can go to the highest resolution and all is fine -just slow refresh. I've swapped out the RAM as I know its shared . but still no difference.

thanks!

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 19806
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA
Contact:

Re: X230 Shuts down when changing video Driver from VGA/Intel device appears missing

#2 Post by RealBlackStuff » Sun Feb 24, 2019 8:11 am

Is that a "standard" or an FHD-upgraded machine?
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly! :mrgreen:
Check out The Boardroom for Parts, Mods and Other Services.

niche
Posts: 15
Joined: Sat Feb 23, 2019 7:23 pm
Location: Egham, Surrey

Re: X230 Shuts down when changing video Driver from VGA/Intel device appears missing

#3 Post by niche » Sun Feb 24, 2019 9:49 am

RealBlackStuff wrote:
Sun Feb 24, 2019 8:11 am
Is that a "standard" or an FHD-upgraded machine?
It's a standard one..

axur-delmeria
Senior ThinkPadder
Senior ThinkPadder
Posts: 2103
Joined: Mon May 28, 2012 5:49 am
Location: Metro Manila, Philippines

Re: X230 Shuts down when changing video Driver from VGA/Intel device appears missing

#4 Post by axur-delmeria » Sun Feb 24, 2019 10:40 am

Since you dropped it, there's a possibility that something broke in the system board.
Daily driver: X220 4291-C91 i7-2620M

Backup: X220 4291-P79 i5-2520M
Toy: X60F Core Solo U1300
In pieces: two retired but working X61Ts
RIP: 760XD 9546-U9E; X61 7676-A24; and a BOE-Hydis HV121P01-100 in failed SXGA+ mod
:cry:

niche
Posts: 15
Joined: Sat Feb 23, 2019 7:23 pm
Location: Egham, Surrey

Re: X230 Shuts down when changing video Driver from VGA/Intel device appears missing

#5 Post by niche » Sun Feb 24, 2019 10:43 am

No, sorry I should have been clearer. I just broke off the corner of the casing, the machine was fine after I dropped it..

axur-delmeria
Senior ThinkPadder
Senior ThinkPadder
Posts: 2103
Joined: Mon May 28, 2012 5:49 am
Location: Metro Manila, Philippines

Re: X230 Shuts down when changing video Driver from VGA/Intel device appears missing

#6 Post by axur-delmeria » Sun Feb 24, 2019 2:16 pm

Did you reapply thermal paste on the heatsink?
Daily driver: X220 4291-C91 i7-2620M

Backup: X220 4291-P79 i5-2520M
Toy: X60F Core Solo U1300
In pieces: two retired but working X61Ts
RIP: 760XD 9546-U9E; X61 7676-A24; and a BOE-Hydis HV121P01-100 in failed SXGA+ mod
:cry:

niche
Posts: 15
Joined: Sat Feb 23, 2019 7:23 pm
Location: Egham, Surrey

Re: X230 Shuts down when changing video Driver from VGA/Intel device appears missing

#7 Post by niche » Sun Feb 24, 2019 4:06 pm

Not yet, but it runs for hours on VGA without issue. 10 seconds on the HD driver and it dies immediately. I think its a hardware fault of some time sadly.. weird one.

niche
Posts: 15
Joined: Sat Feb 23, 2019 7:23 pm
Location: Egham, Surrey

Re: X230 Shuts down when changing video Driver from VGA/Intel device appears missing

#8 Post by niche » Wed Feb 27, 2019 11:35 am

OK, so for anyone interested I bought a replacement motherboard and all is 100% fine again. Seems it was a fault in the GPU which was only fixable with a new board.
X230 working 100% again.

VGA only motherboard now for sale ;-)

thanks all

axur-delmeria
Senior ThinkPadder
Senior ThinkPadder
Posts: 2103
Joined: Mon May 28, 2012 5:49 am
Location: Metro Manila, Philippines

Re: X230 Shuts down when changing video Driver from VGA/Intel device appears missing

#9 Post by axur-delmeria » Wed Feb 27, 2019 1:10 pm

Note that in the X230, the GPU is part of the processor itself, so this means it's a processor issue. :cry:
Daily driver: X220 4291-C91 i7-2620M

Backup: X220 4291-P79 i5-2520M
Toy: X60F Core Solo U1300
In pieces: two retired but working X61Ts
RIP: 760XD 9546-U9E; X61 7676-A24; and a BOE-Hydis HV121P01-100 in failed SXGA+ mod
:cry:

niche
Posts: 15
Joined: Sat Feb 23, 2019 7:23 pm
Location: Egham, Surrey

Re: X230 Shuts down when changing video Driver from VGA/Intel device appears missing

#10 Post by niche » Wed Feb 27, 2019 2:04 pm

Yes, exactly. Very odd, given everything else works 100%..prob why despite posting on various forums and threads I drew blanks!

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X230 and later Series”

Who is online

Users browsing this forum: No registered users and 4 guests