Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

x270 w/Win 10 has performance lag on battery

X230 and later series specific matters only
Post Reply
Message
Author
CharacterFlaw3
Posts: 1
Joined: Tue Jun 18, 2019 2:21 pm
Location: Baltimore, MD USA

x270 w/Win 10 has performance lag on battery

#1 Post by CharacterFlaw3 » Tue Jun 18, 2019 2:24 pm

Hi, thx for reading. I purchased a used X270 with what I thought were reasonable expectations about performance since I was upgrading from an X230T. It's an i7 (7th gen) with a 256gb SSD and 8gb of RAM.

I did a clean install of Win 10, like you do, and have been configuring all the bits to my liking while the OS whirs in the background indexing and updating and all that other BS. I'm accustomed to slowdowns in this period of ownership, but after continuing performance issues I'm afraid this time is different.
No matter what I do every time the device is on battery things bog down. Screens take a few seconds to load, the cursor will occasionally hang, and--perhaps worst of all--registering keystrokes is significantly delayed in some programs. So far I've watched the CPU in the task manager to see if it spikes with the programs I'm using (Opera and journal writing software) but there's nothing to see. I've also left the laptop in the "high performance" power option but it doesn't matter. Battery power always slows everything up, some things worse than others.

Meanwhile in plug-land my keystrokes register immediately and everything is snappy like it should be (I mean, really, I'm not doing a lot here). Oddly, the effects of being plugged in will also last 30-40 seconds after I unplug until I'm slapped across the head with a baseball bat of sluggishness.

Can someone help me? To me this seems like a software issue, but I'm open to your expertise. Thanks.

dr_st
Moderator
Moderator
Posts: 8092
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: x270 w/Win 10 has performance lag on battery

#2 Post by dr_st » Tue Jun 18, 2019 11:37 pm

Welcome to the forum. :)

Make sure all the relevant Lenovo drivers, especially power management driver are installed. You can use Lenovo Vantage application to get those.

It is possible there is some hardware issue with the battery (batteries), but let's figure out the software side first.
Thinkpad 25 (20K7), X1 Carbon (20HQ), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

w0qj
ThinkPadder
ThinkPadder
Posts: 1018
Joined: Fri Jun 11, 2004 9:53 pm
Location: Hong Kong

Re: x270 w/Win 10 has performance lag on battery

#3 Post by w0qj » Thu Jun 20, 2019 7:49 am

Perhaps not exactly related, a user of a ASUS notebook computer reported that:
~Computer shuddering problems occurred after Win'10 1809 update
~After long discussion, the "Best Solution" is to stop the driver for wireless adapter (ASUS USB N66), which stopped the Win'10 shuddering
(Not sure if that is your X270 problem though)

http://forums.tomshardware.com/threads/ ... 09.3489853
Daily Driver: X1 Extreme 1st Gen (X1E1): i7 | 16GB | 1TB | IPS
Current Thinkpads: X1E1 | X1C4 | X1C3 | X250 | X230 | T410
Retired Thinkpads: T42 | 560 (circa 1996)
~~IBM Thinkpad era computer bag !

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X230 and later Series”

Who is online

Users browsing this forum: No registered users and 4 guests