Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

X230 HDD and Win-installation

X230 through X280, plus X390 series specific matters only
Post Reply
Message
Author
Adam-12
Posts: 5
Joined: Sun Feb 09, 2020 2:19 am
Location: Kassel, Germany

X230 HDD and Win-installation

#1 Post by Adam-12 » Sun Feb 09, 2020 3:03 am

Hi there,

as a long time Mac user some weeks ago I thought I wanted to give Linux a try and bought a used X230. Windows 7 was pre-installed on the hard drive and as I didn't want that to be ruined, I switched the hard drive for a 250GB SSD, installed Linux and had some fun with it. A couple of days ago I thought, now would be the time to have a look at Windows 7. So I switched the hard drives, back to the original one and when booting, an error came up: "2100: Detection error on HDD0 (Main HDD)". As I thought that was strange I plugged in the HDD onto my Mac as an external drive, but it wasn't recognised here too. So I figured, it was dead. There was a slight chance that I took the wrong HDD (I had another one from the same manufacturer with the same specs but in another box), but installing that into the X230 brought up the same error plus it showed up dead as an external HDD on my Mac too. So this was either a rare coincidence or the X230 is a HDD killer. When exchanging the hard drive I read about how to do it and always unplugged the battery from the X230. Also, I am used to that kind of activity, so I do want to rule out a wrong doing, although I am not familiar with Lenovo's laptops.

The next thing I did was to put back a SSD, which was recogniced by the laptop. So, it could have been the hard drives that accidentally failed both at the same time. I then thought about that the first SSD triggered something within the Thinkpad that caused a normal HDD to fail. I don't have any more HDDs of that size left to give it another try, though.

So, my first question would be: Did this happen to anyone before, is this a known problem, or really just bad luck? I found some tips here on that error message but don't think that cotton pads would solve my problem.

My next and main question would be how to bring back Windows onto the machine. I downloaded an ISO file of Windows 7 but am unable to build a bootable USB stick of it with my Mac. Is it possible to make a bootable Windows stick with Linux? I could re-install Linux on the SSD and then would do it that way. What Windows 7 version should I use? A 32 or 64 bit version? The X230 has a Windows 7 key on a sticker (Windows professional), does this help in selecting the correct version?

Thanks a lot for reading and any help!

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 20765
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: X230 HDD and Win-installation

#2 Post by RealBlackStuff » Sun Feb 09, 2020 3:37 am

Under Linux you can do this: https://www.romanzolotarev.com/openbsd/geteltorito.html
Under MacOS you can do this: https://epir.at/2013/03/10/modify-a-boo ... age-macos/

As for failing HDD in X230: it could be bad luck with both, or they are not inserted properly/deep enough.
But if they also fail in e.g. a USB-casing, then there is little hope for them.
You could also try an mSATA SSD in the WWAN-slot and install Linux there (remove the main drive first).

As for W7, put in 64-bit, the X230 can have up to 16GB RAM.
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.

"Computers don't lie, but liars can compute." (Terry Hayes)

Adam-12
Posts: 5
Joined: Sun Feb 09, 2020 2:19 am
Location: Kassel, Germany

Re: X230 HDD and Win-installation

#3 Post by Adam-12 » Sun Feb 09, 2020 5:29 am

Thanks RealBlackStuff!

It seems that it should be enough to just format an USB stick and copy the files from the Windows ISO onto it. I'll give that a try and am at the moment in the process of updating the Linux that I just installed on the SSD. I didn't understand the MacOS idea from your link, so I will go the Linux way.

Both hard drives were quite old, so I am not angry about losing them. But I am a bit concerned about why both failed at the same time. Years ago I lost two hard drives because of a faulty electric circuit of an old house electricity system and I hope it was just pure coincidence.

I'll let you know how it turned out!

Adam-12
Posts: 5
Joined: Sun Feb 09, 2020 2:19 am
Location: Kassel, Germany

Re: X230 HDD and Win-installation

#4 Post by Adam-12 » Sun Feb 09, 2020 11:11 am

Could get the Laptop back to Windows 7 via Linux. It wasn't as easy as I thought, as one would need a tool to make a bootable USB stick under Linux. I followed a few leads and the one app that worked for me was woeusb in combination with gparted.

So now I have two partitions on the Laptop, one with Linux and one with Windows 7. I do have problems with Windows :( . It just won't show any network, no wifi nor etehrnet network. So I'm grounded. But the rest works fine. Looking into the network problem is something for next week though. Linux has no trouble finding and using the network hardware of the Lenovo.

Thanks again!

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X230-X280 / X390 Series”

Who is online

Users browsing this forum: No registered users and 9 guests