Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

X240 touchpad swap not working, I've tried everything

X230 through X280, plus X390 series specific matters only
Post Reply
Message
Author
daddyozai
Posts: 1
Joined: Fri Sep 25, 2020 9:13 am
Location: Plano, Texas

X240 touchpad swap not working, I've tried everything

#1 Post by daddyozai » Fri Sep 25, 2020 9:33 am

I've got an x240 I'm trying to swap the clunkpad out of, for an x250 touchpad. The touchpad simply will not be recognized by the motherboard. I've tried swapping out the cable, and that did nothing. I've tried multiple touchpads to test for a problem with the initial one i tested, nothing. Which would indicate that there's something wrong with the motherboard, except for the fact that I have the original clunkpad, and the clunkpad still works -and besides, there's no board damage. It's like the thinkpad is permanently only allowed to use this trackpad. It is on the newest bios, perhaps there's a Lenovo-lockdown problem? And yes, I've tried everything. I've tried resetting the bios (however I know possible - yanking the dime battery), holding down the button in the top left corner of the motherboard....I'm at a loss for what's wrong.

Anyone ran into this before?

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X230-X280 / X390 Series”

Who is online

Users browsing this forum: No registered users and 17 guests