Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

W530 and Windows 8: Bluetooth not running

W530/W540/W541/W550 Series
Post Reply
Message
Author
bendamon
Posts: 4
Joined: Sat Oct 27, 2012 8:38 am
Location: Hamburg, Germany

W530 and Windows 8: Bluetooth not running

#1 Post by bendamon » Sat Oct 27, 2012 8:46 am

Hi,

I have various issues after installing Windows 8 Pro 64 (clean install) on my W530.

Aside from the device Manager showing 4 unknown devices, I by all means cannot get Bluetooth working. Neither BT devices nor the BT Adapter itself is detected. When I try to install the latest Windows 8 "ThinkPad Bluetooth Enhance Data Rate Software", setup will quit stating there's no BT adapter.

Fn+F5 doesn't work either (nothing happens), even though I have the hotkey Feature installed. Bluetooth is enabled in the BIOS.

Any ideas?

Thanks!
Ben

Neil
Senior ThinkPadder
Senior ThinkPadder
Posts: 3030
Joined: Sun Aug 07, 2005 5:41 pm
Location: Paragould AR USA

Re: W530 and Windows 8: Bluetooth not running

#2 Post by Neil » Sat Oct 27, 2012 8:55 am

Either install and run System Update for Win8, or manually install the missing device drivers.
Collection = T430 - T500 - R400 - X300 - T61 (14" WXGA+) - R61 (15" SXGA+) - T60 - X40 - T43p - T43 - T42p - A30P

bendamon
Posts: 4
Joined: Sat Oct 27, 2012 8:38 am
Location: Hamburg, Germany

Re: W530 and Windows 8: Bluetooth not running

#3 Post by bendamon » Sat Oct 27, 2012 8:57 am

Hi,

of course, I already did all that. Lenovo System Update won't find anything new, and the BT Driver cannot be installed, see my post.

Neil
Senior ThinkPadder
Senior ThinkPadder
Posts: 3030
Joined: Sun Aug 07, 2005 5:41 pm
Location: Paragould AR USA

Re: W530 and Windows 8: Bluetooth not running

#4 Post by Neil » Sat Oct 27, 2012 12:37 pm

I thought your original post said you couldn't install "ThinkPad Bluetooth Enhance Data Rate Software". I figured the reason the software wouldn't install is because drivers were missing. After re-reading the original post...that still seems to be the case.

Does the bluetooth device show up in device manager? If not, it's probably because it is one of the 4 unknown devices for which you need to install drivers.
Collection = T430 - T500 - R400 - X300 - T61 (14" WXGA+) - R61 (15" SXGA+) - T60 - X40 - T43p - T43 - T42p - A30P

bendamon
Posts: 4
Joined: Sat Oct 27, 2012 8:38 am
Location: Hamburg, Germany

Re: W530 and Windows 8: Bluetooth not running

#5 Post by bendamon » Sat Oct 27, 2012 2:27 pm

(Still unsolved):

Hi Neil,

I thought that the software mentioned above actually would include the drivers. I cannot find any other drivers in the "Bluetooth" section of the Lenovo W530 drivers page. Any idea what I need to install?

UPDATE:

Well. It seems that the "ThinkPad Enhanced.... Software" does indeed include the BT Drivers (and still can't be installed). I tried to download and install the "Broadcom Bluetooth 4.0 Driver" (even though listed for other models, see http://support.lenovo.com/en_US/downloa ... D=DS031759), and the setup and failure is the same.

Neil
Senior ThinkPadder
Senior ThinkPadder
Posts: 3030
Joined: Sun Aug 07, 2005 5:41 pm
Location: Paragould AR USA

Re: W530 and Windows 8: Bluetooth not running

#6 Post by Neil » Sat Oct 27, 2012 8:03 pm

Did follow closely the 12 installation steps in the Readme file associated with the driver in your link?
Collection = T430 - T500 - R400 - X300 - T61 (14" WXGA+) - R61 (15" SXGA+) - T60 - X40 - T43p - T43 - T42p - A30P

bendamon
Posts: 4
Joined: Sat Oct 27, 2012 8:38 am
Location: Hamburg, Germany

Re: W530 and Windows 8: Bluetooth not running

#7 Post by bendamon » Sun Oct 28, 2012 2:22 am

Hi,

yes I did. After all, they just explain how to download the file and start a setup. It's not that kind of problem. It must have something to do with the fact that also Fn+F5 is not working. Somehow, on a hardware level, Bluetooth seems not be "powered on" or something (even though it is in the BIOS), and so the driver setup doesn't find the BT Adapter.

silviuk
Posts: 1
Joined: Sun Dec 30, 2012 12:38 pm
Location: Bucharest, Romania

Re: W530 and Windows 8: Bluetooth not running

#8 Post by silviuk » Sun Dec 30, 2012 12:46 pm

Hello,

I have registered just to post the solution to this problem, if anyone is still interested.

1. Create a bootable USB stick with Ubuntu Desktop 32 or 64 bits (say 12.10 or the latest). I suggest using LiLi USB Creatorhttp://www.linuxliveusb.com, it takes care of everything (5-10 minutes).
2. Boot from the newly created USB stick. Choose "Try Ubuntu" when asked.
3. Go to the upper right corner and click the user icon. Choose "System Settings". A Control Panel-like window appears.
4. No go to "Bluetooth" and enable it by dragging the slider to the ON position (until it lightens up).
5. Reboot you computer into your Windows 8 installation and install the Lenovo Bluetooth drivers (I recommend ThinkVantage Update, but you can also download it from the Lenovo website).

That's all. Good luck!

SirVerissimo
Posts: 6
Joined: Tue Oct 14, 2008 6:00 pm
Location: Lisbon, Portugal

Re: W530 and Windows 8: Bluetooth not running

#9 Post by SirVerissimo » Sat Mar 23, 2013 6:40 am

Thank you very much for the workaround.

I had the exact same problem with a Thinkpad Edge 15 and now windows 8 has found my bluetooth device.

Thanks again.

Caleb9
Posts: 1
Joined: Sun Feb 09, 2014 6:46 am
Location: Horsens, DK

Re: W530 and Windows 8: Bluetooth not running

#10 Post by Caleb9 » Sun Feb 09, 2014 6:48 am

This workaround doesn't work anymore with Ubuntu 13.10. The ON/OFF switch keeps snapping back to OFF. Use Ubuntu 12.10 to make it work.

sdapkniht
Posts: 1
Joined: Sat Jul 12, 2014 12:12 am
Location: moscow, russia

Re: W530 and Windows 8: Bluetooth not running

#11 Post by sdapkniht » Sat Jul 12, 2014 12:39 am

I confirm that the silviuk's ubuntu 12.10 solution fixed the bluetooth problem on Lenovo B590, windows 8 64bit.
I hadn't been able to turn the bluetooth switch on in PC settings, wireless. It was switching back to off every time.
I installed new Broadcom Bluetooth 4.0 driver from Lenovo site, but that didn't help, and the bluetooth switch became grayed.
I deleted the broadcom bluetooth device from device manager, cold rebooted, and the device didn't appear in the device manager after that. The bluetooth switch disappeared too.
I made a bootable stick with Ubuntu 12.10 LiveCD iso, rebooted into Ubuntu, turned bluetooth on (it did find my other devices), rebooted into windows 8, and the device was in the device manager, as an unknown device.
I updated its driver and after a reboot the bluetooth switch was working and I could see my mobile devices.

lele007
Posts: 1
Joined: Mon Sep 21, 2015 9:16 am
Location: Lagos, Nigeria

Re: W530 and Windows 8: Bluetooth not running

#12 Post by lele007 » Mon Sep 21, 2015 9:26 am

Hello silviuk,

You registered on this forum just to suggest a solution, well I registered just to thank you.

I'm not a computer person, but because of your simple explanation, I followed all the steps and my Bluetooth on a T61 laptop is back! Whoever thought a lawyer could learn how to boot linux from a flash drive to reset his wireless radio, all in one morning? Phew! :banana:

Thanks to all for your priceless and free help.

Now, to flash my BIOS with the middleton update...

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 21841
Joined: Mon Sep 18, 2006 5:17 am
Location: Wexford, Éire
Contact:

Re: W530 and Windows 8: Bluetooth not running

#13 Post by RealBlackStuff » Mon Sep 21, 2015 10:26 am

Welcome to the Forum.
Nice to hear you got it going!
For Middleton's BIOS, go here: http://ali.dj/blog/sata-ii-support-for- ... 61-x61-r61
Their links are regularly updated! (the original links are mostly dead...)
Still NOT a great day for a Guinness! (the Real Black Stuff).
Ireland is on FULL lockdown until Easter 2021!
Covid-19: Stay safe, so Mask it or Casket!

gregui
Posts: 1
Joined: Mon Feb 22, 2021 9:50 am
Location: France / Paris

Re: W530 and Windows 8: Bluetooth not running

#14 Post by gregui » Mon Feb 22, 2021 9:56 am

Hi all,
I hadn't registered yet and did so in order to say a BIG "thanks" to silviuk. After lots of hours messing around with Thinkpad drivers and utilities, it is the only workaround that brought me back my bluetooth in operation.
I still miss a functional fn-F5 key, to be able to choose which radio activate and when, but at least, I can use BT.
Cheers !
Gregui

silviuk wrote:
Sun Dec 30, 2012 12:46 pm
Hello,

I have registered just to post the solution to this problem, if anyone is still interested.

1. Create a bootable USB stick with Ubuntu Desktop 32 or 64 bits (say 12.10 or the latest). I suggest using LiLi USB Creatorhttp://www.linuxliveusb.com, it takes care of everything (5-10 minutes).
2. Boot from the newly created USB stick. Choose "Try Ubuntu" when asked.
3. Go to the upper right corner and click the user icon. Choose "System Settings". A Control Panel-like window appears.
4. No go to "Bluetooth" and enable it by dragging the slider to the ON position (until it lightens up).
5. Reboot you computer into your Windows 8 installation and install the Lenovo Bluetooth drivers (I recommend ThinkVantage Update, but you can also download it from the Lenovo website).

That's all. Good luck!

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad W530/W540/W541/W550 Series”

Who is online

Users browsing this forum: No registered users and 4 guests