Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

W530 Black Screens on Boot

W530/W540/W550 series specific matters only
Post Reply
Posts: 28
Joined: Wed May 23, 2018 1:45 pm
Location: Providence, RI

W530 Black Screens on Boot

#1 Post by ThinkTwinki » Tue Aug 21, 2018 9:00 am

This is a continuation of the ordeal found in my last thread.

Part 2:
The Scoop:
Ordered what looks like to be a K1000 motherboard with the assurance it works. After receiving it and giving it a look over, it looks to be good. I then swapped it into the case and moved all of the internals over (CMOS, speakers, CPU, etc.) to the new motherboard. The laptop boots, but it's a black screen with no other indicators, i.e no error beeps. However, the laptop boots and the fans spin, before abruptly stopping. Audio control LEDs and keyboard light both light up for a second.

The Specs:
  • Model: ???
  • Motherboard: ???
  • Intel Core i7-3740QM (Quad Core)
  • NVidia Quadro K1000M (???)
  • 1600x900 HD+
  • ??? SO-DIMM Slots
The Problem:
On AC power, the laptop fans spin-up, and all of the LEDs and lights flicker. No BIOS or boot screen ever shows up. The power button will continue to glow if it's not shut-off or its power disconnected.

What I've Tried:
  • The RAM modules I've tested worked on the old motherboard and work on other laptops
  • Repasting with Grizzly Kryonaut, and firmly pressing the heatsink down onto the CPU and GPU, while screwing it back in has made no difference
  • Both caddies (HDD and CD tray) contain two working secondary memory drives, with working bootloaders and OSes (SSD + HDD, Windows and Linux respectively). Adding a third liveUSB into the mix does nothing either
  • Boot outcomes don't change if RAM isn't present: no error codes. Motherboard contains two different types of RAM module slots
  • Disconnecting CMOS, WLAN card, keyboard, palmrest, speakers doesn't change boot outcomes
My Guesses:
  1. Damaged wires:
    All of the unplugging could've damaged some wires. The display cable looks exceptionally gnarly underneath its plastic sheath, but it was like that when I got this machine
  2. Incompatible CPU:
    Since the motherboard is likely a K1000 model, it likely doesn't support quad-channel RAM. This might also include what CPUs it can support, i.e transplanting a K2000-specific CPU to a K1000 board might not work
  3. Incompatible USB Module:
    I've transplanted my K2000's always-on, rear USB into the new likely K1000 motherboard. It's possible it's not compatible. Considering this new motherboard also doesn't accept the old motherboard's SD card spring mechanism
  4. Improper reconnection:
    It's possible I've improperly reconnected all the internal cables. Or that there's something special about the screws in the display cable and I used the wrong ones
Note: If anyone's interested in a malfunctioning W530 K2000M board, with its BIOS chips removed, and two pairs of W530 BIOS chips, let me know. They're yours if you pay for shipping

Post Reply
  • Similar Topics
    Last post

Return to “ThinkPad W530/W540/W550 Series”

Who is online

Users browsing this forum: No registered users and 2 guests