Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Win10 upgrade failed on both my X40 and T43p?

Windows 10 on Lenovo hardware
Post Reply
Message
Author
Pan-optical
Posts: 13
Joined: Sun Feb 18, 2018 4:32 pm
Location: Berlin, Germany

Win10 upgrade failed on both my X40 and T43p?

#1 Post by Pan-optical » Mon Jul 30, 2018 12:50 pm

Both are running Win7 and I wanted to find the oldest TP that can support Win10. Both have Pentium-M Dothan CPUs and more than 1GB RAM which is enough for Win10 32bit. The upgrader ran fine, downloaded all files, ran all checks, installed Win10 and started it, but both crashed BSOD when booting Win10. It did automatically revert back to the old install of Win7 without a second attempt (pretty seamless).

T43p: 2GB RAM, Pentium-M Dothan
https://ark.intel.com/products/27597/In ... 33-MHz-FSB

X40: 1.5GB RAM, Pentium-M Dothan
https://ark.intel.com/products/27604/In ... 00-MHz-FSB

Win10 require some CPU features (Intel eXecute Disable XD) , but Dothan is supposed to have these unlike the earlier Banias core.
https://www.zdnet.com/article/windows-1 ... to-run-it/

Any ideas?

MikalE
ThinkPadder
ThinkPadder
Posts: 1026
Joined: Sun Sep 13, 2015 9:51 pm
Location: Marissa, Illinois

Re: Win10 upgrade failed on both my X40 and T43p?

#2 Post by MikalE » Mon Jul 30, 2018 1:52 pm

The upgradeability of a device includes factors beyond the system specification. This includes driver and firmware support, application compatibility, and feature support, regardless of whether or not the device meets the minimum system specification for Windows 10.
T500 T9600 2055-BE9
T510 i5 4384-DV7
T510 i7 4349-A64
T520 i7 4242-4UU(CTO)


T520: i7-2760QM(2.40GHz),16GB, 500GB SSD/250GB SSD, 1600x900, 1GB NVIDIA, DVDRW, Smartcard, media card, FPR, Win7 Pro64, XP Pro64 whitelist BIOS, N 6300 AGN, German KB, BT 4.0.

Hans Gruber
Senior Member
Senior Member
Posts: 815
Joined: Thu Sep 29, 2005 6:18 am
Location: Seattle, WA

Re: Win10 upgrade failed on both my X40 and T43p?

#3 Post by Hans Gruber » Mon Jul 30, 2018 2:41 pm

Most likely the video display capabilities of a T43p and x40 were not near enough for Win10.
:beer: T43p,T61,X200,X200s,x201,T500,W500,T510,T410,T410s,T420s,T430,T430s :parrot:

Pan-optical
Posts: 13
Joined: Sun Feb 18, 2018 4:32 pm
Location: Berlin, Germany

Re: Win10 upgrade failed on both my X40 and T43p?

#4 Post by Pan-optical » Mon Jul 30, 2018 4:02 pm

Shouldn't the compatibility test catch all these potential problems?

jdrou
Senior Member
Senior Member
Posts: 656
Joined: Tue Feb 10, 2009 6:15 pm
Location: Madison Heights, MI

Re: Win10 upgrade failed on both my X40 and T43p?

#5 Post by jdrou » Mon Jul 30, 2018 4:32 pm

Pan-optical wrote:
Mon Jul 30, 2018 12:50 pm
Win10 require some CPU features (Intel eXecute Disable XD) , but Dothan is supposed to have these unlike the earlier Banias core.
Not ALL Dothan (although yours do seem to have it). Older Dothan chips don't have NX/XD (e.g. the 745 in my T42).

I'd expect the T43p at least to work since others report it working on T43:
viewtopic.php?f=73&t=118518&p=803040&hilit=t43#p803040
Looks like you may need to use a modded display driver though.
Current Thinkpads:
X31, X40, X61T, X61, X201, X220 (i7 IPS), W520 (2720QM/2000M/FHD), T440p (i7-4800MQ/GF730GT/FHD),
T480 (i7-8650U/GF150MX/QHD)
Dells: Latitude C840, Precision M70, Precision M4400, M6400 (WUXGA), M6600, M6700, Dell XPS 13 w/Kaby Lake+Iris Pro+TB3
Daily driver: T480

kfzhu1229
ThinkPadder
ThinkPadder
Posts: 1256
Joined: Tue Sep 22, 2015 10:59 pm
Location: Toronto, Canada

Re: Win10 upgrade failed on both my X40 and T43p?

#6 Post by kfzhu1229 » Wed Aug 01, 2018 12:20 am

Pan-optical wrote:
Mon Jul 30, 2018 4:02 pm
Shouldn't the compatibility test catch all these potential problems?
For my experience of Windows 10 on my T43 and T43p's, I have far better experience with Anniversary edition than any other version. Previous versions are more buggy and less baked, while later versions have terrible support to DirectX 9.0/9.0b display adapters.
And yes, I also found out that the new April version of Windows 10 end up with a BSoD on my T43 and T43p computers. I will investigate in the cause when I have time.
Meanwhile, I have two Pentium 4 systems that I have tried the April version on. Dell Dimension E510 (P4 640, 3.5GB RAM, Radeon HD 5450) and OptiPlex GX520 (P4 650, 3GB RAM, Radeon HD 8570), and both work just fine just like the previous versions.
_________________________________
T23 PIII 1.13ghz 1gb W7
T43 15" 1.86 XGA 2gb fp W7
T530i 15.6" i7 16gb fp W10
Flexview UXGA:
A30p PIII 1.2 1gb W7 (IDTech)
T43p 2.26 2gb fp W10

Pan-optical
Posts: 13
Joined: Sun Feb 18, 2018 4:32 pm
Location: Berlin, Germany

Re: Win10 upgrade failed on both my X40 and T43p?

#7 Post by Pan-optical » Wed Aug 01, 2018 10:08 am

kfzhu1229 wrote:
Wed Aug 01, 2018 12:20 am
Pan-optical wrote:
Mon Jul 30, 2018 4:02 pm
Shouldn't the compatibility test catch all these potential problems?
For my experience of Windows 10 on my T43 and T43p's, I have far better experience with Anniversary edition than any other version. Previous versions are more buggy and less baked, while later versions have terrible support to DirectX 9.0/9.0b display adapters.
And yes, I also found out that the new April version of Windows 10 end up with a BSoD on my T43 and T43p computers. I will investigate in the cause when I have time.
Meanwhile, I have two Pentium 4 systems that I have tried the April version on. Dell Dimension E510 (P4 640, 3.5GB RAM, Radeon HD 5450) and OptiPlex GX520 (P4 650, 3GB RAM, Radeon HD 8570), and both work just fine just like the previous versions.
This is very interesting, is there any way for me to get and older version of Win10 (pre Anniversary) as a boot image or DVD?

kfzhu1229
ThinkPadder
ThinkPadder
Posts: 1256
Joined: Tue Sep 22, 2015 10:59 pm
Location: Toronto, Canada

Re: Win10 upgrade failed on both my X40 and T43p?

#8 Post by kfzhu1229 » Thu Aug 02, 2018 12:22 am

Pan-optical wrote:
Wed Aug 01, 2018 10:08 am
This is very interesting, is there any way for me to get and older version of Win10 (pre Anniversary) as a boot image or DVD?
As I said, Anniversary version is the best version for a T43 or T43p or R52 with ATI graphics. Previous versions lack features such as Infrared support and floppy disk support, all of which are nice to have on such a machine that support both.
If you want the anniversary version, I think I can try to find the iso file that I used, or I can just image my personal working version of Windows 10 Anniversary version straight from my T43 and then do a factory reset to get rid of all my files and accounts, while having all of the drivers ready to go for a T43.
Unfortunately, the free upgrade for users with assistive technologies program had ended, so if you want Windows 10 on your T43 and X41, you have to get a product key yourself (I have Windows 10 Pro as they came from Windows 7 Ultimate upgrades and Windows 10 preview rewards).
Honestly, installing a fresh copy of anniversary edition is not easy because there are so much stuff that you need to connect to the internet with windows update on to complete, yet you have to keep a keen eye on the activity to see whether it is attempting to upgrade or not. Also, the drivers don't work optimally ootb, they require tweaking to get to the optimal performance and convenience. Those tweakings are nowhere to be found online, and I have to do them by my 3 year experience with Windows 10 on a T43 (Yes, I have been running Windows 10 on one of my T43 computers ever since the April 2015 previews)
_________________________________
T23 PIII 1.13ghz 1gb W7
T43 15" 1.86 XGA 2gb fp W7
T530i 15.6" i7 16gb fp W10
Flexview UXGA:
A30p PIII 1.2 1gb W7 (IDTech)
T43p 2.26 2gb fp W10

Dolphin
Posts: 2
Joined: Sat May 04, 2019 9:23 pm
Location: HongKong

Re: Win10 upgrade failed on both my X40 and T43p?

#9 Post by Dolphin » Sat May 04, 2019 9:53 pm

HI!
Win10 (1709) works reasonably well on the T43 (15", ATI, mSATA SSD@PATA adapter, no fingerprint sensor)
Same experience though:
Failed with BSOD ("IRQL_NOT_LESS_OR_EQUAL") when attempting to upgrade to 1803 or 1809

I reckon some driver issues:
Tried to completely deactivate automatic driver updates as well as to unenable devices one-by-one via the device manager ...
No success so far ...

Cheers!
Last edited by Dolphin on Sat May 11, 2019 7:47 pm, edited 2 times in total.

kfzhu1229
ThinkPadder
ThinkPadder
Posts: 1256
Joined: Tue Sep 22, 2015 10:59 pm
Location: Toronto, Canada

Re: Win10 upgrade failed on both my X40 and T43p?

#10 Post by kfzhu1229 » Sun May 05, 2019 5:59 pm

Dolphin wrote:
Sat May 04, 2019 9:53 pm
HI!
Win10 (1709) works reasonably well on the T43 (15", ATI, mSATA SSD@PATA adapter, no fingerprint sensor)
Same experience though:
Failed with BSOD ("IRQL_NOT_LESS_OR_EQUAL") when attempting to upgrade to 1803 or 1809

I reckon some driver issues:
Tried to completely deactivate automatic driver updates as well as to unenable devices one-by-one via the device manager ...
No success so far ...

Cheers!
How did you get 1709 working well on the T43? I have 15" T43p and 14.1" T43 (X300) and both have trouble playing back video with anything newer than 1607 (Media player classic and VLC player plays slideshow no matter what settings I use, and the stock video player app doesn't work well)
As for the newer versions than that, even running the setup off the bootable DVD will create BSoD on those machines, so I don't think there is anything you can do.
_________________________________
T23 PIII 1.13ghz 1gb W7
T43 15" 1.86 XGA 2gb fp W7
T530i 15.6" i7 16gb fp W10
Flexview UXGA:
A30p PIII 1.2 1gb W7 (IDTech)
T43p 2.26 2gb fp W10

Dolphin
Posts: 2
Joined: Sat May 04, 2019 9:23 pm
Location: HongKong

Re: Win10 upgrade failed on both my X40 and T43p?

#11 Post by Dolphin » Sat May 11, 2019 7:39 pm

Hi!

I just started up the T43 and double-checked Settings>system>About:
Edition: Win10 Pro
Version: 1709
Build: 16299.1087

Unfortunately, I don't remember what I did exactly one year ago.
Basically, I started by upgrading from Win7 and ended up with the MS MediaCreationTool to setup an USB-stick.

For what is worth, the T43 is a Model 2687-DDU and the device manager shows MS Basic Display Adapter.
Win10 runs on both PATA HDD and mSATA SSD@PATA adapter (the one from Japan as mentioned in forum)

With 1803 and 1809 I tried both update via Internet connection as well as from USB, but failed.
When I have more time, I will try to install from scratch again.

Cheers!


Edit: sorry, I don't use the T43 for video playback, so cannot tell; I was referring to the general responsiveness of the Win10 on the T43

kfzhu1229
ThinkPadder
ThinkPadder
Posts: 1256
Joined: Tue Sep 22, 2015 10:59 pm
Location: Toronto, Canada

Re: Win10 upgrade failed on both my X40 and T43p?

#12 Post by kfzhu1229 » Sat May 11, 2019 9:37 pm

Dolphin wrote:
Sat May 11, 2019 7:39 pm
Edit: sorry, I don't use the T43 for video playback, so cannot tell; I was referring to the general responsiveness of the Win10 on the T43
Well I also tried 1703 and 1709 before on my T43 with X300 graphics and both works just like 1607 in many ways. But, on top of being unable to play videos, it also refused to run the DirectX 7, 8, 9/b games that worked with 1607 just fine. And from the time I had 1703 and 1709, both felt noticeably slower than 1607, all while Windows Update is also a bit harder to turn off in those versions (you have to, otherwise it is gonna try install the newer versions, bluescreen, rolls back, and then cycles again), all that combined are the reasons why I am still sticking with 1607
_________________________________
T23 PIII 1.13ghz 1gb W7
T43 15" 1.86 XGA 2gb fp W7
T530i 15.6" i7 16gb fp W10
Flexview UXGA:
A30p PIII 1.2 1gb W7 (IDTech)
T43p 2.26 2gb fp W10

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “Windows 10”

Who is online

Users browsing this forum: No registered users and 7 guests