Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

W10: FIX for Chrome/Chromium based browsers black screen after switch to discrete graphics in BIOS

Windows 10 on Lenovo hardware
Post Reply
Message
Author
calypso
Posts: 1
Joined: Wed Dec 11, 2019 3:30 pm
Location: Zagreb, Croatia

W10: FIX for Chrome/Chromium based browsers black screen after switch to discrete graphics in BIOS

#1 Post by calypso » Wed Dec 11, 2019 3:42 pm

Hi all,

just solved a big problem with my Lenovo P51 so decided to share my findings as I couldn't find anything similar on the web (been browsing for the past few days).

Problem
Chrome or Chromium based browsers (eg. Opera) might start with black screen after you disable onboard graphics in BIOS (switch from hybrid to discrete mode). Browsers will react to right click and show the menu, but nothing will be visible on the screen. If you run the browser with HW acceleration disabled, everything works fine, but Youtube videos become laggy.

Reason why this is happening
Frankly said - I have no idea, but I suspect it has something to do with which GPU is used when you start Chromium based browsers for the first time as they seem to store this data somewhere and then make problems if you disable the original graphics card. When I browser internet and forums, I found that lots of people had this problem when they simply switched graphics cards, even on desktop computers.

Solution (for Google Chrome)
1. Go to C:\Users\<YOUR USER ACCOUNT>\AppData\Local\Google\Chrome\User Data
2. Rename folder 'ShaderCache' to something else (eg. $ShaderCache, _ShaderCache)
3. Inside the same Google Chrome User Data Go to profile folder (usually called 'Profile 1', 'Profile 2', etc)
4. Rename folder 'GPUCache' to something else (eg. $GPUCache, _GPUCache)
5. Start the browser (remember to remove --disable-gpu switch in case you used it)

Solution (for Opera)
1. Go to C:\Users\<YOUR USER ACCOUNT>\AppData\Roaming\Opera Software\Opera Stable
2. Rename folder 'ShaderCache' to something else (eg. $ShaderCache, _ShaderCache)
3. Rename folder 'GPUCache' to something else (eg. $GPUCache, _GPUCache)
4. Rename folder 'VideoDecodeStats' to something else (eg. $VideoDecodeStats, _VideoDecodeStats)
5. Start the browser (remember to remove --disable-gpu switch in case you used it)


I hope this will help Thinkpad users. Note that this solved the problem I had on my P51 after I disabled hybrid graphics in BIOS.



Note to moderators: in case I posted in the wrong part of the forum, please move the post to the correct place.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “Windows 10”

Who is online

Users browsing this forum: No registered users and 7 guests