Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Solved: TrackPoint excruciatingly slow

T25-Retro specific matters only
Post Reply
Cookie Guru
Posts: 14
Joined: Sun Aug 21, 2011 3:42 am
Location: Seattle, WA

Solved: TrackPoint excruciatingly slow

#1 Post by Cookie Guru » Fri Oct 26, 2018 11:02 pm


I have my TrackPoint settings set to be really fast. However the TrackPoint feels like it's at the slowest setting.

I also have a ThinkPad Compact USB Keyboard (FRU 03X8715) that I use with this laptop while docked. The USB keyboard respects the speed settings.

No idea where "Evaluation Copy" comes from; I'm using the drivers that came with the Win10 install. Not sure if it matters but I have the TouchPad disabled in the BIOS.

What causes this and/or how can I fix it?
Last edited by Cookie Guru on Sat Nov 03, 2018 4:40 pm, edited 1 time in total.

Posts: 7494
Joined: Sat Oct 29, 2005 6:20 am

Re: TrackPoint excruciatingly slow

#2 Post by dr_st » Sat Oct 27, 2018 1:50 am

I haven't tried disabling the touchpad on the Thinkpad 25, because I actually like it. You can try re-enabling it to see if it has any effect (shouldn't, but perhaps there is a bug in the software).

Also, try to rule out physical problems with the touchpad. Is the cap fully/correctly attached? Is it intact? I started experiencing problems (sluggish trackpoint movement) after using the TP25 for a few months, and it turned out that the trackpoint cap got ripped on one side, so it was not making good contact with the actual joystick underneath.
Thinkpad 25 (20K7), X1 Carbon (20HQ), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG, X61 7673-V2V
T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

Junior Member
Junior Member
Posts: 495
Joined: Mon Oct 28, 2013 5:48 am
Location: Perth Aus / Thailand

Re: TrackPoint excruciatingly slow

#3 Post by shawross » Sun Oct 28, 2018 10:34 pm

You could try Linux from a USB drive to see if it an OS or hardware problem.

Active --- Love the X series
X301 SU9400 IDA Mod - W 7 / X201 540M - W 7 / X220 2520 - W7

X61 T7500 / T41 T42 T43 / A31

Rogue daily driver - Samsung RV511 15.6 " Screen - W 7

Senior Member
Senior Member
Posts: 755
Joined: Fri Jun 11, 2004 9:53 pm
Location: Hong Kong

Re: TrackPoint excruciatingly slow

#4 Post by w0qj » Mon Oct 29, 2018 7:15 am

The OP said he is using Win10 on his T25-Retro (circa 2017), and has excruciatingly slow TrackPoint, despite cranking up the TrackPoint mouse speed to fastest.

I also had such a problem on my X1 Carbon Generation 4 (circa 2016), again excruciatingly slow TrackPoint, despite cranking up the TrackPoint mouse speed to fastest (for both Win7 64-bit and Win10 64-bit).
ThinkPad may have used a new supplier for the TrackPoint red rubber tip for my X1C4; its red rubber tip was far too soft, and actually became seriously deformed over my 2 years of use (abuse). In the end, the TrackPoint was hammered flat (no dimples, top crown shape was flattened to a flat pancake shape).
This "too soft" rubber tip also seriously slowed down my TrackPoint speed, I believe.
Even ThinkPad service department commented that my TrackPoint red tip looked "different".

Anyways, I recently switched to another new TrackPoint red tip with a noticeably harder rubber texture (but normal texture), and lo and behold, the TrackPoint speed was up to the normal snappy/fast speed that I've been accustomed to for the past 20+ years. I love my TrackPoint on my X1C4 now! ymmv.
Daily Driver: X1 Carbon 4th Gen (X1C4): i7 | 16GB | 1TB | IPS WQHD | LTE WWAN | Win7 Pro
Current Thinkpads: X1C4 | X1C3 | X250 | X230 | T410
Retired Thinkpads: T42 | 560 (circa 1996)
~~IBM Thinkpad era computer bag !

Cookie Guru
Posts: 14
Joined: Sun Aug 21, 2011 3:42 am
Location: Seattle, WA

Re: TrackPoint excruciatingly slow

#5 Post by Cookie Guru » Sat Nov 03, 2018 4:40 pm

Linux live CD was a great suggestion. I booted in there and set the sensitivity to a reasonable value and all worked great, so clearly this was a driver issue in Windows.

It looks like there was a driver update that was forced upon me earlier this year that caused this. The solution was to uninstall the existing Synaptics drivers and install the latest ones directly from Lenovo. "Programs and Features" (appwiz.cpl) wasn't any help as nothing from Synaptics was found there, but there's a command to bring up the uninstaller:

Code: Select all

rundll32.exe "C:\Program Files\Synaptics\SynTP\SynISDLL.dll",standAloneUninstall
Blocking driver installation is possible: Control Panel > System > Advanced system settings > Hardware tab > Device Installation Settings, but that will disable driver installs for all hardware which is probably not advisable for most situations. But there is Stop Windows from installing drivers for specific devices.

Post Reply
  • Similar Topics
    Last post

Return to “Thinkpad T25-Retro”

Who is online

Users browsing this forum: No registered users and 2 guests