Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

X62 problems, quirks, and fixes

Old(er) Thinkpads with New(er) Intestines: X62 / T50 / T70 / etc.
Message
Author
bitonic
Posts: 16
Joined: Fri Nov 10, 2017 11:54 am
Location: Rome, Italy

Re: X62 problems, quirks, and fixes

#151 Post by bitonic » Tue Nov 21, 2017 3:41 am

vavet,

I've added a comment explaining the values: https://github.com/bitonic/x62-fancontr ... rol.c#L155 . I still don't really know what they _mean_, but that's the effect they have on the fan speed.

Given the PWM terminology one would think that the fan speed regulates the pulse width modulation frequency, but there are a few jumps in the 0-255 range and even in the range where the change is smooth it does not seem to change the fan speed linearly

bitonic
Posts: 16
Joined: Fri Nov 10, 2017 11:54 am
Location: Rome, Italy

Re: X62 problems, quirks, and fixes

#152 Post by bitonic » Tue Nov 21, 2017 4:01 am

now onto the next problem: the fan emits a very high frequency vibration at low speeds (which i'm hearing for the first time since it was always at high speed before)

wujstefan
Senior Member
Senior Member
Posts: 583
Joined: Fri Mar 04, 2011 8:38 am
Location: Tarnow, Poland

Re: X62 problems, quirks, and fixes

#153 Post by wujstefan » Wed Dec 13, 2017 11:18 am

Other than that:

Battery charge and discharge times are a bit... say, they go mad sometimes. I've installed BatteryBar and it worked just fine with both charging and sicharging times... for two days :) then I needed to reinstall it to make sure what is the exact working time and how long would the system stay alive, and still it jumps every 5 seconds to different value, ranging from 3,5hrs to 8hrs on fresh battery (update every 5 seconds).

Is there any reasonable way to create own powerplan on those systems in W7? I guess you can't change voltage on i5 without changing the clock, but a good utility would be nice in here.
Dailies:
T601f, X61sfL - work
HP Elitebook 8740w - multimedia
R61f - wife
R61f - kids
Collectibles:
T43, Z60t, G41, R30, R50e
Under construction:
A31, 600X, R52p, T22, A22m, R40, T30

NonesensE
Sophomore Member
Posts: 134
Joined: Mon May 29, 2017 6:28 am
Location: GF/BS/OHA, Germany

Re: X62 problems, quirks, and fixes

#154 Post by NonesensE » Wed Dec 13, 2017 3:21 pm

wujstefan wrote:
Wed Dec 13, 2017 11:18 am
I guess you can't change voltage on i5 without changing the clock, but a good utility would be nice in here.
You can set a voltage offset (read: undervolt) the X62 with Intel XTU or ThrottleStop (I recommend the latter: Less processor usage, built-in C-state check window which you need anyway for configuring the X62 to save power).
Sometimes coming over from the German forum...
X62s 3rd batch, [s]T61[/s] T70 14" 4:3 1st batch

flyingfishfinger
Junior Member
Junior Member
Posts: 267
Joined: Sun Nov 18, 2012 5:42 pm
Location: San Francisco Bay Area

Re: X62 problems, quirks, and fixes

#155 Post by flyingfishfinger » Wed Dec 27, 2017 7:35 am

Hi,
Fan control issues here.
Has anyone figured out what the numbers mean in the config file that go along with the Windows fan utility that was posted?
I can't quite figure out how it transitions from one state to another, and additionally it seems to go into states that aren't in the file sometimes (as indicated by the scrolling command line output).

It mostly seems to work for about 10 seconds, then the fan goes silent. Does this have anything to do with how the system cooling policy is set?

I was trying to transcode some video and I ended up with a thermal shutdown...

Rafael

wujstefan
Senior Member
Senior Member
Posts: 583
Joined: Fri Mar 04, 2011 8:38 am
Location: Tarnow, Poland

Re: X62 problems, quirks, and fixes

#156 Post by wujstefan » Tue Jan 02, 2018 3:44 am

Hello Rafael,

I'm fighting pretty similar issue here for some time and it seems that the fan behaviour depends on many variables.

There are 4 values in the text file:
a,b,c,d
[up temperature], [down temperature], [fan speed - PWM modulation], [NULL]
up is when to start this speed
down is when to drop to the previous line
fan speed is in 0-100 range (actually did not try more)

When working w/W7 this thing did not work for me, at all. It worked for - say - 30 seconds, and then the fan started living its own way. No matter what I put in there. fullstop.

However, when I installed W10 it actually started working... the opposite. Figuring the numbers in the default thermal table it seems that the lowest fan speed should be there for "100", and the highest one for "1" - and it worked this way for W7 (for a very limited amount of time, however). On windows 10, while on A/C, it works the opposite - highest fan speed is set at "100", and lowest at "1".

I was happy when I found the solution until I switched to battery. Now the nasty thing is living completely on its own; floating between max and min speeds of the fan all the time when the .exe file is on. Another thing is that the temp monitor is unable to execute from W10 autostart (while all the other apps do not have this limitation).

Still fighting. Will let you know when I make it.

EDIT: OK, it works, and it works perfectly. Maybe the only thing I'm missing is sething this app in startup, but this does not seem to work at all. All I did was a BIOS update and W10 update.
Dailies:
T601f, X61sfL - work
HP Elitebook 8740w - multimedia
R61f - wife
R61f - kids
Collectibles:
T43, Z60t, G41, R30, R50e
Under construction:
A31, 600X, R52p, T22, A22m, R40, T30

wujstefan
Senior Member
Senior Member
Posts: 583
Joined: Fri Mar 04, 2011 8:38 am
Location: Tarnow, Poland

Re: X62 problems, quirks, and fixes

#157 Post by wujstefan » Mon Jan 08, 2018 5:36 am

Another thing: have no idea if this has been already mentioned, but "BatteryBar" app gives true charge/discharge rates under Windows.
Dailies:
T601f, X61sfL - work
HP Elitebook 8740w - multimedia
R61f - wife
R61f - kids
Collectibles:
T43, Z60t, G41, R30, R50e
Under construction:
A31, 600X, R52p, T22, A22m, R40, T30

ktron1
Posts: 2
Joined: Sat Jan 20, 2018 6:27 am
Location: Espoo, Finland

Re: X62 problems, quirks, and fixes

#158 Post by ktron1 » Sat Jan 20, 2018 6:48 am

Has anyone managed to update the Intel CPU microcode on an x62?

I'm suspecting that the microcode updates from Intel check the CPU version, and as the x62 has an ES (Engineering Sample) CPU, it will not update.

There are of course other reasons to update the microcode, but patching the Spectre variant 1 vulnerability (https://spectreattack.com/) is my main concern. And we have probably not seen the last of these kind of CPU vulnerabilities that need a microcode fix..

vavet
Sophomore Member
Posts: 193
Joined: Mon Apr 15, 2013 8:32 am
Location: Geneva, Switzerland

Re: X62 problems, quirks, and fixes

#159 Post by vavet » Wed Feb 28, 2018 2:18 pm

HI,
does anyone know if there are new BIOS versions available for x62?
I have tried all those fitting 2nd batch from https://forum.51nb.com/forum.php?mod=vi ... id=1791568

I am using 10/12. The problem with this version is that it keeps the fan up most of the time, so I have to use the temp monitor tool. I have managed to make it run in the bg with auto resume (stop/start) at computer suspend/resume. the only problem is that the Temp Monitor seem to start misbehaving when some inadequate temp readings appear. The solution can be either a more error tolerant version of the tool (with delayed reaction on temp reading jumps) or a better bios version

Another issue is the low emitted noise from fan when it spins slowly. I am using the maglev fan which emits less noise but still can be annoying. My fan configuration skips these speeds that emit noise, but nevertheless the fan jumps to these speeds due to these wrong temp readings ( I suppose).

Any insights on those issues are welcome.
X61 (T9300, 8gb RAM, 120gb SSD, LED SXGA+, integrated webcam, invisible touchpad, modded battery etc.)

SynbiosVyse
Posts: 15
Joined: Sun Mar 19, 2017 1:06 pm
Location: Washington, DC

Re: X62 problems, quirks, and fixes

#160 Post by SynbiosVyse » Sun Apr 01, 2018 12:05 pm

Bibin wrote:
Thu Nov 24, 2016 4:13 pm
I got my MiniDP working with a VGA adapter. Neither a MiniDP to HDMI nor MiniDP to DVI adapter would work, though. On the bright side, the VGA one was fully cooperative, and hotplugged without issues.
This was also my experience. I tried a mDP adapter to combo VGA/HDMI/DP and it didn't work. The small adapter that goes from mDP to VGA works fine. My mini-HDMI to full HDMI adapter also does not work, and is annoyingly loose. I'm pretty disappointed with the video output options on this thing. They are a deal breaker for someone on the move which is what the X series is geared for in the first place. I wish they just left the VGA port at this point since it's the only thing that works anyways.

Anyone have any other luck?

mDP -> VGA/HDMI/DP -> doesn't work
mDP -> VGA only -> works
mini-HDMI - > HDMI -> doesn't work

This is the one that is working for me:
https://www.staples.com/Staples-6-Mini- ... ct_2094888
Have used and owned many thinkpads.
Daily driver: X62s
  • Lid: X60 with SXGA+ IPS
  • Bottom: X61s
  • Motherboard: X62

NonesensE
Sophomore Member
Posts: 134
Joined: Mon May 29, 2017 6:28 am
Location: GF/BS/OHA, Germany

Re: X62 problems, quirks, and fixes

#161 Post by NonesensE » Tue Apr 03, 2018 10:19 am

AFAIK, the mDP doesn't support DP's HDMI/DVI alternative mode. There are, however, active adapters that decode the DP signal and encode it as HDMI. These should work, but I haven't tried yet.
Sometimes coming over from the German forum...
X62s 3rd batch, [s]T61[/s] T70 14" 4:3 1st batch

SynbiosVyse
Posts: 15
Joined: Sun Mar 19, 2017 1:06 pm
Location: Washington, DC

Re: X62 problems, quirks, and fixes

#162 Post by SynbiosVyse » Wed Apr 04, 2018 8:10 am

NonesensE wrote:
Tue Apr 03, 2018 10:19 am
AFAIK, the mDP doesn't support DP's HDMI/DVI alternative mode. There are, however, active adapters that decode the DP signal and encode it as HDMI. These should work, but I haven't tried yet.
That certainly sounds like the issue.

Regarding the mini-HDMI port, has anyone gotten it to work? I'm not sure what brand mine is but all it is is a direct mini-HDMI to HDMI port and is very loose and isn't detected at all.
Have used and owned many thinkpads.
Daily driver: X62s
  • Lid: X60 with SXGA+ IPS
  • Bottom: X61s
  • Motherboard: X62

NonesensE
Sophomore Member
Posts: 134
Joined: Mon May 29, 2017 6:28 am
Location: GF/BS/OHA, Germany

Re: X62 problems, quirks, and fixes

#163 Post by NonesensE » Wed Apr 04, 2018 12:50 pm

SynbiosVyse wrote:
Wed Apr 04, 2018 8:10 am
NonesensE wrote:
Tue Apr 03, 2018 10:19 am
AFAIK, the mDP doesn't support DP's HDMI/DVI alternative mode. There are, however, active adapters that decode the DP signal and encode it as HDMI. These should work, but I haven't tried yet.
That certainly sounds like the issue.

Regarding the mini-HDMI port, has anyone gotten it to work? I'm not sure what brand mine is but all it is is a direct mini-HDMI to HDMI port and is very loose and isn't detected at all.
I have used a HDMI screen via a mini-HDMI to HDMI cable at work, worked fine. Don't know the brand, though.
Sometimes coming over from the German forum...
X62s 3rd batch, [s]T61[/s] T70 14" 4:3 1st batch

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “51nb and other modded Thinkpads”

Who is online

Users browsing this forum: No registered users and 4 guests