Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

X330 / 51nb backlight issue

Old(er) Thinkpads with New(er) Intestines: X62 / T50 / T70 / etc.
Post Reply
Message
Author
thott
Posts: 11
Joined: Thu Apr 05, 2018 1:25 pm
Location: Elsdorf, Germany

X330 / 51nb backlight issue

#1 Post by thott » Sun Oct 28, 2018 3:34 pm

I'm a proud owner of the X330 with the 13.3" AUO B133HAN04.6. While this is overall working perfectly recently it started to disconnect the USB backlight every now and then.

When this happens the display goes blank for a few hundred milliseconds and I can see this in my system logs.

Code: Select all

[19193.632037] usb 3-3: USB disconnect, device number 35
[19193.944187] usb 3-3: new full-speed USB device number 36 using xhci_hcd
[19194.125219] usb 3-3: New USB device found, idVendor=10c4, idProduct=83ce
[19194.125221] usb 3-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[19194.125222] usb 3-3: Product: X230
[19194.125223] usb 3-3: Manufacturer: AGAN
[19194.126567] hid-generic 0003:10C4:83CE.0023: hiddev0,hidraw0: USB HID v1.01 Device [AGAN X230] on usb-0000:00:14.0-3/input0
I could not find any pattern for these disconnects, they happen randomly, not connected to system load or movement or any other programs from all I can tell.

Can someone give me any advise on what to look for and how to fix it? I would be ok with disabling the brightness control and somehow soldering static to the brightest setting if that's a possibility.

thott
Posts: 11
Joined: Thu Apr 05, 2018 1:25 pm
Location: Elsdorf, Germany

Re: X330 / 51nb backlight issue

#2 Post by thott » Wed Nov 21, 2018 5:15 am

Sadly I could still not find any solution. Here are a few things I tried
- Blacklisting the usb driver modules
- Disabling usb3 in bios
- Disabling the port using

Code: Select all

echo "0" > "/sys/bus/usb/devices/usbX/power/autosuspend_delay_ms"
echo "auto" > "/sys/bus/usb/devices/usbX/power/control"
- resoldering all connections of my mod

At this point I'm at a loss and wondering what I should try next - does anyone else have this mod and maybe an idea on how to fix or work-around this issue:
https://item.taobao.com/item.htm?spm=20 ... 3863861510

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 19500
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA
Contact:

Re: X330 / 51nb backlight issue

#3 Post by RealBlackStuff » Wed Nov 21, 2018 6:13 am

Backlight is not USB-controlled.
Could it be the SSD on that front-corner PCB?
Lovely day for a Guinness! (The Real Black Stuff)

Check out The Boardroom for Parts, Mods and Other Services.

thott
Posts: 11
Joined: Thu Apr 05, 2018 1:25 pm
Location: Elsdorf, Germany

Re: X330 / 51nb backlight issue

#4 Post by thott » Wed Nov 21, 2018 5:53 pm

Based on all I can say it's the usb device that I can also use to read the brightness of the backlight. I have nothing connected to the mSATA port at this point.

axur-delmeria
Senior ThinkPadder
Senior ThinkPadder
Posts: 2000
Joined: Mon May 28, 2012 5:49 am
Location: Metro Manila, Philippines

Re: X330 / 51nb backlight issue

#5 Post by axur-delmeria » Thu Nov 22, 2018 12:23 am

Oh, it has one of those 1080p kits with a USB-connected backlight controller?
Daily driver: X220 4291-C91 i7-2620M

Backup: X220 4291-P79 i5-2520M
Toy: X60F Core Solo U1300
In pieces: two retired but working X61Ts
RIP: 760XD 9546-U9E; X61 7676-A24; and a BOE-Hydis HV121P01-100 in failed SXGA+ mod
:cry:

thott
Posts: 11
Joined: Thu Apr 05, 2018 1:25 pm
Location: Elsdorf, Germany

Re: X330 / 51nb backlight issue

#6 Post by thott » Thu Nov 22, 2018 6:42 am

Yes, I can read the backlight state using a script like this https://gist.github.com/tott/753d44545b ... 4314b2490b
However, I could not find any way to disable this device. I also could not figure out what exactly is causing the reset. The only thing I can tell for sure is that whenever this device reset happens the display goes blank for a fraction of a second.

axur-delmeria
Senior ThinkPadder
Senior ThinkPadder
Posts: 2000
Joined: Mon May 28, 2012 5:49 am
Location: Metro Manila, Philippines

Re: X330 / 51nb backlight issue

#7 Post by axur-delmeria » Thu Nov 22, 2018 9:35 am

thott wrote:
Thu Nov 22, 2018 6:42 am
Yes, I can read the backlight state using a script like this https://gist.github.com/tott/753d44545b ... 4314b2490b
However, I could not find any way to disable this device. I also could not figure out what exactly is causing the reset. The only thing I can tell for sure is that whenever this device reset happens the display goes blank for a fraction of a second.
I'm thinking maybe there's an issue with the board itself, or the soldering is dodgy.
Daily driver: X220 4291-C91 i7-2620M

Backup: X220 4291-P79 i5-2520M
Toy: X60F Core Solo U1300
In pieces: two retired but working X61Ts
RIP: 760XD 9546-U9E; X61 7676-A24; and a BOE-Hydis HV121P01-100 in failed SXGA+ mod
:cry:

thott
Posts: 11
Joined: Thu Apr 05, 2018 1:25 pm
Location: Elsdorf, Germany

Re: X330 / 51nb backlight issue

#8 Post by thott » Thu Nov 22, 2018 10:52 am

This was also my thought and I already redid all the solder points. Sadly, no luck. Was really hoping someone else ran into this already :/

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “51nb and other modded Thinkpads”

Who is online

Users browsing this forum: No registered users and 3 guests