Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

51nb's X62: latest update

Old(er) Thinkpads with New(er) Intestines: X62 / T50 / T70 / etc.
Post Reply
Message
Author
flyingfishfinger
Junior Member
Junior Member
Posts: 270
Joined: Sun Nov 18, 2012 5:42 pm
Location: San Francisco Bay Area

Re: 51nb's X62: latest update

#181 Post by flyingfishfinger » Mon Oct 31, 2016 1:54 pm

walrustahiti wrote: Please, please, please, be quick to post photos and review when you get'em!
See my other thread for at least some of the requested information, feel free to add questions if you have them!

R

zoob
Posts: 12
Joined: Tue Dec 18, 2012 7:44 am
Location: Toronto, Canada
Contact:

Re: 51nb's X62: latest update

#182 Post by zoob » Wed Nov 02, 2016 6:14 pm

My X62 arrived today via DHL. The USB ports are properly placed, but the headphone and mic jack are kind of googley-eyed. It appears they used a lid with the WWAN antenna bulge on the right side. I haven't taken it out of the plastic wrap yet, but it looks like a super clean chassis with no sticker applied to the lid.

fatpolomanjr
Sophomore Member
Posts: 187
Joined: Wed Aug 11, 2010 2:11 pm
Location: Moreno Valley, CA USA
Contact:

Re: 51nb's X62: latest update

#183 Post by fatpolomanjr » Wed Nov 02, 2016 6:29 pm

Mine arrived yesterday. It is up and running Windows 10, but I haven't yet had time to test anything out. I still need to install the BIOS update, which I'll do tonight after work.
T70 | 15" UXGA LED with RealBlackStuff LED-Cable-Mod | i7-7700HQ | Windows 10
X62 | 12.1" SXGA+ Xiphmont LED | i7-5500U | Xubuntu / Windows 10
T61F | 14.1" SXGA+ Xiphmont LED | T9500 | Windows 10

flyingfishfinger
Junior Member
Junior Member
Posts: 270
Joined: Sun Nov 18, 2012 5:42 pm
Location: San Francisco Bay Area

Re: 51nb's X62: latest update

#184 Post by flyingfishfinger » Wed Nov 02, 2016 7:21 pm

BIOS update? Where to get it, and what does it do?

R

fatpolomanjr
Sophomore Member
Posts: 187
Joined: Wed Aug 11, 2010 2:11 pm
Location: Moreno Valley, CA USA
Contact:

Re: 51nb's X62: latest update

#185 Post by fatpolomanjr » Thu Nov 03, 2016 12:15 am

I was actually searching for it recently on the 51nb forums and couldn't find the post. All I found was a post from January from HOPE to upgrade the BIOS, but that was probably only for testers.
T70 | 15" UXGA LED with RealBlackStuff LED-Cable-Mod | i7-7700HQ | Windows 10
X62 | 12.1" SXGA+ Xiphmont LED | i7-5500U | Xubuntu / Windows 10
T61F | 14.1" SXGA+ Xiphmont LED | T9500 | Windows 10

zoob
Posts: 12
Joined: Tue Dec 18, 2012 7:44 am
Location: Toronto, Canada
Contact:

Re: 51nb's X62: latest update

#186 Post by zoob » Thu Nov 03, 2016 7:45 pm

Some quick pics

I received an i7-5500U board
Picked up my Crucial 2x8GB DDR3L-1866 RAM no problem.

http://imgur.com/a/zlFFf

fatpolomanjr
Sophomore Member
Posts: 187
Joined: Wed Aug 11, 2010 2:11 pm
Location: Moreno Valley, CA USA
Contact:

Re: 51nb's X62: latest update

#187 Post by fatpolomanjr » Thu Nov 03, 2016 9:23 pm

I have no audio. Did I make a wrong connection? From all the pictures of installing an X62 motherboard I've seen, the speaker should be plugged in to the farthest left of the connector on the motherboard. Are there driver issues or something I'm missing? Headphones are work fine.
T70 | 15" UXGA LED with RealBlackStuff LED-Cable-Mod | i7-7700HQ | Windows 10
X62 | 12.1" SXGA+ Xiphmont LED | i7-5500U | Xubuntu / Windows 10
T61F | 14.1" SXGA+ Xiphmont LED | T9500 | Windows 10

el-sahef
Sophomore Member
Posts: 129
Joined: Sat Mar 17, 2007 6:20 am
Location: Frankfurt, Germany

Re: 51nb's X62: latest update

#188 Post by el-sahef » Thu Nov 03, 2016 10:26 pm

You must install a driver for the internal audio to work. See this post: http://forum.thinkpads.com/viewtopic.ph ... 50#p788821
T70 15" 4:3 QXGA @ daylight LED, Core i7 7700HQ, 16 GB RAM, SSD
X62t, SXGA+ @ daylight LED,
T70 i5 WUXGA RGB-LED
600X @ Ivy Bridge Core i7 1,9 GHz

fatpolomanjr
Sophomore Member
Posts: 187
Joined: Wed Aug 11, 2010 2:11 pm
Location: Moreno Valley, CA USA
Contact:

Re: 51nb's X62: latest update

#189 Post by fatpolomanjr » Thu Nov 03, 2016 11:06 pm

Gosh dang it; thank you for that. I read that post a few days ago and didn't think to save the links or to download the drivers early.
T70 | 15" UXGA LED with RealBlackStuff LED-Cable-Mod | i7-7700HQ | Windows 10
X62 | 12.1" SXGA+ Xiphmont LED | i7-5500U | Xubuntu / Windows 10
T61F | 14.1" SXGA+ Xiphmont LED | T9500 | Windows 10

mdancer
Posts: 48
Joined: Sun Apr 18, 2010 12:24 pm
Location: Trieste, Italy

Re: 51nb's X62: latest update

#190 Post by mdancer » Fri Nov 04, 2016 3:45 pm

Has anyone tried to replace the thermal paste? CPU goes to 105C in a second under heavy load (3+ treads). However the performance is great to my taste https://browser.geekbench.com/v4/cpu/952931

fatpolomanjr
Sophomore Member
Posts: 187
Joined: Wed Aug 11, 2010 2:11 pm
Location: Moreno Valley, CA USA
Contact:

Re: 51nb's X62: latest update

#191 Post by fatpolomanjr » Fri Nov 04, 2016 7:34 pm

I was thinking about it, but decided to test it out as is before re-pasting. I haven't gotten any crazy temperature spikes, though I do notice that the battery is always between 8-15 mWh according to BatteryBar, which is a little high for Broadwell as far as I know. Do broadwell i7 ulv processors normally idle that high? My brightness is pretty low.
T70 | 15" UXGA LED with RealBlackStuff LED-Cable-Mod | i7-7700HQ | Windows 10
X62 | 12.1" SXGA+ Xiphmont LED | i7-5500U | Xubuntu / Windows 10
T61F | 14.1" SXGA+ Xiphmont LED | T9500 | Windows 10

RealBlackStuff
Admin
Admin
Posts: 19312
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA
Contact:

Re: 51nb's X62: latest update

#192 Post by RealBlackStuff » Sat Nov 05, 2016 6:15 am

With newer CPUs come newer thermal pastes.
Switch over from the old AS5 to Thermal Grizzly Hydronaut or Kryonaut (the very best).
See also this: http://overclocking.guide/thermal-paste ... gen-ln2/6/
Lovely day for a Guinness! (The Real Black Stuff)

Check out The Boardroom for Parts, Mods and Other Services.

mdancer
Posts: 48
Joined: Sun Apr 18, 2010 12:24 pm
Location: Trieste, Italy

Re: 51nb's X62: latest update

#193 Post by mdancer » Sat Nov 05, 2016 4:35 pm

Changing the thermal paste is must do. I have the drop in temperature from 105C to 83C under heavy load with my 3 year old AS5. Eager to try something newer.

fatpolomanjr
Sophomore Member
Posts: 187
Joined: Wed Aug 11, 2010 2:11 pm
Location: Moreno Valley, CA USA
Contact:

Re: 51nb's X62: latest update

#194 Post by fatpolomanjr » Sat Nov 05, 2016 6:36 pm

My core temps are a solid 38 deg C idle according to psensor in Xubuntu, and 41 deg C for overall idle temp. This is with the default paste. I'll buy some of the paste mentioned by RBS and apply it sometime.

The fan starts up for even the slightest temperature increase. Going to test out thinkfan and see if I can get it working; the sensors-detect command with lm-sensors picked up the Intel temperature sensors (coretemp), so I might be able to use those to regulate the fan.
T70 | 15" UXGA LED with RealBlackStuff LED-Cable-Mod | i7-7700HQ | Windows 10
X62 | 12.1" SXGA+ Xiphmont LED | i7-5500U | Xubuntu / Windows 10
T61F | 14.1" SXGA+ Xiphmont LED | T9500 | Windows 10

mdancer
Posts: 48
Joined: Sun Apr 18, 2010 12:24 pm
Location: Trieste, Italy

Re: 51nb's X62: latest update

#195 Post by mdancer » Sun Nov 06, 2016 2:46 am

fatpolomanjr wrote:Going to test out thinkfan and see if I can get it working.
The problem is that linux cannot find any PWM controller chip. The only thing which sensors-detect shows is

Trying family `National Semiconductor/ITE'... Yes
Found unknown chip with ID 0xfc11

It is probably isn't exported in BIOS properly, so one need to ask board developers about fan control possibility.

fatpolomanjr
Sophomore Member
Posts: 187
Joined: Wed Aug 11, 2010 2:11 pm
Location: Moreno Valley, CA USA
Contact:

Re: 51nb's X62: latest update

#196 Post by fatpolomanjr » Sun Nov 06, 2016 6:31 am

There is no thinkpad acpi device, which thinkfan relies on to read temperatures from. So thinkfan is out. If the fan cannot even be controlled then that is clearly a much larger issue.
T70 | 15" UXGA LED with RealBlackStuff LED-Cable-Mod | i7-7700HQ | Windows 10
X62 | 12.1" SXGA+ Xiphmont LED | i7-5500U | Xubuntu / Windows 10
T61F | 14.1" SXGA+ Xiphmont LED | T9500 | Windows 10

jaspen-meyer
Senior Member
Senior Member
Posts: 828
Joined: Wed May 19, 2010 11:21 pm
Location: Pardubice, Czech Republic
Contact:

Re: 51nb's X62: latest update

#197 Post by jaspen-meyer » Sun Nov 06, 2016 9:25 am

fatpolomanjr wrote:There is no thinkpad acpi device, which thinkfan relies on to read temperatures from. So thinkfan is out. If the fan cannot even be controlled then that is clearly a much larger issue.
The initial task is to turn off the fan from the command line.
Then, set fan levels.
Once those are achieved thinkfan's config file can be adjusted as needed: define temp input file, file for pwm values.

A few possible leads here:
In Debian is /usr/share/doc/thinkfan/examples/thinkfan.conf.complex
temp url: http://termbin.com/d4k2
T420 i7 3612QM seabios; T420 i7 3630QM; T400 Q9100 seabios; T61 P9600; T60 libreboot; x62; x60s libreboot, led; x24 xiphmont led

wileE
Sophomore Member
Posts: 204
Joined: Sun May 26, 2013 5:20 am
Location: Seligenstadt, Germany

Re: 51nb's X62: latest update

#198 Post by wileE » Sun Nov 06, 2016 10:49 am

X62 Tablet by el-sahef with working tablet buttons and wacom digitizer.
Link to german thread. Large pic warning!
Wacom rotation is unresolved, and that machine desperately needs a daylight LED kit.

TPFanatic
ThinkPadder
ThinkPadder
Posts: 1027
Joined: Thu Jul 30, 2015 11:29 pm
Location: Boston, Massachusetts

Re: 51nb's X62: latest update

#199 Post by TPFanatic » Sun Nov 06, 2016 11:31 am

It's beautiful. :cry: Everything about it. Bravo to el sahef, bravo to 51nb.
lenovo T61 T7500, SXGA+, 8GB
lenovo T410s i5 520m, WXGA+, 4GB
lenovo T430 i5 3320m, FHD, 8GB
lenovo T500 P9700, WUXGA, 8GB
lenovo T520 i7 2760QM, FHD, 8GB



Enable 2 finger scroll on any Synaptics touchpads with registry: http://forum.thinkpads.com/viewtopic.php?f=2&t=122612

mifritscher
Posts: 8
Joined: Sun Nov 06, 2016 7:01 pm
Location: Langen, Germany

Re: 51nb's X62: latest update

#200 Post by mifritscher » Sun Nov 06, 2016 7:09 pm

Hmpf, it seems I missed the second batch? Will there be a third - perhaps with some adaptions for x61 tablets? I would buy 5(!) at once.

Edit: I found the formular https://docs.google.com/forms/d/e/1FAIp ... 0465966000 and sent a submission. Was this the right way?

2th Edit: there is a 3th batch under http://forum.51nb.com/thread-1712790-1-1.html ! Lasts until 2016-11-10! Will there be an international shipping again?
Last edited by mifritscher on Mon Nov 07, 2016 2:40 am, edited 1 time in total.

zoob
Posts: 12
Joined: Tue Dec 18, 2012 7:44 am
Location: Toronto, Canada
Contact:

Re: 51nb's X62: latest update

#201 Post by zoob » Sun Nov 06, 2016 9:39 pm

I used an X61 for several years but with only an XGA screen. This SXGA+ panel is gorgeous.

E350
Sophomore Member
Posts: 215
Joined: Sat May 07, 2011 10:22 pm
Location: Sacramento, CA

Re: 51nb's X62: latest update

#202 Post by E350 » Sun Nov 06, 2016 10:22 pm

zoob why is your display different? Did you only buy only the motherboard or did you buy an entire machine with a display which is different than the typical x61 display (which I am looking at as I type)?

wileE I have an x61T tablet which I would like to upgrade as well, but is it the same upgrade or is it a different motherboard, etc. for x61T?

zoob
Posts: 12
Joined: Tue Dec 18, 2012 7:44 am
Location: Toronto, Canada
Contact:

Re: 51nb's X62: latest update

#203 Post by zoob » Sun Nov 06, 2016 10:39 pm

@E350 I bought the entire barebones unit (add my own RAM/SSD/Battery) since I figured they would be able to build it to fit better than I'd ever be able to :oops:

My X61 is an overclocked T7200, 2x4GB RAM, 1024x768 TN screen.

The only two things that I think would improve the X62 from 'stock' form would be:
- Mod heatsink with X200 maglev fan
- LED backlight mod (I would get an entirely new lid and screen so I don't mess this one up)

xiphmont
Junior Member
Junior Member
Posts: 301
Joined: Wed Apr 07, 2010 2:46 pm
Location: Jaffrey, NH
Contact:

Re: 51nb's X62: latest update

#204 Post by xiphmont » Mon Nov 07, 2016 12:10 am

I'm starting back up on my LED backlight kits-- I've been unable to get to making any for a few months, so I need to clear a backlog but hopefully I can get a few more out per week wit the new lab setup than I'd been managing before.

el-sahef
Sophomore Member
Posts: 129
Joined: Sat Mar 17, 2007 6:20 am
Location: Frankfurt, Germany

Re: 51nb's X62: latest update

#205 Post by el-sahef » Mon Nov 07, 2016 12:46 am

I am relieved to hear that :wink: . I absolutely need them for my QXGA screens and the X62 tablet. I get used to those kits, screens without them become suddenly almost unusuable.
T70 15" 4:3 QXGA @ daylight LED, Core i7 7700HQ, 16 GB RAM, SSD
X62t, SXGA+ @ daylight LED,
T70 i5 WUXGA RGB-LED
600X @ Ivy Bridge Core i7 1,9 GHz

fatpolomanjr
Sophomore Member
Posts: 187
Joined: Wed Aug 11, 2010 2:11 pm
Location: Moreno Valley, CA USA
Contact:

Re: 51nb's X62: latest update

#206 Post by fatpolomanjr » Mon Nov 07, 2016 2:06 am

jaspen-meyer wrote:The initial task is to turn off the fan from the command line.
Then, set fan levels.
Once those are achieved thinkfan's config file can be adjusted as needed: define temp input file, file for pwm values.

A few possible leads here:
In Debian is /usr/share/doc/thinkfan/examples/thinkfan.conf.complex
temp url: http://termbin.com/d4k2
This is going to be an adventure. Now I just realized audio isn't working for me in Xubuntu 16.04.1. Anyone else get audio in other distros? I tried installing the Linux version of the Realtek audio driver, but it expects you to compile from source, and I can't get past compilation errors. It probably has something to do with the kernel being 4.4 instead of 3.0. I did make some progress I think, in that I no longer have a "Dummy Device" through Pulse Audio. But still no sound through the onboard speakers. Headphones are fine.

I'll be testing and researching audio and fan control for the next few weeks...or until someone else gets it all figured out. Oh well; the fun is in the discovery and the learning.
T70 | 15" UXGA LED with RealBlackStuff LED-Cable-Mod | i7-7700HQ | Windows 10
X62 | 12.1" SXGA+ Xiphmont LED | i7-5500U | Xubuntu / Windows 10
T61F | 14.1" SXGA+ Xiphmont LED | T9500 | Windows 10

mdancer
Posts: 48
Joined: Sun Apr 18, 2010 12:24 pm
Location: Trieste, Italy

Re: 51nb's X62: latest update

#207 Post by mdancer » Mon Nov 07, 2016 4:36 am

fatpolomanjr, have you tried it in windows? I have the same problem with no sound from the speaker in Gentoo. I'm wondering if I supposed to connect it to the right two pins of audio output jack on the motherboard or to the left two?

fatpolomanjr
Sophomore Member
Posts: 187
Joined: Wed Aug 11, 2010 2:11 pm
Location: Moreno Valley, CA USA
Contact:

Re: 51nb's X62: latest update

#208 Post by fatpolomanjr » Mon Nov 07, 2016 5:10 am

It works fine in Windows, using the sound drivers posted above by el-sahef:

http://forum.thinkpads.com/viewtopic.ph ... 50#p788821

I have my speakers plugged into the far left of the connector, and it works for me in Windows. But from other pictures I've seen it plugged into the far right. I really hope to get audio working in Linux, since I like the trackpoint functionality much better than in Windows. And I feel more comfortable and knowledgeable editing config files in Linux to figure out how to control the fan than basically trying to recreate tpfancontrol for the X62. Not to mention the plethora of documentation. I'm going to test out Manjaro i3 (16.06.1)

In Linux I've adjusted trackpoint sensitivity and speed, and the middle point scroll works like the Lenovo ultranav drivers by default. It is so much better in Linux. If anyone knows of a better trackpoint driver than the default Windows 10 one I'm all ears. I really dislike the middle button trackpoint scrolling that has that circular wheel come up where you move the cursor to scroll. It is so inaccurate and doesn't work all the time.
Last edited by fatpolomanjr on Tue Nov 08, 2016 2:24 am, edited 2 times in total.
T70 | 15" UXGA LED with RealBlackStuff LED-Cable-Mod | i7-7700HQ | Windows 10
X62 | 12.1" SXGA+ Xiphmont LED | i7-5500U | Xubuntu / Windows 10
T61F | 14.1" SXGA+ Xiphmont LED | T9500 | Windows 10

Bibin
Senior Member
Senior Member
Posts: 509
Joined: Fri Mar 13, 2009 1:07 am
Location: Brooklyn, New York

Re: 51nb's X62: latest update

#209 Post by Bibin » Tue Nov 08, 2016 1:30 am

From a thread on 51nb, it looks like HV121P01-100 stock is running short, and de-bonding HV121P01-101 screens might be considered. I'm basing this on this thread: https://translate.google.com/translate? ... rev=search

Notably, the OP is the same person "Jacky" who is orchestrating many X62 orders for those in the US.
Give your T43/T43p/R52/X41 the SATA it deserves! http://mikejmoffitt.com/sata

fatpolomanjr
Sophomore Member
Posts: 187
Joined: Wed Aug 11, 2010 2:11 pm
Location: Moreno Valley, CA USA
Contact:

Re: 51nb's X62: latest update

#210 Post by fatpolomanjr » Tue Nov 08, 2016 4:00 am

I got decent drivers working in Windows 10! Now the sensitivity and speed are adjustable, and the middle scrolling works in ultranav fashion. You even get the Thinkpad logos and all. I just followed wile's post from December 2015. After extracting Lenovo synaptics drivers, simply update the mouse drivers manually (Have disk -> Lenovo -> Synaptics Drivers.)

The drivers I used were recommended by HOPE in a 51nb post from the beginning of October before release: Lenovo Trackpoint Drivers (I believe they are X220 drivers?)

Source:
51nb.com Windows 10 Install Guide
51nb.com Trackpoint Driver Installation

Little victories. I guess it was just a common Windows 10 issue. Still no audio in Linux using Manjaro i3 16.08 or Xubuntu 16.04.1, and no way to control fan via pwm.
T70 | 15" UXGA LED with RealBlackStuff LED-Cable-Mod | i7-7700HQ | Windows 10
X62 | 12.1" SXGA+ Xiphmont LED | i7-5500U | Xubuntu / Windows 10
T61F | 14.1" SXGA+ Xiphmont LED | T9500 | Windows 10

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “51nb and other modded Thinkpads”

Who is online

Users browsing this forum: No registered users and 3 guests