Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

thinkpad T70 - weird resume from suspend issue

Old(er) Thinkpads with New(er) Intestines: X62 / T50 / T70 / etc.
Post Reply
Message
Author
sona1111
Posts: 38
Joined: Mon Sep 17, 2012 10:27 pm
Location: Franklin Park, NJ

thinkpad T70 - weird resume from suspend issue

#1 Post by sona1111 » Wed Jul 19, 2017 11:00 am

Hello,

First of all, I have no idea if this is the right board or if one will be created in the future for these 'hacked' thinkpads. Please feel free to move the thread if needed.

Anyway I have recently ordered and installed the thinkpad T70 motherboard from 51nb in a standard thinkpad T60 (14"). Everything went pretty well and I have a running system. I plan to use ubuntu linux (16.04) as the primary operating system but I also have windows 7 available for debugging purposes.

The problem I am having is very strange - using ubuntu, I can suspend and resume correctly with the lid of the laptop open. Also, while the system is running, I can completely close and open the lid, and the system will keep running fine. (I disabled any actions from lid closing/opening in system settings). Now, the problem comes if I suspend the system (using the lid close, or Fn+F4, or the system 'syspend' menu option), and then close the lid (either partially or fully, just enough to trigger the lid switch), and them open it. If I do this, the system will start to come out of suspend and the screen will come on for just about one second, and then the system will completely shut off and lose power instantly (seemingly not a software issue). This is 100% reproducible, not intermittant. After the crash, the system will start without issue upon pressing the power button again. Again, I don't actually have to close the lid all the way, just enough that opening it will trigger the lid switch to resume.

I am thinking of just disabling the lid switch, unless one of you had another idea to try. does anyone know where it is connected or now to remove it? Also, I was going to attempt to reproduce it with windows, but I can not find a working display driver to try (so I get no 'suspend' option in windows - hd graphics 630 drivers say that system does not meet minimum requirements, other driver search tools do not seem to find anything).

Thanks for reading!

fatpolomanjr
Sophomore Member
Posts: 187
Joined: Wed Aug 11, 2010 2:11 pm
Location: Moreno Valley, CA USA
Contact:

Re: thinkpad T70 - weird resume from suspend issue

#2 Post by fatpolomanjr » Wed Jul 19, 2017 1:14 pm

Linux has always had weird suspend / sleep issues with closing the lid, especially with newer Linux kernels, and especially on newer hardware (cpu, chipset). What you're describing could probably be replicated by any 7th gen Intel processors in Ubuntu.
T70 | 15" UXGA LED with RealBlackStuff LED-Cable-Mod | i7-7700HQ | Windows 10
X62 | 12.1" SXGA+ Xiphmont LED | i7-5500U | Xubuntu / Windows 10
T61F | 14.1" SXGA+ Xiphmont LED | T9500 | Windows 10

sona1111
Posts: 38
Joined: Mon Sep 17, 2012 10:27 pm
Location: Franklin Park, NJ

Re: thinkpad T70 - weird resume from suspend issue

#3 Post by sona1111 » Wed Jul 19, 2017 5:01 pm

Hey, thanks for the reply.

I just now managed to get sleep on windows going by switching to windows 10. The same issue persists in the same manner while using windows. Please let me know if you are able to get a picture of the issue, or if a video would help more in explaining.

Thanks for reading

NonesensE
Sophomore Member
Posts: 137
Joined: Mon May 29, 2017 6:28 am
Location: GF/BS/OHA, Germany

Re: thinkpad T70 - weird resume from suspend issue

#4 Post by NonesensE » Thu Jul 20, 2017 6:51 am

Seems to be a bios related issue. A user on the German forum described the same behaviour (my board is not yet running). Either deactivate the switch or wait for a new bios version.
Sometimes coming over from the German forum...
X62s 3rd batch, [s]T61[/s] T70 14" 4:3 1st batch

sona1111
Posts: 38
Joined: Mon Sep 17, 2012 10:27 pm
Location: Franklin Park, NJ

Re: thinkpad T70 - weird resume from suspend issue

#5 Post by sona1111 » Thu Jul 20, 2017 8:34 am

Hey, thanks again.

I think I will just remove the magnet from the keyboard bezel for now - wake via lid switch is not that important to me.

Also, I can speak German better than Chinese, if you have a chance could you link to the thread that you mentioned?

Thanks,
-Paul

NonesensE
Sophomore Member
Posts: 137
Joined: Mon May 29, 2017 6:28 am
Location: GF/BS/OHA, Germany

Re: thinkpad T70 - weird resume from suspend issue

#6 Post by NonesensE » Thu Jul 20, 2017 4:45 pm

sona1111 wrote:
Thu Jul 20, 2017 8:34 am
Hey, thanks again.

I think I will just remove the magnet from the keyboard bezel for now - wake via lid switch is not that important to me.

Also, I can speak German better than Chinese, if you have a chance could you link to the thread that you mentioned?

Thanks,
-Paul
Here's the thread:
https://thinkpad-forum.de/threads/20780 ... otherboard
Starting with #13, the issue was discussed in a few posts.
Sometimes coming over from the German forum...
X62s 3rd batch, [s]T61[/s] T70 14" 4:3 1st batch

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “51nb and other modded Thinkpads”

Who is online

Users browsing this forum: No registered users and 2 guests