Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

X62: No Boot/BIOS/Splash Screen

Old(er) Thinkpads with New(er) Intestines: X62 / T50 / T70 / etc.
Post Reply
Posts: 1
Joined: Sat Dec 30, 2017 1:21 pm
Location: New York, NY

X62: No Boot/BIOS/Splash Screen

#1 Post by syntaxing » Sat Dec 30, 2017 5:15 pm

I am in the midst of installing a new fourth batch X62 motherboard. For the better or the worse, I also installed the SVGA+ and LED mod screen at the same time. However, when I turn on the computer, the fan spins for a split second and then nothing happens. The indicator lights seem like they are working but the RAM indicator lights does not seem to be flashing. I tried all the DDR3 RAM that I have on hand with different combinations on the slots and nothing works. No matter what I do, the screen remains black. I tried the newly installed screen with the old X61motherboard and Middleton BIOS and it works as expected. Does anyone here have any insight on what might be happening?


Junior Member
Junior Member
Posts: 275
Joined: Sun Nov 18, 2012 5:42 pm
Location: San Francisco Bay Area

Re: X62: No Boot/BIOS/Splash Screen

#2 Post by flyingfishfinger » Sun Dec 31, 2017 4:04 am

Got your PM, happy to send / post help with external Bios flashing.
Meanwhile, if you installed the new screen and backlight at the same time, I would first try disconnecting it completely (I.e remove lid and use an external screen) and see if you get further. If you have a short somewhere on the screen frame or with the LEDs, you could get such behavior.


EDIT: Sorry, just saw that you said it works on a regular X61 so the display is fine then. Try running with no display anyway, or try the X62 mobo with the original display. Change one variable at a time :)

Post Reply
  • Similar Topics
    Last post

Return to “51nb and other modded Thinkpads”

Who is online

Users browsing this forum: No registered users and 7 guests