Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

P50/Win7 memory-issue on login and first "safe as" (each app)

P1/P50/P70 and later specific matters only
Post Reply
Message
Author
jwege
Freshman Member
Posts: 104
Joined: Wed Nov 21, 2007 11:10 am
Location: Karlsruhe Germany

P50/Win7 memory-issue on login and first "safe as" (each app)

#1 Post by jwege » Wed May 29, 2019 11:16 am

Hi all,

I hope that someone can help me with two odd issues that I suspect result from the same source.

A well equipped P50 (details see @end) bought in 2017 worked nicely until one day in 2018 (i guess). I have no tracks as to WHAT caused the change, also I guess I "recognized" the true problem only after a while:

Problem #1:
1.) After Login (before see below):
Any Application I run, be it Word, Excel, MS-Editor, Gimp, Notepad++, Visio or others, the FIRST TIME I try to safe a document/file, it takes ages until the dialog to select the place where to safe, reacts again letting me choose directories or enter the filename.

I found out (acccidently) that, while the waiting period runs, the COMPLETE ram is being "filled" slowly but continouusly, which I can see when invoking the task manager and go to the Performance Tab (I guess that's the name of it, 4th tab, German "Leistung"). after the max is reached (32GB in my case), the usage goes back very slowly again (like it raised) and when it is back to "normal", the safe as dialog reacts again.

I thought of having a hard or soft junction somewher that makes an endless loop but I could not find it.


2.) During Login
The same experience happens when starting the PC and logging in. Then the black screen stays "forever" and when pressing "ctrl-alt-del" and invoking the task manager, I can see the very same behaviour: Mem is consumed more and more to the max and then released down to "nothing" and immediately after reaching the low point, the background screen is shwon and Windows reacts again.


The waiting time for the above mentionned "timeout" is some minutes.


Problem #2:
Usually I do not shut down the P50 and let it run "indefinite". After some time (sometimes multiple days, sometimes only a few days) a "Microsoft Windows" message appears that I should close some programs to avoid data loss. It says (translated form German) "The computer does not have enough menory. Safe data and close the following programs:"

In the list of programs to close are all sorts of: Google Chrome, Firefox, Outlook (I still run outlook 2003) and even Skype and Explorer are amongst the suggestions. Below the buttons (close programs and cancel) it further says: "Windows will only close a part of the programs until enough memory will be available".


Thanks for any help or hint!
jw


Machine Info:
- Lenovo TP P50
- Intel Core i7-6700HQ
- 32GB RAM
- 256 GB internal SSD (Intel SSDSCKKF256H6L) original when purchasing, 60GB free
- 2TB Samsung SSD in 2,5" internal bay
- Win 7 Professional 64bit SP1
R30, R31, T42, R50, R52, T61, T400, DELL XPS and some other "regular stuff" pc's.
Addicted to Music, Lotus Notes, Internet of Things, Home Automation and the use of a PC as a modern tool.

dr_st
Moderator
Moderator
Posts: 7860
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: P50/Win7 memory-issue on login and first "safe as" (each app)

#2 Post by dr_st » Wed May 29, 2019 1:04 pm

You might have a buggy driver or malware on your system.
Thinkpad 25 (20K7), X1 Carbon (20HQ), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

jwege
Freshman Member
Posts: 104
Joined: Wed Nov 21, 2007 11:10 am
Location: Karlsruhe Germany

Re: P50/Win7 memory-issue on login and first "safe as" (each app)

#3 Post by jwege » Thu May 30, 2019 10:29 am

Malware ... I would say no ... everything works quite nicely apart from that mem thing.

Driver .. maybe ... but how to find out?
R30, R31, T42, R50, R52, T61, T400, DELL XPS and some other "regular stuff" pc's.
Addicted to Music, Lotus Notes, Internet of Things, Home Automation and the use of a PC as a modern tool.

w0qj
Senior Member
Senior Member
Posts: 929
Joined: Fri Jun 11, 2004 9:53 pm
Location: Hong Kong

Re: P50/Win7 memory-issue on login and first "safe as" (each app)

#4 Post by w0qj » Thu May 30, 2019 11:01 am

Perhaps we're lazy, but we tend to use a disk imaging program (AOMEI for us) to take a disk snapshot, after product recovery and windows customization.

Then we revert to this image every two years or so, then reinstall the programs we use.

This way, the Windows gremlins (maybe like what you are observing) may be eradicated in such a way.
Also, too many program install/uninstall may eventually affect the stability of your system.
We've also been using Win7 until very recently.

Yes, I'm suggesting that perhaps you consider product recovery.
Daily Driver: X1 Extreme 1st Gen (X1E1): i7 | 16GB | 1TB | IPS
Current Thinkpads: X1E1 | X1C4 | X1C3 | X250 | X230 | T410
Retired Thinkpads: T42 | 560 (circa 1996)
~~IBM Thinkpad era computer bag !

jwege
Freshman Member
Posts: 104
Joined: Wed Nov 21, 2007 11:10 am
Location: Karlsruhe Germany

Re: P50/Win7 memory-issue on login and first "safe as" (each app)

#5 Post by jwege » Mon Jun 03, 2019 4:32 am

Thanks ... that will be my last resort. I also do backups every now and then, especially with some "milestones reached". Unfortunately Mickysoft has no interest in helping users ... as you can even today not make a really independant backup of system vs. programs. If I could with not so much effort, I would go to another OS, but unfortunately, many of the programs I use are Win based and not avail under Linux.

And when "re-setting", then the instakl will again begin with the hundreds of update for the OS ... so, if you want to make it really like this, the machine should not used but connected and running for maybe a week to be able to da a propper "installation-free-backup" but not rolled back to 2017 in my case.

So, I still hope that someone can give me a hint how to figure out the troublemaker. I am relatively sure it's a simple thing but as I do not get any information about whats happening (apart form the mem usage that you can easily see in the Task manager) i am kind of lost.

I would like to have a toll reporting mem usage & activity of processes. That would for sure make it easy to find the process that causes the trouble and then I could research in google for more details.
R30, R31, T42, R50, R52, T61, T400, DELL XPS and some other "regular stuff" pc's.
Addicted to Music, Lotus Notes, Internet of Things, Home Automation and the use of a PC as a modern tool.

w0qj
Senior Member
Senior Member
Posts: 929
Joined: Fri Jun 11, 2004 9:53 pm
Location: Hong Kong

Re: P50/Win7 memory-issue on login and first "safe as" (each app)

#6 Post by w0qj » Mon Jun 03, 2019 5:30 am

Does your Windows image/snapsot solution support restoring only the Windows OS files, leaving your data & programs intact?

(Strongly suggest you backup your data before trying something like this!)
Daily Driver: X1 Extreme 1st Gen (X1E1): i7 | 16GB | 1TB | IPS
Current Thinkpads: X1E1 | X1C4 | X1C3 | X250 | X230 | T410
Retired Thinkpads: T42 | 560 (circa 1996)
~~IBM Thinkpad era computer bag !

jwege
Freshman Member
Posts: 104
Joined: Wed Nov 21, 2007 11:10 am
Location: Karlsruhe Germany

Re: P50/Win7 memory-issue on login and first "safe as" (each app)

#7 Post by jwege » Mon Jun 03, 2019 6:50 am

" Does your Windows image/snapsot solution support restoring only the Windows OS files, leaving your data & programs intact? "

To be honest ... I have no idea ... I use Acronis and of course there are multiple options ... I used the "full image" so far ... as it was more for backups than to really roll-back the OS.
R30, R31, T42, R50, R52, T61, T400, DELL XPS and some other "regular stuff" pc's.
Addicted to Music, Lotus Notes, Internet of Things, Home Automation and the use of a PC as a modern tool.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad P1/P50/P70 and later Series”

Who is online

Users browsing this forum: No registered users and 1 guest