Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

ECCM2SensorsData.dat needed from Pantone P50 or P51

P1/P50/P70 and later specific matters only
Post Reply
Message
Author
draco2527
Senior Member
Senior Member
Posts: 713
Joined: Tue Mar 29, 2005 12:41 am
Location: Sterling Heights, Michigan

ECCM2SensorsData.dat needed from Pantone P50 or P51

#1 Post by draco2527 » Sat Apr 06, 2019 9:36 pm

Had to get my MOBO replaced, followed by a re-image. Lost the following file for the pantone:

c:\ProgramData\X-Rite\ECCM-2\ECCM2SensorsData.dat

If you have a P50 or P51 with a working Pantone. Would you mind making a copy of the DAT file and sending it to me?

It would be greatly appreciated.

PS: c:\programdata might not be visible, change it in folder view or type c:\programdata >> Enter, in file explorer to search the directory.


Thank you!
X220T Multi-touch
T410
X61T (pen)
X61T X2 (pen/touch) 1-WIN7 1-WIN8
T61

w0qj
ThinkPadder
ThinkPadder
Posts: 1018
Joined: Fri Jun 11, 2004 9:53 pm
Location: Hong Kong

Re: ECCM2SensorsData.dat needed from Pantone P50 or P51

#2 Post by w0qj » Sat May 11, 2019 1:32 pm

So what LCD screen are you using for your P51?

For the 4k LCD P51 model, there's a X-Rite calibration profile that you can download as per the 2nd URL link below:

www.notebookcheck.net/Lenovo-ThinkPad-P ... 212.0.html

www.notebookcheck.net/uploads/tx_nbc2/B156ZAN02_1.icm
Daily Driver: X1 Extreme 1st Gen (X1E1): i7 | 16GB | 1TB | IPS
Current Thinkpads: X1E1 | X1C4 | X1C3 | X250 | X230 | T410
Retired Thinkpads: T42 | 560 (circa 1996)
~~IBM Thinkpad era computer bag !

rrecord
Posts: 2
Joined: Sat Jul 06, 2019 12:36 pm
Location: Bucharest, Romania

Re: ECCM2SensorsData.dat needed from Pantone P50 or P51

#3 Post by rrecord » Sat Jul 06, 2019 12:58 pm

Here are the files:
x-rite eccm full folder: https://we.tl/t-zHr8rH8XD5
x-rite pantone folder for missing tables: https://we.tl/t-t6W0HVBN8p


I had a similar issue, boght a p51 mainboard, then p51 palmrest and other parts, and had this issue with eccm2sensordat. I did replace all files like copy paste and ran the sensor replacement utility, then calibration and all worked well. After succes I saw some new logs in eccm folder that showed it actually saves the configuration in eeprom memory so next time you reinstall, probably you are safe without any back-up. This issue may only appear when one of the following: changed sensor, changed matherboard or more or less changed LCD. I had everything changed so there i go :D

tripman
Posts: 2
Joined: Tue Jul 16, 2019 3:48 am
Location: Lodz, Poland

Re: ECCM2SensorsData.dat needed from Pantone P50 or P51

#4 Post by tripman » Tue Jul 16, 2019 3:53 am

I have similar isue with w541 Can you reupload files please?

jm26
Posts: 1
Joined: Mon Oct 28, 2019 4:39 pm
Location: Cracow, POLAND

Re: ECCM2SensorsData.dat needed from Pantone P50 or P51

#5 Post by jm26 » Mon Oct 28, 2019 4:46 pm

Hi, Can you be so kind and share once again these files?

draco2527
Senior Member
Senior Member
Posts: 713
Joined: Tue Mar 29, 2005 12:41 am
Location: Sterling Heights, Michigan

Re: ECCM2SensorsData.dat needed from Pantone P50 or P51

#6 Post by draco2527 » Mon Nov 18, 2019 12:02 am

Still haven't fixed the issue and I missed the link he posted (as mentioned above, it is no longer valid)

Searching high/low and not able to find the file.

Unfortunately Lenovo thinks that sending a replacement LCD is the answer to this problem. (HINT: IT IS NOT!)

Reached out to rrecord...
X220T Multi-touch
T410
X61T (pen)
X61T X2 (pen/touch) 1-WIN7 1-WIN8
T61

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 20387
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: ECCM2SensorsData.dat needed from Pantone P50 or P51

#7 Post by RealBlackStuff » Mon Nov 18, 2019 3:48 am

I happened to have downloaded those files.
Uploaded them (as a directory with 2 files) to the same outfit,.
THIS LINK IS VALID ONLY FOR 1 WEEK from today: https://we.tl/t-02j2yPkQmq
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.

draco2527
Senior Member
Senior Member
Posts: 713
Joined: Tue Mar 29, 2005 12:41 am
Location: Sterling Heights, Michigan

Re: ECCM2SensorsData.dat needed from Pantone P50 or P51

#8 Post by draco2527 » Mon Nov 18, 2019 11:50 am

I grabbed them, will play with it tonight. From what I unzipped, they might not be the correct files.

I believe they should be c:\ProgramData\X-Rite\ECCM-2\ECCM2SensorsData.dat

The error specifically states to "if you have a backup copy of the file, please restore it. If you do not have a backup copy or it doesn't fix this problem, please report this error to technical support."
X220T Multi-touch
T410
X61T (pen)
X61T X2 (pen/touch) 1-WIN7 1-WIN8
T61

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 20387
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: ECCM2SensorsData.dat needed from Pantone P50 or P51

#9 Post by RealBlackStuff » Mon Nov 18, 2019 12:17 pm

I don't have such a machine.

The directory name: P50-Color-Profile is my own and contains these 2 files:
F7HH2-156WF6 #2 2016-10-07 18-46 S XYZLUT+MTX RGB LED.icc
You could perhaps shorten this to: LED.icc
The .7z file contains only: LQ156D1JW05.icm
Where you put those files is none of my business
Didn't see any .dat file

Alternative: viewtopic.php?f=70&t=129350

Maybe helpful? https://sourceforge.net/p/dispcalgui/di ... /1e8dfd1c/
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.

levin92
Posts: 1
Joined: Fri Nov 29, 2019 8:22 am
Location: Tokyo, Japan

Re: ECCM2SensorsData.dat needed from Pantone P50 or P51

#10 Post by levin92 » Fri Nov 29, 2019 8:30 am

rrecord wrote:
Sat Jul 06, 2019 12:58 pm
Here are the files:
x-rite eccm full folder: https://we.tl/t-zHr8rH8XD5
x-rite pantone folder for missing tables: https://we.tl/t-t6W0HVBN8p


I had a similar issue, boght a p51 mainboard, then p51 palmrest and other parts, and had this issue with eccm2sensordat. I did replace all files like copy paste and ran the sensor replacement utility, then calibration and all worked well. After succes I saw some new logs in eccm folder that showed it actually saves the configuration in eeprom memory so next time you reinstall, probably you are safe without any back-up. This issue may only appear when one of the following: changed sensor, changed matherboard or more or less changed LCD. I had everything changed so there i go :D
Sorry. Can you reload the two folders that you have uploaded? I am also having problems with the color sensor. If possible you can email me "sonthuy.gtvt@gmail.com". Thank you verry much!

draco2527
Senior Member
Senior Member
Posts: 713
Joined: Tue Mar 29, 2005 12:41 am
Location: Sterling Heights, Michigan

Re: ECCM2SensorsData.dat needed from Pantone P50 or P51

#11 Post by draco2527 » Tue Dec 03, 2019 1:43 am

Still need the files from the following folders:

x-rite eccm full folder
x-rite pantone folder for missing tables

PITA with this Pantone...
X220T Multi-touch
T410
X61T (pen)
X61T X2 (pen/touch) 1-WIN7 1-WIN8
T61

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad P1/P50/P70 and later Series”

Who is online

Users browsing this forum: No registered users and 10 guests