Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Debian8: weak wifi signal on thinkpad T60 comparing with windows

Linux on ThinkPads
Post Reply
Message
Author
arabianights
Posts: 38
Joined: Thu Jan 13, 2011 7:19 pm
Location: James Madison HS, NYC, NY

Debian8: weak wifi signal on thinkpad T60 comparing with windows

#1 Post by arabianights » Mon Dec 28, 2015 10:08 pm

hi,

i have a winXP/debian8/freebsd triple boot setup on my thinkpad t60. it comes with an integrated wi-fi card. i noticed whenever i web browsing in Debian8, it takes several seconds to load a page, in windows xp, it loads/refreshes page almost immediately. i use the laptop at the exact same location at home on the same wi-fi network.

it makes me think debian8 has a weak wifi signal comparing with windows but i have no way to test whether this is indeed the case.
Lenovo Thinkpad T60 1.83Ghz/2G RAM/80G HDD
WinXP/freebsd/Debian8 triple boot

ajkula66
SuperUserGeorge
SuperUserGeorge
Posts: 16346
Joined: Sun Feb 25, 2007 11:28 am
Location: Brodheadsville, Pennsylvania, USA

Re: Debian8: weak wifi signal on thinkpad T60 comparing with windows

#2 Post by ajkula66 » Mon Dec 28, 2015 11:18 pm

If your T60 sports Intel 3945ABG which was the most common wireless card in these machines, then yes, it will pretty much misbehave in any *nix distro.

Truth be told, it's an atrocious card to begin with. Moving on to something with an Atheros chipset would do you a world of good in *nix environments.

Good luck.
...Knowledge is a deadly friend when no one sets the rules...(King Crimson)

Cheers,

George (your grouchy retired FlexView farmer)

AARP club members:A31p,T43pSF

Abused daily: T61p

Work in progress: X60T

PMs requesting personal tech support will be ignored.

arabianights
Posts: 38
Joined: Thu Jan 13, 2011 7:19 pm
Location: James Madison HS, NYC, NY

Re: Debian8: weak wifi signal on thinkpad T60 comparing with windows

#3 Post by arabianights » Tue Dec 29, 2015 11:59 pm

correct, that's the wi-fi card on my T60.

i've noticed the slow loading of webpage in linux before but didn't realize it's caused by the integrated wi-fi until recently.

i plugged in a Netgear w511 wifi card pulled from my old T23, installed linux driver, seems working better now.
Lenovo Thinkpad T60 1.83Ghz/2G RAM/80G HDD
WinXP/freebsd/Debian8 triple boot

ajkula66
SuperUserGeorge
SuperUserGeorge
Posts: 16346
Joined: Sun Feb 25, 2007 11:28 am
Location: Brodheadsville, Pennsylvania, USA

Re: Debian8: weak wifi signal on thinkpad T60 comparing with windows

#4 Post by ajkula66 » Wed Dec 30, 2015 12:03 am

You can pick up an Atheros-chipped card with a FRU for under $10, a bit more if you want the "N" version which is FRU 42T0825.

Or, if you don't mind applying modded BIOS, go for Atheros 9380 which is the card that I have in all of my machines that sport a mini-PCI-e format.
...Knowledge is a deadly friend when no one sets the rules...(King Crimson)

Cheers,

George (your grouchy retired FlexView farmer)

AARP club members:A31p,T43pSF

Abused daily: T61p

Work in progress: X60T

PMs requesting personal tech support will be ignored.

arabianights
Posts: 38
Joined: Thu Jan 13, 2011 7:19 pm
Location: James Madison HS, NYC, NY

Re: Debian8: weak wifi signal on thinkpad T60 comparing with windows

#5 Post by arabianights » Wed Dec 30, 2015 11:19 am

ajkula66 wrote:You can pick up an Atheros-chipped card with a FRU for under $10, a bit more if you want the "N" version which is FRU 42T0825.

Or, if you don't mind applying modded BIOS, go for Atheros 9380 which is the card that I have in all of my machines that sport a mini-PCI-e format.
thank you for the advice!

I'll look into it once I got time. to be honest, after extensive and very time consuming messing around with my old t23/t42 in previous years, now i'm just happy to have a working laptop :)
Lenovo Thinkpad T60 1.83Ghz/2G RAM/80G HDD
WinXP/freebsd/Debian8 triple boot

jaspen-meyer
Senior Member
Senior Member
Posts: 829
Joined: Wed May 19, 2010 11:21 pm
Location: Pardubice, Czech Republic
Contact:

Re: Debian8: weak wifi signal on thinkpad T60 comparing with windows

#6 Post by jaspen-meyer » Thu Dec 31, 2015 10:38 am

iwconfig will tell your your signal strength. You have to be root to run that in debian.

Code: Select all

jaspen@meyer:~$ sudo iwconfig
eth1      no wireless extensions.

wwan0     no wireless extensions.

lo        no wireless extensions.

wlan1     IEEE 802.11abgn  ESSID:""  
          Mode:Managed  Frequency:2.452 GHz  Access Point:   
          Bit Rate=1 Mb/s   Tx-Power=2 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=48/70  Signal level=-62 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:136   Missed beacon:0
Note this line: Link Quality=48/70 Signal level=-62 dBm

My x61s was using the Intel 3945ABG without problems in Xubuntu 14.04.
I replaced it with an Intel 5100 today but haven't used it enough to know if there is any difference, and didn't
run any benchmarks to measure changes.
T420 i7 3612QM seabios; T420 i7 3630QM; T400 Q9100 seabios; T61 P9600; T60 libreboot; x62; x60s libreboot, led; x24 xiphmont led

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “Linux Questions”

Who is online

Users browsing this forum: No registered users and 4 guests