Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

volume keys on XFCE / fedora 25

Linux on ThinkPads
Post Reply
Posts: 4
Joined: Sun Jun 07, 2009 5:33 pm
Location: vancouver, canada

volume keys on XFCE / fedora 25

#1 Post by tedman » Sun Nov 27, 2016 4:50 am

This is just a post on how to fix the volume keys on the latest Fedora 25 with xfce as I couldn't find this information easily anywhere else.

I have a thinkpad t420, the volume keys have always previously worked straight out of the box. Just installed fedora 25 and none of those keys now work.

To fix it, manually assign the key commands. On the menu : Settings -> Keyboard -> Application Short Cuts. Use the Add option and press the corresponding keys when prompted.
up command : amixer set Master 5%+
down command : amixer set Master 5%-
mute command : amixer set Master toggle


Posts: 4
Joined: Sun Jun 07, 2009 5:33 pm
Location: vancouver, canada

Re: volume keys on XFCE / fedora 25

#2 Post by tedman » Sat Jun 10, 2017 3:13 am

more updates on this topic...
still fedora 25 but this time a thinkpad x270

With the new keyboard, the top row now defaults to media keys and you have to press fn first to get f1,f2 etc. As any normal person would do... you change this back to normal in the bios so f1 is f1 and mute is fn+f1.

Now when you go into application short-cuts, it won't detect fn+f1 properly anymore. When you press fn it calls it "x86Wakeup" or something like that. What you really want to capture is XF86AudioMute, XF86AudioLowerVolume, XF86AudioRaiseVolume, XF86AudioMicMute. To do that, turn on fnlock i.e. fn-esc such that the fn light is on, then you can press f1 when it asks to capture a key and it'll capture mute properly etc. Now you should be able to map your keys again.

One glitch though, I can't capture the mic-mute button at all, I don't know why. I even tried to manually map the setting via "settings" -> "Settings editor" by adding the XF86AudioMicMute but it has no effect. It doesn't seem to send the fn-f4 button properly, I have no idea why.

Post Reply
  • Similar Topics
    Last post

Return to “Linux Questions”

Who is online

Users browsing this forum: No registered users and 15 guests