error message when trying to boot

Linux on ThinkPads
Post Reply
Message
Author
retired
Freshman Member
Posts: 98
Joined: Mon Mar 02, 2009 9:40 pm
Location: hunter, n.y.

error message when trying to boot

#1 Post by retired » Wed Mar 01, 2017 8:21 am

My t-60 is double booted - xp and linux mint 18 - recently can't boot into linux mint - get error cpu pipe underrun - can boot with live disk - did fresh install of linux - cannot boot into that - same error message

EAkamai
Sophomore Member
Posts: 168
Joined: Sat May 17, 2008 5:23 pm

Re: error message when trying to boot

#2 Post by EAkamai » Thu Mar 02, 2017 6:25 pm

Are you able to boot to XP ok? Maybe something messed up in the MBR etc.
What kind of boot manager are you using? I do the same with one of my drives and use the excellent Bare Metal (Terabyte Unlimited).
Never has a hiccup. Fantastic boot mgr.
TPad T61 14.1 XGA TFT - T7500-8897CTO - 320/750 GB Int. 320/750 GB Multibay - 1TB GB USB - GSA-E50L + Combo Drive Multibay 4 GB RAM

Muse
Senior Member
Senior Member
Posts: 818
Joined: Thu Nov 30, 2006 9:19 pm
Location: Berkeley, CA

Re: error message when trying to boot

#3 Post by Muse » Fri Mar 03, 2017 12:18 pm

I got my 2nd T60 very cheap off ebay because it wouldn't boot and the seller didn't realize that the problem was fixable. My internet searches convinced me that I had a great chance of salvaging the machine, which was being sold for parts. Yes, I fixed it pretty easily.
"If a star were a grain of salt, you could fit all the stars visible to the naked eye on a teaspoon, but all the stars in the universe would fill a ball eight miles wide." - A Briefer History of Time, Stephen Hawking & Leonard Mlodinow

Dec. 2010: Now thought to be over 11 miles wide!

retired
Freshman Member
Posts: 98
Joined: Mon Mar 02, 2009 9:40 pm
Location: hunter, n.y.

Re: error message when trying to boot

#4 Post by retired » Fri Mar 03, 2017 12:39 pm

can boot into xp ok - did fresh install of linux - boot manager is ok - still get error message when trying to boot mint

Neil
Senior ThinkPadder
Senior ThinkPadder
Posts: 2936
Joined: Sun Aug 07, 2005 5:41 pm
Location: Paragould AR USA

Re: error message when trying to boot

#5 Post by Neil » Fri Mar 03, 2017 2:00 pm

If I had found that the Linux distro I was trying to install was not compatible with my hardware, I would be looking for a different distro to try.

Since Linux Mint 18 (Main Edition I assume) kernel appears to cause issues with your T60, try Linux Mint MATE 17.3 (17.3 Main Edition might be OK too), or some other distro entirely. You now know to avoid Mint 18 (and probably any other distro built on Ubuntu 16.04).
Collection = T500 - R400 - X300 - X200 - T61 (14" WXGA+) - T61 (14.1" SXGA+) - T60 (15" SXGA+) - X40 - T43p - T43 - T42p - A30P

retired
Freshman Member
Posts: 98
Joined: Mon Mar 02, 2009 9:40 pm
Location: hunter, n.y.

Re: error message when trying to boot

#6 Post by retired » Tue Mar 07, 2017 9:02 pm

have been using 18 for some time with no problem till recently

Cigarguy
ThinkPadder
ThinkPadder
Posts: 1478
Joined: Thu Aug 09, 2012 3:08 pm
Location: Calgary, Alberta, Canada

Re: error message when trying to boot

#7 Post by Cigarguy » Tue Mar 07, 2017 9:38 pm

No problem with Mint 18 on a variety of laptops. The oldest being a T42.

axur-delmeria
ThinkPadder
ThinkPadder
Posts: 1495
Joined: Mon May 28, 2012 5:49 am
Location: Metro Manila, Philippines

Re: error message when trying to boot

#8 Post by axur-delmeria » Wed Mar 08, 2017 12:02 am

Does your T60 have Intel graphics, or ATI/AMD?
Daily driver: X220 4291-P79 i5-2520M

In reserve: X61 T7500, X60 T2300
In pieces: X60s CS U1300 [board only], two retired but working X61Ts
RIP: 760XD 9546-U9E

retired
Freshman Member
Posts: 98
Joined: Mon Mar 02, 2009 9:40 pm
Location: hunter, n.y.

Re: error message when trying to boot

#9 Post by retired » Wed Mar 08, 2017 1:39 pm

Intel

jaspen-meyer
Senior Member
Senior Member
Posts: 719
Joined: Wed May 19, 2010 11:21 pm
Location: Pardubice, Czech Republic
Contact:

Re: error message when trying to boot

#10 Post by jaspen-meyer » Thu Mar 09, 2017 2:55 pm

I second what Neil said, try another kernel. Mint 17.3 uses a different kernel and is supported till 2019. It's an easy solution. Harder, if you're not used to it, would be to fix the broken system -- one way would be to 'chroot' into the broken system, install a new kernel, update grub, etc...

Some of the talk about the problem you're reporting is discussed in context with the kernel.
You report a Live CD works (one version of kernel), but installed version (newer kernel) doesn't...but it did for a while (yet another kernel).
T420 i7 3612QM; T420 i7 3630QM; T400 Q9100; x60s libreboot, led; x24 xiphmont led

retired
Freshman Member
Posts: 98
Joined: Mon Mar 02, 2009 9:40 pm
Location: hunter, n.y.

Re: error message when trying to boot

#11 Post by retired » Sat Mar 11, 2017 6:36 pm

I was running 18 for months without updating so I have trouble understanding how it could be the kernel - same kernel as my live copy of 18

jaspen-meyer
Senior Member
Senior Member
Posts: 719
Joined: Wed May 19, 2010 11:21 pm
Location: Pardubice, Czech Republic
Contact:

Re: error message when trying to boot

#12 Post by jaspen-meyer » Sun Mar 12, 2017 6:18 am

retired wrote:I was running 18 for months without updating so I have trouble understanding how it could be the kernel - same kernel as my live copy of 18
Maybe I'm reading between the lines too much in your first post -- I assumed your aim was to boot into Linux.

If your intent is to understand why you're getting the error message try the Mint forum.
T420 i7 3612QM; T420 i7 3630QM; T400 Q9100; x60s libreboot, led; x24 xiphmont led

Dekks
Junior Member
Junior Member
Posts: 483
Joined: Thu Jun 26, 2014 9:38 am
Location: Birmingham, UK

Re: error message when trying to boot

#13 Post by Dekks » Sun Mar 12, 2017 6:31 am

have you updated a 32bit installation with a 64bit update or visa versa when you went to mint 18?
Home Win10/i5 Arch//Openbox R61//GNOME 3 X201i/X230 Tablet //Spectrwm T61/X61/X61 Debian 9.2/X32/T60p
Work - Win7/X220T BunsenLabs/Debian 9 T43
Retired T60/X30/X31/X61S RIP T400/T21/X61T/X200T

retired
Freshman Member
Posts: 98
Joined: Mon Mar 02, 2009 9:40 pm
Location: hunter, n.y.

Re: error message when trying to boot

#14 Post by retired » Sun Mar 12, 2017 5:05 pm

no - just 32 - I'm trying to boot into linux

Neil
Senior ThinkPadder
Senior ThinkPadder
Posts: 2936
Joined: Sun Aug 07, 2005 5:41 pm
Location: Paragould AR USA

Re: error message when trying to boot

#15 Post by Neil » Sun Mar 12, 2017 6:04 pm

retired wrote:have been using 18 for some time with no problem till recently
Too much missing information.
On what hardware have you been using Mint 18? Has there been any hardware changes since it was working?
What kernel were you using when 18 was working? Are you now trying to use 18.1 (with it's newer kernel)?
Bottom line...what has changed in your hardware or software since Mint 18 was working for you? That kind of info is going to help us identify where you issue is coming from.
Collection = T500 - R400 - X300 - X200 - T61 (14" WXGA+) - T61 (14.1" SXGA+) - T60 (15" SXGA+) - X40 - T43p - T43 - T42p - A30P

Dekks
Junior Member
Junior Member
Posts: 483
Joined: Thu Jun 26, 2014 9:38 am
Location: Birmingham, UK

Re: error message when trying to boot

#16 Post by Dekks » Mon Mar 13, 2017 11:31 am

retired wrote:no - just 32 - I'm trying to boot into linux
model number? ati gpu?
Home Win10/i5 Arch//Openbox R61//GNOME 3 X201i/X230 Tablet //Spectrwm T61/X61/X61 Debian 9.2/X32/T60p
Work - Win7/X220T BunsenLabs/Debian 9 T43
Retired T60/X30/X31/X61S RIP T400/T21/X61T/X200T

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “Linux Questions”

Who is online

Users browsing this forum: No registered users and 5 guests