Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Operating system cannot be found, Cannot boot from any device w510

Linux on ThinkPads
Post Reply
Posts: 1
Joined: Sun Oct 22, 2017 9:06 pm
Location: New York, NY

Operating system cannot be found, Cannot boot from any device w510

#1 Post by aioy » Sun Oct 22, 2017 9:10 pm

Before this problem I was stuck in a grub rescue screen after trying to install puppy linux, and to fix it I used a boot rescue disc, but after using the boot rescue disc I restarted my computer and it says no operating system found, then this screen appears https://ibb.co/iAHe86 and I have no idea what to do from here. I thought the boot repair disc erased puppy linux after I installed it, so I put in a lubuntu disc and tried installing that, but while I was trying to install it, it said puppy linux was still on my computer, but I don't know how because its not booting. Does anyone know how I can get puppy linux to boot from here?

I'm using a thinkpad w510 and I don't think anything is wrong with my hardware since I can still boot into another operating system like I did in lubuntu, I just want to boot into puppy linux though. And Does anyone know how much a computer shop will charge to fix a problem like this? I will appreciate any help.

EDIT: /viewtopic.php?t=63779
This guy has the same problem as me, but the responses suggest his hardware is faulty, but since I can still boot other operating systems I don't think my hardware is faulty, I just want to know how to boot puppy linux.

Junior Member
Junior Member
Posts: 445
Joined: Wed May 16, 2012 3:36 pm
Location: Salinas, CA

Re: Operating system cannot be found, Cannot boot from any device w510

#2 Post by bit_twiddler » Mon Oct 23, 2017 8:34 am

It could be a lot of things. In particular, it sounds like you have puppy linux installed on a hard drive,
so booting off a dvd or cdrom doesn't indicate that your hard drive is O.K.

One place to start would be to do some form of hard drive diagnostics on your hard drive.

If your drive checks out, I'd try getting a drive caddy, and some extra hard drives, setting the BIOS to boot from the drive bay,
and do your installs from an external USB 2.0 dvd reader. This assures that different operating systems
are not going to clobber each other during an install or update.
Daily Drivers: W520 i7-2760QM | W520 i7-2860QM | T420 FHD IPS i7-2640m | W701
Others: W510 | 701C (on its shrine)
Non-TP: Dell m7510
Currently Experimenting With: T420s

Senior Member
Senior Member
Posts: 829
Joined: Wed May 19, 2010 11:21 pm
Location: Pardubice, Czech Republic

Re: Operating system cannot be found, Cannot boot from any device w510

#3 Post by jaspen-meyer » Tue Oct 24, 2017 12:34 pm

That picture is saying, "you don't have grub installed on your hard drive."

Years ago I tried using puppy linux as my daily operating system, which is to say not as just a live CD, and the main file, one big squash file with the entire os and data, got corrupted after an unclean shutdown. Perhaps they've fixed that issue, but it was far too unreliable for me and I've never reconsidered using it as anything more than a rescue disk since.

I'm not sure how to install grub from puppy, in version 3.x and 4.x it had something called 'installed MBR'. On debian, or a derivate, you can install grub to a device with:
grub-install /dev/sdX

To recover your system, perhaps you can boot into puppy and ask it to search all media for the squash file.
T420 i7 3612QM seabios; T420 i7 3630QM; T400 Q9100 seabios; T61 P9600; T60 libreboot; x62; x60s libreboot, led; x24 xiphmont led

Post Reply
  • Similar Topics
    Last post

Return to “Linux Questions”

Who is online

Users browsing this forum: No registered users and 5 guests