Page 1 of 1

T420 - Linux + WiFi web browsing woes

Posted: Tue Jun 09, 2020 6:56 pm
by skye20
I have two T420s. One is running Ubuntu 18.04 and the other is running Fedora 30. Both have the Intel Centrino Advanced-N 6205 WiFi cards.

Both have serious issues connecting to some web sites via Chrome or Firefox. eBay and Shutterfly are both culprits. Essentially, after a few connections they will no longer load pages from those sites and throw a ERR_CONNECTION_CLOSED error. The only remedy is to clear the browser cache every few connections. Not ideal to say the least.

I have tried multiple USB WiFi adapters and the problem is the same. With Windows 7 installed the WiFi works flawlessly. I can only conclude there is something odd about the T420, Linux, and WiFi.

If anyone can provide insight into this I will be in your debt!

Re: T420 - Linux + WiFi web browsing woes

Posted: Tue Sep 22, 2020 12:06 am
by Khrome
Have you tried using those sites on other networks?
If you can connect to the internet then it isn't a problem with your card. And if chrome and firefox work fine then it probally isn't your browser. So it will probaly be something to do with your networking settings, or network restrictions like in a work enviroment.

Re: T420 - Linux + WiFi web browsing woes

Posted: Tue Sep 22, 2020 7:17 am
by atagunov
T520 and X220 here, very similar to T420. Home wifi network. Ubuntu 18.04 and 20.04. Firefox. No issues whatsoever ever..

I'm sorry to hear you've got trouble.. Perhaps you could try to re-install Ubuntu? Should be pretty quick to do.
A side benefit of re-installing Ubuntu is that you can upgrade to 20.04, the new LTS and it will make your Thinkpad boot a lot faster than with 18.04
If you do decide to re-install I suggest to secure-erase the SSD first; I always suggest that before installing any OS.
I am also very opposed to upgrading OS-es across major versions like Win7 -> Win10, Ubuntu LTS releases if this is avoidable at all

What kind of WiFi network is this? Home? Office? Starbucks? :)

Re: T420 - Linux + WiFi web browsing woes

Posted: Tue Sep 22, 2020 11:16 am
by RealBlackStuff
Replace that 6205 with a 6300, FRU 60Y3233, even if you have only 2 antenna wires.

Re: T420 - Linux + WiFi web browsing woes

Posted: Thu Oct 08, 2020 3:00 pm
by skx
atagunov wrote:
Tue Sep 22, 2020 7:17 am
What kind of WiFi network is this? Home? Office? Starbucks? :)
:lol:

on topic, it cannot be related to sh!tty router? i confirm T420's wifi should work perfectly