Unable to Install Linux Properly on T60

Solaris, RedHat, FreeBSD and the like
Post Reply
Message
Author
Ken Fox
Senior Member
Senior Member
Posts: 838
Joined: Thu Dec 14, 2006 1:52 am
Location: Idaho, USA

Unable to Install Linux Properly on T60

#1 Post by Ken Fox » Wed Aug 08, 2007 11:14 pm

I have tried, I believe 15 or perhaps 20 times, to install various Linux distros on a T60, with very little luck. I believe the problem is due to a combination of software and hardware factors, however not being very experienced with Linux I can't be sure. Perhaps if I explain the problem, in a little detail, someone can explain to me what I am doing wrong.

The machine is a T60 2007 C4U, 2ghz core duo, that has been upgraded (by me) with 2gb of RAM and a 7K100 Hitachi 7200rpm drive, and with XP loaded via Ghost 2003 image. This image was made with the -ib switch preserving the MBR, and with the service partition intact. The XP installation is completely up to date, including the Lenovo stuff, with the current 4.1 version of R&R (which may be causing the problem). I arbitrarily put the windows partition into a 40gb NTFS partition. The Service partition resides in an 8+gb FAT partition, and the rest (a little less than 50gb) is/was unpartitioned space.

I have now attempted to load the following distros, some of them more times than others: Kubuntu, Ubuntu 7.04, Debian 4.0, Fedora (current version), and OpenSuse (also current). My goal has been to try to preserve the stock MBR, so as to preserve the functionality of the "blue button." As a result, I have tried to have the Linux distros load GRUB (and once or twice, LILO) onto the Linux main partition, which I have told these installation programs to make the "active" partition.

I have designated the partition for loading the grub boot code depending on what the loading linux OS called it, be it SDA3, SDA4, hd0,4, or Sda5; this depended on the way the remaining space was suggested to be partitioned by the Linux distro in question. I have divided up the free space msyelf a number of times, even going so far as to create a tiny "boot partition" to see if THAT would work. NO DICE.

The only distro I was able to get to load this way, and to subsequently boot, preserving the "blue button" functionality was Ubuntu, which quite honestly I did not like, for several reasons including that I could never get it to recognize the WPA-AES encryption of my WiFi router (it only offers WEP configuration in spite of my reading about this on the various Linux Wikis ad nauseum). Most of the time the attempts to load the Grub code on the Linux partition simply result in the system either (1) freezing at that point in the install, requiring a hard reboot, or (2) acting as if the requested action has occured, but then the system refuses to boot, with an error message such as, "no operating system found," or a couple of others. Some times I've been able to boot into the recovery space with the blue button, but not to do anything else even though Grub may or may not appear with its choices, which it then cannot execute, all returning error messages about no OS found or that the requested partition does not have an OS or does not exist.

One or two other times I was able to get a distro to install the GRUB code into the MBR, which of course then makes the "blue button" non functional, however most times I simply ended up with a non-booting system. At that point even the IBM MBR repair floppy won't work, returning some sort of error message I have forgotten. The only thing that would then work would be to use an MBR tool I downloaded from the internet, to completely wipe the MBR, because even the Linux distros couldn't make the system boot at all at that point. After wiping the MBR (and partition table) entirely, then I could start all over and put the ghost image back on the disk, which otherwise would not boot if I did not previously wipe the MBR entirely.

My working hypothesis is that there is something in the new version of R&R (4.1) that is changing the MBR in a way that the Linux distros don't anticipate, and are not prepared to deal with.
The result has been almost uniform failure. I base this on the fact that the new R&R (maybe version 4.0 as well) changes not only the R&R on the main Windows partition but also on the recovery partition. You can see that if you push the blue button and go into the recovery space, that the R&R program is the same as in your Windows partition, which is not what has happened previously when R&R has been updated on the main NTFS drive.

At this point, I think the problem is nearly unresolvable. Perhaps there is also some hardware incompatibility with the 7K100, to make a dual boot system with this new R&R version and the MBR on the machine I'm using. Don't know. Or, maybe, something in my hardware is defective, but I haven't had any problems with this machine otherwise.

Does anyone have any suggestions?
Ken Fox

dmitrio
Freshman Member
Posts: 53
Joined: Sun Mar 11, 2007 2:52 am
Location: MumbaUmba, MaltaPalta
Contact:

:. gentoo-wiki

#2 Post by dmitrio » Thu Aug 09, 2007 2:01 am

check out this article http://gentoo-wiki.com/HARDWARE_Lenovo_Thinkpad_T61

in this portion some info about hidden partition and how to deal with it.

carbon_unit
Moderator Emeritus
Moderator Emeritus
Posts: 2988
Joined: Sat Apr 24, 2004 9:10 pm
Location: South Central Iowa, USA

#3 Post by carbon_unit » Thu Aug 09, 2007 7:02 am

How about running Linux in a virtual machine? This avoids all the MBR and partitioning problems.
T60 2623-D7U, 3 GB Ram.
Dual boot XP and Linux Mint.
Registered linux user #160145

whizkid
ThinkPadder
ThinkPadder
Posts: 1555
Joined: Wed Sep 29, 2004 1:40 pm
Location: Saint Paul, MN
Contact:

#4 Post by whizkid » Thu Aug 09, 2007 10:29 am

I have Fedora running on my T60 and ThinkVantage is working fine. I would not recommend F7 yet (my machine is almost useless at the moment), but FC6 was working great.

The ThinkWiki (www.thinkwiki.org) page for FC6 on a T60 is very good. Its F7 on a T60 has useful information, but doesn't tell you how to actually do the install, and it is out of date.
Machine-Project: 750P, 600X, T42, T60, T400, X1 Carbon Touch

acasto
Freshman Member
Posts: 89
Joined: Fri Dec 08, 2006 8:17 pm
Location: Asheville, NC, USA

#5 Post by acasto » Thu Aug 09, 2007 10:31 am

If your goal is to retain R&R and the functionality of the blue button, then you could just boot linux from the windows bootloader instead. I've used it before, but this time I just wiped out the R&R partition since I only use windows maybe ten minutes a month anyways.

Here's a link with some info.

Basically, you just install grub to the linux partition, dd 512 bytes from the front of that partition and put it somewhere accessible to Windows, then edit boot.ini in Windows to reference that file.

whizkid
ThinkPadder
ThinkPadder
Posts: 1555
Joined: Wed Sep 29, 2004 1:40 pm
Location: Saint Paul, MN
Contact:

#6 Post by whizkid » Thu Aug 09, 2007 10:57 am

acasto, that is good information for XP. It's more difficult with Vista... kind of. Adding one worked for me, but there's an old entry somewhere that I can't seem to find, and it's the default. Argh.
Machine-Project: 750P, 600X, T42, T60, T400, X1 Carbon Touch

K0LO
Senior Member
Senior Member
Posts: 659
Joined: Wed Sep 07, 2005 12:14 pm
Location: State College, PA, USA

#7 Post by K0LO » Thu Aug 09, 2007 11:35 am

Ken:

For your method to work, GRUB must be installed to a primary partition because only primaries are bootable from the MBR code. More info here.

Your suggestion of using a small boot partition should work OK as long as it is a primary and made the active partition. You need one primary for /boot; one for Windows XP, and one for the recovery partition. All of the others must be logical partitions.

Also, network-manager in Ubuntu or knetworkmanager in Kubuntu give out-of-the-box automatic connection to WPA-AES wireless networks. The latest (7.04) version of Kubuntu has this package installed by default. Not sure about Ubuntu but probably so also.
Mark

X61T 7764-CTO, Core 2 Duo L7500 LV 1.6 GHz, 4 GB RAM, 120 GB Intel X25M SSD
Multiboot w/Grub4DOS -- Windows 10, MustangPE, PartedMagic
My ex: X41T (2005 - 2009)

Harryc
Moderator Emeritus
Moderator Emeritus
Posts: 13228
Joined: Thu Apr 12, 2007 8:23 am
Location: Upstate New York

#8 Post by Harryc » Thu Aug 09, 2007 12:03 pm

k0lo wrote:Ken:

For your method to work, GRUB must be installed to a primary partition because only primaries are bootable from the MBR code.
Agree with KOlo 100%. He helped me out the first time I installed Linux on a Thinkpad. I just installed Opensuse this morning on an R52 and used this method. It worked fine keeping everything intact. You can install all other partitions including /swap to an extended partition, just not / if you expect to boot from it.

Ken Fox
Senior Member
Senior Member
Posts: 838
Joined: Thu Dec 14, 2006 1:52 am
Location: Idaho, USA

#9 Post by Ken Fox » Fri Aug 10, 2007 11:26 am

First, thanks to everyone who replied. I was away from home most of yesterday and unable to respond.

To Carbon Unit, I am unfamiliar with virtual machines. I did a little google research on them after reading your post and am not certain that I want to "complicate" my WinXP install with this, although I'm open to the idea. Which program would you suggest? I have a strong bias towards something free!

To Mark, I will try again to load one of these distros and will pay particular attention to what you have written about the partitions. I do believe, however, that I have done all of these things before multiple times and they have not worked. Ubuntu 7.04 does install network manager, but in my case for some reason I have only been given the option for WEP encryption not for WPA. I cannot explain this because all the documentation I can find on the web indicates that it should install WPA functionality. Perhaps there was a glitch in the installation and repeating it would correct this.

As to the other comments, I think I have already tried most or all of these things, including loading the grub bootloader to the Linux partition which is then made active. What has happened is that either the Linux installation then crashed or it indicated that the bootloader WAS loaded on that partition which was made active, however the bootloader was not loaded there and did not work.

I have used several downloadable programs such as "supergrub" and various MBR editors and utilities to try to confirm the loading of grub in this linux partition, to activate the partition if it was not activated, etc., and none of these things have helped.

My impression remains that the upgrade to version 4 (or maybe v4.1) of R&R has done something to the MBR and partition table that the current Linux distros can't deal with. I have several reasons for thinking this which come from my installation experiences. In one case, I had actually, previously, installed Kubuntu to the T60, which was working ok, but I had let Grub install on the MBR. Then, I used System Update while in WinXP, which downloaded and installed the upgrade from v3 to v4 of R&R. I was prompted to reboot, and ended up with a nonbooting system with a corrupted MBR and partition table. R&R's upgrade had obviously done something to the MBR in the process, which presumably was that it tried to change a Grub-encoded MBR and couldn't do it.

The fact that I've ended up, multiple times, with a system that I could only restore after using MBR utilities erasing the entire MBR and partition table, then using Ghost 2003 to put my old WinXP and service partition and Lenovo MBR back on, says to me that something funny here is going on and I'm pretty [censored] sure it is coming from that v4 R&R install, changing the MBR and partition table.

Of you folks commenting, who have dual booting systems, how many of you have upgraded to v4 or v4.1 R&R?????? I think you might find that you have some problems of your own if you do!

ken
Ken Fox

Volker
Junior Member
Junior Member
Posts: 482
Joined: Fri Oct 01, 2004 10:21 am
Location: Dublin, Ireland
Contact:

#10 Post by Volker » Fri Aug 10, 2007 12:42 pm

I have R&R4 on my T61 by default, and I can boot through grub into the R&R partition. There were some links posted previously on how to achieve this. Make sure you get the right partition in your grub.conf, on my T61 the R&R partition is (hd0,0). If it doesn't work post the output of "fdisk -l /dev/sda".

Personally, I think grub is the way to go since it can boot everything else. First boot into grub and then let grub load whatever you want.

As for the wireless problem, use NetworkManager. To configure WPA-AES, for example, click on the icon in the gnome panel and select "Connect to other Network". Then pick "WPA Personal" as your wireless security, and type "AES-CCMP".

Note that WPA2 (which uses AES by default) would be much more common. Are you sure you want to use WPA-AES?

Ken Fox
Senior Member
Senior Member
Posts: 838
Joined: Thu Dec 14, 2006 1:52 am
Location: Idaho, USA

#11 Post by Ken Fox » Fri Aug 10, 2007 3:34 pm

Volker wrote:I have R&R4 on my T61 by default, and I can boot through grub into the R&R partition. There were some links posted previously on how to achieve this. Make sure you get the right partition in your grub.conf, on my T61 the R&R partition is (hd0,0). If it doesn't work post the output of "fdisk -l /dev/sda".

Personally, I think grub is the way to go since it can boot everything else. First boot into grub and then let grub load whatever you want.

As for the wireless problem, use NetworkManager. To configure WPA-AES, for example, click on the icon in the gnome panel and select "Connect to other Network". Then pick "WPA Personal" as your wireless security, and type "AES-CCMP".

Note that WPA2 (which uses AES by default) would be much more common. Are you sure you want to use WPA-AES?
It is probably WPA2 that I am using, but since I was only given WEP options it really didn't matter with that Ubuntu install I did.

As to Grub, I've now tried again, with Suse and Debian, to follow all the kind suggestions given in this thread and none of them work, unfortunately. With Debian, after what appeared to be a successful installation plus putting the Grub code into the Linux partiition (made active and primary) I got grub to boot up but when I chose any option, including WinXP, Linux, or the service partition, I get "Error 21; Selected disk does not exist."

With Suse, all I get is a blinking cursor after the supposed installation of the system and grub in the manually designated Linux partition. I did not try this time around to put grub in the MBR.

I may try loading Ubuntu one more time, which is the one installation that was capable of preserving the "blue button" functionality and that actually booted. If I do, I'll try playing around with Network manager as you suggest above.

ken
Ken Fox

rarirurero
Posts: 20
Joined: Wed Jul 25, 2007 11:00 am
Location: San Jose, CA

#12 Post by rarirurero » Fri Aug 10, 2007 4:35 pm

Here's my experience with other OSs.
I am on a T61 with the Intel GMA965 (X3100).

Ubuntu 7.04 - the alternate CD had to be used, and even then, there was a problem with the Intel drivers, so that did not work.

Ubuntu 7.10 (Tribe 3) - either CD (alternate or normal), but the window manager did not load. The login prompt appeared, but after that, only a beige screen showed and remained like that. Under some sessions (failsafe GNOME) the desktop loaded, but subsequent attempts (even under failsafe mode) did not load.

For both installations, it booted to GRUB, but the blue button still worked and I was able to load Vista from GRUB as well.

Executing grub commands (I believe it was setup) allowed me to move GRUB and then in Vista, use the BCD instead - the Vista boot menu showed Vista and GRUB, and from there I was able to go to GRUB and then Ubuntu.

Solaris 10 - installed fine, ran fine (resolution was 1024x768 or something, though), but screwed up the MBR. Neither the ThinkVantage button nor Vista worked. GRUB had a Vista option, but that only led to an error complaining about winload.exe.

To fix this (HUGE pain, that is why I am posting the instructions here, in case someone needs them), I downloaded the Windows Pre-Installation CD from Microsoft (WinPE 2.0). I did not have a DVD burner available to burn the image, but I could open the file with WinRAR. I extracted the contents to a folder and then clicked on setup.exe (I believe that was the name of the installer) and installed Windows AIK. The rest of the tutorial to make the CD can be found here: http://www.apcstart.com/node/3894

Now when you boot into WinPE, you will get a console window. It will run an init program, so just wait a short while. You should soon be able to type into the console.

The program that will save you is bcdedit.exe. Type bcdedit into the console and press Enter to view the Vista BCD. This is where Vista gets all of its Boot Configuration Data. If you see that some entries say "device" or "osdevice" followed by "unknown," that is your problem. To remedy this, you can type

Code: Select all

bcdedit /set {id} device partition=C:
"id" refers to the IDs that are printed out when you type bcdedit. In my current configuration, I have

Code: Select all

Windows Boot Manager
--------------------
identifier              {bootmgr}
device                  partition=C:
description             Windows Boot Manager
locale                  en-US
inherit                 {globalsettings}
default                 {current}
resumeobject            {9f5c8777-704a-11db-9519-8441f37d8489}
displayorder            {current}
toolsdisplayorder       {memdiag}
timeout                 0

Windows Boot Loader
-------------------
identifier              {current}
device                  partition=C:
path                    \Windows\system32\winload.exe
description             Microsoft Windows Vista
locale                  en-US
inherit                 {bootloadersettings}
recoverysequence        {572bcd55-ffa7-11d9-aae0-0007e994107d}
recoveryenabled         Yes
osdevice                partition=C:
systemroot              \Windows
resumeobject            {9f5c8777-704a-11db-9519-8441f37d8489}
nx                      OptIn
so the possible IDs could be bootmgr or current. When you use bcdedit, make sure to encapsulate the ID within curly braces; you would type bcdedit /set {bootmgr} device partition=C: as an example.

Of course, if your Windows partition is D: and not C:, then you would set the value of "device" to partition=D:. Do the same for entries labeled "osdevice" as well.

Now, you can try and boot into Vista, and the winload.exe error should be gone; Vista can boot. If this does not work for you, then you can resort to using the Vista DVD (which we do not have because Lenovo does not ship them...) and supposedly you can use bootrec.exe to repair the MBR and BCD.

Hope this helps some poor soul who kills their computer, just like I did yesterday.

K0LO
Senior Member
Senior Member
Posts: 659
Joined: Wed Sep 07, 2005 12:14 pm
Location: State College, PA, USA

#13 Post by K0LO » Fri Aug 10, 2007 6:16 pm

Ken Fox wrote:As to Grub, I've now tried again, with Suse and Debian, to follow all the kind suggestions given in this thread and none of them work, unfortunately. With Debian, after what appeared to be a successful installation plus putting the Grub code into the Linux partiition (made active and primary) I got grub to boot up but when I chose any option, including WinXP, Linux, or the service partition, I get "Error 21; Selected disk does not exist."ken
At least you have the GRUB boot working correctly. The rest should not be too difficult to sort out. From the GRUB manual:
Error 21 : Selected disk does not exist
This error is returned if the device part of a device- or full file name refers to a disk or BIOS device that is not present or not recognized by the BIOS in the system.
This sounds like you have more than one disk in your system and the Linux installer that generated the /boot/grub/menu.lst file got them confused. Do you have more than one disk drive?

What would be helpful here is to post one of the GRUB command lines for booting an OS. So could you start up the PC and let it boot into the GRUB menu. When this happens, press the "ESC" key to stop the timer. Then move the cursor to one of the operating system choices; for example, the one for booting Windows. Now press the "e" key (for edit) and the boot commands that GRUB is to execute will be displayed on the screen. Copy those down and post them back here if you don't mind.
Mark

X61T 7764-CTO, Core 2 Duo L7500 LV 1.6 GHz, 4 GB RAM, 120 GB Intel X25M SSD
Multiboot w/Grub4DOS -- Windows 10, MustangPE, PartedMagic
My ex: X41T (2005 - 2009)

Ken Fox
Senior Member
Senior Member
Posts: 838
Joined: Thu Dec 14, 2006 1:52 am
Location: Idaho, USA

#14 Post by Ken Fox » Fri Aug 10, 2007 7:26 pm

k0lo wrote:
At least you have the GRUB boot working correctly. The rest should not be too difficult to sort out. From the GRUB manual:
Error 21 : Selected disk does not exist
This error is returned if the device part of a device- or full file name refers to a disk or BIOS device that is not present or not recognized by the BIOS in the system.
This sounds like you have more than one disk in your system and the Linux installer that generated the /boot/grub/menu.lst file got them confused. Do you have more than one disk drive?

What would be helpful here is to post one of the GRUB command lines for booting an OS. So could you start up the PC and let it boot into the GRUB menu. When this happens, press the "ESC" key to stop the timer. Then move the cursor to one of the operating system choices; for example, the one for booting Windows. Now press the "e" key (for edit) and the boot commands that GRUB is to execute will be displayed on the screen. Copy those down and post them back here if you don't mind.
The only other drives present in the system are the CDRW/DVDRW drive in the ultrabay, and some of the time, a PCMCIA card with a compact flash disk in it. Since I have considered the possibility that the CF card was causing problems, I have installed the distros with and without the PC card in place, and it made no difference. Earlier on, I loaded several distros with a USB floppy drive attached and even tried a few times to load the GRUB code to the floppy, which also never worked and generated error messages. I'd read elsewhere that you could load Grub to a floppy and later transfer the file to a hard drive, but that has never worked to the point where I could even try it.

With my latest round of install attempts, I have been trying to avoid having to put the image of WinXP and the service partition back on the hard drive. I've failed today with Ubuntu 7.04 once, Debian 4.0 twice, and openSuse once. Right now, I decided to try putting both Debian and openSuse 10.2 on in the remaining 50gb of the 100gb drive, and the openSuse install is still in process. I did not let Debian even try to put Grub on this time, but will have openSuse try.

Once I get this done, I'll attempt to post what you have requested and we'll see what is going on. I guess there is a small possibility that there is something wrong with my 7K100 hard drive that only becomes apparent when dual booting is attempted, but I sorta doubt it.

ken
Ken Fox

Ken Fox
Senior Member
Senior Member
Posts: 838
Joined: Thu Dec 14, 2006 1:52 am
Location: Idaho, USA

#15 Post by Ken Fox » Fri Aug 10, 2007 9:02 pm

k0lo wrote: This sounds like you have more than one disk in your system and the Linux installer that generated the /boot/grub/menu.lst file got them confused. Do you have more than one disk drive?

What would be helpful here is to post one of the GRUB command lines for booting an OS. So could you start up the PC and let it boot into the GRUB menu. When this happens, press the "ESC" key to stop the timer. Then move the cursor to one of the operating system choices; for example, the one for booting Windows. Now press the "e" key (for edit) and the boot commands that GRUB is to execute will be displayed on the screen. Copy those down and post them back here if you don't mind.
My attempt at a WinXP/openSuse/Debian system did not go well, so I removed all the partitions except for the WinXP and Thinkpad Service, and reloaded Debian. This time, I let Debian set up a /home partition in addition to the / and swap partitions. The / partition was made bootable (as before), and primary, with the rest extended (although WinXP and IBM Service remain primary). Grub was told to load onto Sda3, which should have been the Linux partition.

The error message I got was once again, "Error 21: Selected disk does not exist." Above this was written, "root (hd1,2)

As requested, here is what shows up as the boot commands for my WinXP (selection) partition:

root (hd1,0)
savedefault
map (hd0) (hd1)
map (hd1) (hd0)
chainloader +1

For the Debian (linux) partition, the boot commands read:

root (hd1,2)
kernal /boot/vmlinuz-2.6.18-4-686 root=/dev/sda3 ro
initrd /boot/initrd.img-2.6.18-4-686
savedefault

I have played around with editing the line for booting the kernel into Linux, and anything I have tried produces errors such as "unrecognized device string" or "Error 1: Filename must be either an absolute pathname or blocklist."

This experience with Linux parallels one I had on a desktop several years ago, that after endless wasted hours I decided I did not need Linux after all, and the hell with it.

Any help would be much appreciated!

ken
Ken Fox

Volker
Junior Member
Junior Member
Posts: 482
Joined: Fri Oct 01, 2004 10:21 am
Location: Dublin, Ireland
Contact:

#16 Post by Volker » Fri Aug 10, 2007 9:30 pm

If you have only one hard disk, then you only have hd0. All references to hd1 necessarily give you some "disk not found" error because, well, you don't have a second hard disk. The output of "fdisk -l /dev/sda" then tells you which partition contains what. The only devices in your grub.conf should be (hd0,n) where n is some non-negative integer.

And remove any flash memory sticks during installation, thats asking for trouble because, to the computer, it'll look like some extra disk hanging around.

K0LO
Senior Member
Senior Member
Posts: 659
Joined: Wed Sep 07, 2005 12:14 pm
Location: State College, PA, USA

#17 Post by K0LO » Fri Aug 10, 2007 9:54 pm

Volker:

You hit the nail on the head.

Ken:

This is what I suspected was happening. Your Linux installer got confused about which disk was which. Volker is correct; all disk references should be (hd0,x) where "x" is referencing a partition. You probably had either your flash disk or a USB flash drive attached when you ran the Linux installer.

To fix this you can edit your /boot/grub/menu.lst file and change the references. You can do this by booting from a LiveLinux CD, for example, the one for Ubuntu, and navigating to the file and opening it in an editor.

Before doing that though, how about some instant gratification? You have discovered how to directly enter commands in GRUB. Try these two tests:

1. Let the PC start up to the GRUB menu. Move the cursor to the Windows XP entry and press "c" to get a command prompt. Enter the following one line at a time:

Code: Select all

rootnoverify (hd0,0)
chainloader +1
boot
This should boot into Windows.

2. Now for Linux. Move the cursor to the line for Debian Linux and press "e" to edit the commands. Change the first line:

Code: Select all

root (hd1,2)
to this:

Code: Select all

root (hd0,2)
Press "ESC" to go back to the GRUB menu and then press Enter to boot into Debian.

Let us know if this works then we can modify the GRUB menu to make it permanent.
Mark

X61T 7764-CTO, Core 2 Duo L7500 LV 1.6 GHz, 4 GB RAM, 120 GB Intel X25M SSD
Multiboot w/Grub4DOS -- Windows 10, MustangPE, PartedMagic
My ex: X41T (2005 - 2009)

Ken Fox
Senior Member
Senior Member
Posts: 838
Joined: Thu Dec 14, 2006 1:52 am
Location: Idaho, USA

#18 Post by Ken Fox » Fri Aug 10, 2007 10:09 pm

k0lo wrote:Volker:

You hit the nail on the head.

Ken:

This is what I suspected was happening. Your Linux installer got confused about which disk was which. Volker is correct; all disk references should be (hd0,x) where "x" is referencing a partition. You probably had either your flash disk or a USB flash drive attached when you ran the Linux installer.

To fix this you can edit your /boot/grub/menu.lst file and change the references. You can do this by booting from a LiveLinux CD, for example, the one for Ubuntu, and navigating to the file and opening it in an editor.

Before doing that though, how about some instant gratification? You have discovered how to directly enter commands in GRUB. Try these two tests:

1. Let the PC start up to the GRUB menu. Move the cursor to the Windows XP entry and press "c" to get a command prompt. Enter the following one line at a time:

Code: Select all

rootnoverify (hd0,0)
chainloader +1
boot
This should boot into Windows.

2. Now for Linux. Move the cursor to the line for Debian Linux and press "e" to edit the commands. Change the first line:

Code: Select all

root (hd1,2)
to this:

Code: Select all

root (hd0,2)
Press "ESC" to go back to the GRUB menu and then press Enter to boot into Debian.

Let us know if this works then we can modify the GRUB menu to make it permanent.
Thank you, Volker and Mark!

So far so good, it appears to work.

So how do I edit the grub menu permanently?

Thanks in advance,

ken
Ken Fox

K0LO
Senior Member
Senior Member
Posts: 659
Joined: Wed Sep 07, 2005 12:14 pm
Location: State College, PA, USA

#19 Post by K0LO » Fri Aug 10, 2007 10:43 pm

Do you have a LiveLinux CD? Ubuntu/Kubuntu, Knoppix or other?
Mark

X61T 7764-CTO, Core 2 Duo L7500 LV 1.6 GHz, 4 GB RAM, 120 GB Intel X25M SSD
Multiboot w/Grub4DOS -- Windows 10, MustangPE, PartedMagic
My ex: X41T (2005 - 2009)

Ken Fox
Senior Member
Senior Member
Posts: 838
Joined: Thu Dec 14, 2006 1:52 am
Location: Idaho, USA

#20 Post by Ken Fox » Fri Aug 10, 2007 10:45 pm

k0lo wrote:Do you have a LiveLinux CD? Ubuntu/Kubuntu, Knoppix or other?
I believe that the Ubuntu and Kubuntu CDs I have can be used in this fashion ---

Otherwise, I could download something and burn a disk, but I think that what I have will suffice.

I have booted into Debian and in fact have it open on my T60 right now, with the temporary boot line changes you previously suggested, Mark.

ken
Ken Fox

Volker
Junior Member
Junior Member
Posts: 482
Joined: Fri Oct 01, 2004 10:21 am
Location: Dublin, Ireland
Contact:

#21 Post by Volker » Fri Aug 10, 2007 11:36 pm

You have to edit /etc/grub.conf (requires root privileges).

Code: Select all

[vbraun@thinkpad ~]$ su
Password or swipe finger: 
[root@thinkpad vbraun]# emacs /etc/grub.conf 
The grub.conf should be very familiar after you worked on the grub command line.

Ken Fox
Senior Member
Senior Member
Posts: 838
Joined: Thu Dec 14, 2006 1:52 am
Location: Idaho, USA

#22 Post by Ken Fox » Sat Aug 11, 2007 12:16 am

Volker wrote:You have to edit /etc/grub.conf (requires root privileges).

Code: Select all

[vbraun@thinkpad ~]$ su
Password or swipe finger: 
[root@thinkpad vbraun]# emacs /etc/grub.conf 
The grub.conf should be very familiar after you worked on the grub command line.
Thanks for your help. I am unfamiliar with Linux and have not been able to figure out your instructions, as they are too cryptic for someone with my level of Linux knowledge.

I have tried to edit the boot/grub/menu.1st file however I am not allowed to save it because I don't have the necessary "privileges." Obviously I should have them but I don't know how to give them to myself. Likewise, I've tried the command line and to edit, but I can't get that to work either.

Best,

ken

EDIT:

"Logon as Root" is so obvious that it took me half an hour to realize what you were suggesting. I think I have now fixed it, after relogging on as "Root"

thanks,

ken
Ken Fox

K0LO
Senior Member
Senior Member
Posts: 659
Joined: Wed Sep 07, 2005 12:14 pm
Location: State College, PA, USA

#23 Post by K0LO » Sat Aug 11, 2007 7:16 am

Ken Fox wrote:As requested, here is what shows up as the boot commands for my WinXP (selection) partition:

root (hd1,0)
savedefault
map (hd0) (hd1)
map (hd1) (hd0)
chainloader +1

For the Debian (linux) partition, the boot commands read:

root (hd1,2)
kernal /boot/vmlinuz-2.6.18-4-686 root=/dev/sda3 ro
initrd /boot/initrd.img-2.6.18-4-686
savedefault
Ken:

You've probably figured this out by now but when you do edit your /boot/grub/menu.lst file you should change the above entry for Windows XP to the following:

Code: Select all

rootnoverify (hd0,0)
chainloader +1
and the one for Debian to:

Code: Select all

root (hd0,2)
kernel  /boot/vmlinuz-2.6.18-4-686 root=/dev/sda3 ro
initrd /boot/initrd.img-2.6.18-4-686
If you have more than one entry for booting Debian (perhaps one for recovery mode) then change it also as above.

In other words you should change all references to the hard disk from (hd1,x) to (hd0,x), you should eliminate the disk mapping lines in the Windows boot and also change "root" to "rootnoverify" (because grub cannot read the files on an NTFS partition so using "root" will produce an error message), and you should eliminate the "savedefault" lines (hardly anyone uses that grub feature correctly so don't worry about it).

If you post the current entry for booting into the recovery partition I'll help you with that one also.
Mark

X61T 7764-CTO, Core 2 Duo L7500 LV 1.6 GHz, 4 GB RAM, 120 GB Intel X25M SSD
Multiboot w/Grub4DOS -- Windows 10, MustangPE, PartedMagic
My ex: X41T (2005 - 2009)

Ken Fox
Senior Member
Senior Member
Posts: 838
Joined: Thu Dec 14, 2006 1:52 am
Location: Idaho, USA

#24 Post by Ken Fox » Sat Aug 11, 2007 9:22 am

I'm tied up this morning, and have no time to boot up the T60 to answer your questions, Mark. I'll do so this afternoon and appreciate your help.

ken
Ken Fox

Ken Fox
Senior Member
Senior Member
Posts: 838
Joined: Thu Dec 14, 2006 1:52 am
Location: Idaho, USA

#25 Post by Ken Fox » Sat Aug 11, 2007 3:07 pm

k0lo wrote:
Ken Fox wrote:As requested, here is what shows up as the boot commands for my WinXP (selection) partition:

root (hd1,0)
savedefault
map (hd0) (hd1)
map (hd1) (hd0)
chainloader +1

For the Debian (linux) partition, the boot commands read:

root (hd1,2)
kernal /boot/vmlinuz-2.6.18-4-686 root=/dev/sda3 ro
initrd /boot/initrd.img-2.6.18-4-686
savedefault
Ken:

You've probably figured this out by now but when you do edit your /boot/grub/menu.lst file you should change the above entry for Windows XP to the following:

Code: Select all

rootnoverify (hd0,0)
chainloader +1
and the one for Debian to:

Code: Select all

root (hd0,2)
kernel  /boot/vmlinuz-2.6.18-4-686 root=/dev/sda3 ro
initrd /boot/initrd.img-2.6.18-4-686
If you have more than one entry for booting Debian (perhaps one for recovery mode) then change it also as above.

In other words you should change all references to the hard disk from (hd1,x) to (hd0,x), you should eliminate the disk mapping lines in the Windows boot and also change "root" to "rootnoverify" (because grub cannot read the files on an NTFS partition so using "root" will produce an error message), and you should eliminate the "savedefault" lines (hardly anyone uses that grub feature correctly so don't worry about it).

If you post the current entry for booting into the recovery partition I'll help you with that one also.
Hi Mark,

These are all great suggestions. I had already corrected the references to disks and grub was working for all entries.

I think I have decided to go back to another distro, probably Ubuntu or Kubuntu. Although Debian has more (native) application packages, the time it is going to take to get it to recognize all my devices and my networking is more time than I care to spend with it. At least Ubuntu (or maybe it was Kubuntu) worked more or less out of the box, and I'm rapidly running out of patience!

Best and thanks again, to all; I will use all of your suggestions on the grub and distro install I decide to keep.

ken
Ken Fox

Mr. The Guy
Posts: 32
Joined: Sun Oct 22, 2006 3:55 pm
Location: Cowtown

PCLInuxOS

#26 Post by Mr. The Guy » Thu Aug 16, 2007 2:26 pm

I have a T60p and PCLinuxOS installed easily for me. I would recommend it for a noob. I admit I didn't try the wireless as ethernet worked and there were other reasons that made me switch to Fedora 7 which is working splendidly (except for the wireless and my iPod).

Harryc
Moderator Emeritus
Moderator Emeritus
Posts: 13228
Joined: Thu Apr 12, 2007 8:23 am
Location: Upstate New York

#27 Post by Harryc » Tue Dec 18, 2007 9:32 pm

Volker wrote:I have R&R4 on my T61 by default, and I can boot through grub into the R&R partition.
Volker, can you post your grub.conf please? I need to recreate the entry to boot into R&R in GRUB for dual boot Vista and OpenSUSE 10.3 on the machine in my sig. Thank-you

Volker
Junior Member
Junior Member
Posts: 482
Joined: Fri Oct 01, 2004 10:21 am
Location: Dublin, Ireland
Contact:

#28 Post by Volker » Thu Dec 20, 2007 7:22 pm

I think this has already been answered in another thread, but for the sake of completeness:

Code: Select all

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You do not have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /, eg.
#          root (hd0,1)
#          kernel /boot/vmlinuz-version ro root=/dev/sda2
#          initrd /boot/initrd-version.img
#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,1)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.23.12-99.fc8)
        root (hd0,1)
        kernel /boot/vmlinuz-2.6.23.12-99.fc8 ro root=LABEL=/ rhgb quiet
        initrd /boot/initrd-2.6.23.12-99.fc8.img
title Fedora (2.6.23.9-85.fc8)
        root (hd0,1)
        kernel /boot/vmlinuz-2.6.23.9-85.fc8 ro root=LABEL=/ rhgb quiet
        initrd /boot/initrd-2.6.23.9-85.fc8.img
title Fedora (2.6.23.9-67.fc8)
        root (hd0,1)
        kernel /boot/vmlinuz-2.6.23.9-67.fc8 ro root=LABEL=/ rhgb quiet
        initrd /boot/initrd-2.6.23.9-67.fc8.img
title ThinkPad Rescue and Recovery
      rootnoverify    (hd0,0)
      chainloader     +1

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “Linux Questions”

Who is online

Users browsing this forum: No registered users and 2 guests