Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T500 thermal sensor locations?

T400/410/420 and T500/510/520 series specific matters only
Post Reply
Message
Author
fmyhr
Posts: 14
Joined: Fri Dec 28, 2007 4:39 pm
Location: Berkley, MI

T500 thermal sensor locations?

#1 Post by fmyhr » Thu Apr 02, 2009 9:54 pm

On my T500 type 2242 (P8400, GMA) running Linux:

# modprobe thinkpad-acpi
# cat /proc/acpi/ibm/thermal
temperatures: 39 36 32 -128 50 -128 29 -128 35 39 42 -128 -128 -128 -128 -128

It appears there are 7 or 8 thermal sensors, ignoring the -128 values and possibly the 50 which never seems to change. The first one seems to be cpu temperature. Anybody know about the others?

Thanks,
Frank

fmyhr
Posts: 14
Joined: Fri Dec 28, 2007 4:39 pm
Location: Berkley, MI

Re: T500 thermal sensor locations?

#2 Post by fmyhr » Sun Apr 05, 2009 1:34 pm

After watching how the temperatures change as the machine warms up, starts/stops mprime etc. it appears that T500 sensor locations may be identical to those reported for the T61:

http://www.thinkwiki.org/wiki/Thermal_S ... inkPad_T61

Code: Select all

Index in "thermal"   Location
1                    CPU
2                    MiniPCI
3                    HDD
4                    n/a (-128)
5                    Battery 1
6                    n/a (-128)
7                    Battery 2
8                    n/a (-128)
9                    ?
10                   ?
11                   ?
12                   n/a (-128)
13                   n/a (-128)
14                   n/a (-128)
15                   n/a (-128)
16                   n/a (-128)
In addition to the above, I'll hazard a guess that sensor 11 is perhaps the cpu heatsink. It is very closely correlated to cpu load but shows a lot more inertia than sensor 1 which changes almost instantaneously with cpu load.

On a related note, I'm seeing higher temperatures than I expected from sensor 1, about 70 C when running mprime with 2 threads. That's with the embedded controller setting fan speed around 3000 RPM. Setting the fan manually to "level 7" ~3450 RPM doesn't bring sensor1 temp down much but is significantly louder.

Here are the fan speeds I get for the manual levels:

Code: Select all

level     rpm
0           0
1        1900
2        2700
3,4,5    3000
6,7      3450

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T400/410/420 and T500/510/520 Series”

Who is online

Users browsing this forum: No registered users and 19 guests