L420 All hotkeys work except for the speaker mute light

SL and L series specific matters only
Post Reply
Message
Author
razoreater
Posts: 6
Joined: Sun Apr 16, 2017 1:54 pm
Location: Athens, Greece

L420 All hotkeys work except for the speaker mute light

#1 Post by razoreater » Sun Apr 16, 2017 4:45 pm

Hello,

I have a thinkpad L420. i5 2520M with a clean installation of Windows 10 Pro and the latest BIOS. I have installed the audio driver, hotkey driver and communications utility driver and everything works (mute button included), except for the mute button light. Whenever I press it it toggles between sound and mute but the light stays unchanged. And by unchanged I mean that if I press it during boot-up it will light up and stay lit when I log into windows, and if I press it again during boot-up it stays off. This is frustrating for me, please help.

Note: I don't remember the exact sequence by which I installed the drivers.

TPFanatic
Senior Member
Senior Member
Posts: 515
Joined: Thu Jul 30, 2015 11:29 pm
Location: Hudson, New Hampshire

Re: L420 All hotkeys work except for the speaker mute light

#2 Post by TPFanatic » Sun Apr 16, 2017 4:48 pm

You might need to install an older version of the driver for Windows 10. Try version 3.87 from the list at the bottom of this page: http://pcsupport.lenovo.com/us/en/produ ... s/DS014985

I hope you are running an SSD because Windows 10 is really slow on normal hard drives.
Daily driver: lenovo T500 P9700, WUXGA, 8GB
Ultraportable: IBM lenovo X60s
Home theater: lenovo T420

Enable advanced features on older Synaptics touchpads with the registry: http://forum.thinkpads.com/viewtopic.php?f=2&t=122612

razoreater
Posts: 6
Joined: Sun Apr 16, 2017 1:54 pm
Location: Athens, Greece

Re: L420 All hotkeys work except for the speaker mute light

#3 Post by razoreater » Sun Apr 16, 2017 5:04 pm

I run conventional hdd and it works fine for me. Do I have to uninstall the previous driver and reboot? Please guide me through because I want to cover all my bases.

razoreater
Posts: 6
Joined: Sun Apr 16, 2017 1:54 pm
Location: Athens, Greece

Re: L420 All hotkeys work except for the speaker mute light

#4 Post by razoreater » Sun Apr 16, 2017 5:48 pm

Version 3.01 did the trick. I had to go top to bottom after version 3.86 failed to work. Is there a way to disable the on screen volume display, it being redundant and all?

Update: I'm not marking it as solved due to the brightness setting being stuck to 100%
Last edited by razoreater on Sun Apr 16, 2017 6:04 pm, edited 1 time in total.

TPFanatic
Senior Member
Senior Member
Posts: 515
Joined: Thu Jul 30, 2015 11:29 pm
Location: Hudson, New Hampshire

Re: L420 All hotkeys work except for the speaker mute light

#5 Post by TPFanatic » Sun Apr 16, 2017 5:51 pm

Yes under Display Adapter Properties. Get there by right clicking on desktop, Screen Resolution, find the "Advanced Settings" button and get to the On screen Display Tab. Then uncheck the "Enable on-screen display" check box.
Daily driver: lenovo T500 P9700, WUXGA, 8GB
Ultraportable: IBM lenovo X60s
Home theater: lenovo T420

Enable advanced features on older Synaptics touchpads with the registry: http://forum.thinkpads.com/viewtopic.php?f=2&t=122612

razoreater
Posts: 6
Joined: Sun Apr 16, 2017 1:54 pm
Location: Athens, Greece

Re: L420 All hotkeys work except for the speaker mute light

#6 Post by razoreater » Sun Apr 16, 2017 6:49 pm

Done but brightness still cannot be controlled via the function keys. I tried uninstalling my monitor in device manager and reinstalling the graphics driver but nothing changed. Hotkey driver is currently 3.7.0001.

razoreater
Posts: 6
Joined: Sun Apr 16, 2017 1:54 pm
Location: Athens, Greece

Re: L420 All hotkeys work except for the speaker mute light

#7 Post by razoreater » Sun Apr 16, 2017 9:51 pm

Tried almost every hotkey driver version and it seems that you have to choose between the mute light and functional brightness controls. This is kinda terrible. :(

razoreater
Posts: 6
Joined: Sun Apr 16, 2017 1:54 pm
Location: Athens, Greece

Re: L420 All hotkeys work except for the speaker mute light

#8 Post by razoreater » Mon Apr 17, 2017 5:25 am

Still if anyone knows some kind of hack or trick to get it to work please help.

RealBlackStuff
Admin
Admin
Posts: 17363
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA USA
Contact:

Re: L420 All hotkeys work except for the speaker mute light

#9 Post by RealBlackStuff » Mon Apr 17, 2017 6:29 am

You probably don't want to hear this, but IMHO your best solution is to dump Windows 10.
Either go back to W7 or dump Micro$haft altogether and switch over to Linux.
Lovely day for a Guinness! (The Real Black Stuff)

Check out The Boardroom for Parts, Mods and Other Services.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad SL and L Series”

Who is online

Users browsing this forum: No registered users and 1 guest