Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

x230 bricked after bios update?

X230 and later series specific matters only
Post Reply
Message
Author
bgravato
Posts: 2
Joined: Tue Dec 04, 2018 8:06 am
Location: Aveiro, Portugal

x230 bricked after bios update?

#1 Post by bgravato » Tue Dec 04, 2018 8:49 am

Hi,

I bought a x230 second hand on ebay (from UK) an year ago. 2x4GB ram (samsung), IPS screen, SSD, 9-cell battery, wifi, fingerprint reader, english keyboard.
I installed both linux and windows 7 on it. On windows, Lenovo's software kept bugging me about updating the bios, so I did (from Windows yes) it got bricked. It powered, power button light on, thinklight flashed once, fan spinned for a couple of seconds then stopped, black screen all the time, no image on external screen, etc... dead.
Not sure what the original bios version was.

Meanwhile I bought a few second hand motherboards. The first two I got I replaced them but still no luck... same symptoms.
The third motherboard I got worked and I got my x230 up and running again. I wiped the disk and installed Win7 and Linux again, though 99% of the time I'm using Linux.
BIOS version was 2.02 and EC 1.10.

Yesterday I gained courage and decided to try to update the BIOS again. This time I played safe and decided to go with the bootable cd option... ("burning" it to an usb pen).
I also thought it would be a good idea to update one version at a time. I followed strickly the instructions on the txt file that comes with the bios update.

I downloaded the iso's from here: https://support.lenovo.com/pt/pt/downloads/ds029188
On linux, I used geteltorito to extract the image from the iso and "burned" it to USB with dd

I successfully updated from 2.02 to 2.06.
Then successfully update to 2.50, then 2.51, then 2.52, then 2.54.
All good up to this point. After each update I would reset bios to defaults (F9 on bios menu).
Then I decided to skip 2.55 update (it didn't change much) and go straight to 2.56 (changelog says it adds support for windows 8).

Booted from usb, run the the bios update, rebooted and BIOS flashing went through normally like the other times.
Then I got the "system will reboot in 5 seconds message" as usual, but when it restarted it didn't boot. Black screen, power button on, no reaction.

So I'm wondering if this might have been because I skipped the 2.55 update? Or maybe 2.56 and later versions introduce some change that is incompatible with my hardware, namely the IPS screen or the memory sticks?

If I remove both memory sticks and power on it starts beeping indicating a memory error as expected, so does that mean it's not completely bricked?

With previous motherboards I tried removing the WIFI, fingerprint, etc boards, but it didn't make a difference. So if it's some hardware incompatibility with the bios I guess it must be either the screen, the RAM or the keyboard.

Any thoughts?

Thanks.

GomJabbar
Moderator
Moderator
Posts: 9872
Joined: Tue Jun 07, 2005 6:57 am

Re: x230 bricked after bios update?

#2 Post by GomJabbar » Tue Dec 04, 2018 10:47 am

I have skipped BIOS update versions in the past and never had a problem with a BIOS update so far. I always update using the Bootable CD version.

You might try removing all power (AC, main battery & CMOS battery), hold the power button down for a minute or so, replace the batteries and AC power, and try booting up again.
DKB

bgravato
Posts: 2
Joined: Tue Dec 04, 2018 8:06 am
Location: Aveiro, Portugal

Re: x230 bricked after bios update?

#3 Post by bgravato » Tue Dec 04, 2018 3:01 pm

GomJabbar wrote:
Tue Dec 04, 2018 10:47 am
I have skipped BIOS update versions in the past and never had a problem with a BIOS update so far. I always update using the Bootable CD version.

You might try removing all power (AC, main battery & CMOS battery), hold the power button down for a minute or so, replace the batteries and AC power, and try booting up again.
I did that, but still the same.

Tanbam
Posts: 2
Joined: Sun Mar 10, 2019 1:02 pm
Location: Austin, TX

Re: x230 bricked after bios update?

#4 Post by Tanbam » Sun Mar 10, 2019 1:50 pm

Old thread, but this happened to me yesterday. It’s probably the RAM. Lenovo apparently blocks 8500 sticks in the latest update. Try some different sticks. Worked for me as soon as I swapped them.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X230 and later Series”

Who is online

Users browsing this forum: JPOESQ and 7 guests