Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

W520 - can't enter BIOS and boot menu after motherboard upgrade when SSD is connected

W500/510/520 and W700/710 series specific matters only
Post Reply
Message
Author
endriu
Posts: 6
Joined: Wed Oct 16, 2019 10:51 am
Location: Lima, Peru

W520 - can't enter BIOS and boot menu after motherboard upgrade when SSD is connected

#1 Post by endriu » Tue Oct 22, 2019 11:05 pm

After replacing the 04W2028 motherboard with the 04W2029 one I can't enter BIOS or boot menu using the standard ways (ThinkVantage button and F12, respectively).
The BIOS itself doesn't seem to be corrupted because I can edit the settings to some extent using WMI interface and this tool: https://thinkdeploy.blogspot.com/2016/0 ... -tool.html
However I can't get the boot order persistent this way and regardless of that I'd like to be able to change it dynamically when starting the computer.

I have recorded the videos showing the problem:
https://streamable.com/mwqgi
https://streamable.com/obojc

Could this be due to the fact that I didn't updated the serial numbers in the new motherboard with the values from the old one (no errrors suggesting that though)?
Last edited by endriu on Thu Oct 24, 2019 9:06 pm, edited 1 time in total.

dr_st
Moderator
Moderator
Posts: 8360
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: W520 - can't enter BIOS and boot menu after motherboard upgrade

#2 Post by dr_st » Wed Oct 23, 2019 2:40 am

Can you enter the BIOS directly using F1?
Thinkpad 25 (20K7), X1 Carbon (20HQ), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 21005
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: W520 - can't enter BIOS and boot menu after motherboard upgrade

#3 Post by RealBlackStuff » Wed Oct 23, 2019 2:43 am

AFAIK, and I have always done this, you go into BIOS on all Thinkpads by pressing F1.
If your mobo is missing its Type, S/N and UUID, download the HMD: http://download.lenovo.com/ibmdl/pub/pc ... tm38us.exe
When you run it first time (in Windows), it wants to unpack itself to c:\drivers\maintenance...
Change it to where it suits you.
Then go to the program usbfmtpw.exe to make a self-booting USB-stick.
Remove your HDD/SSD and CD drives, then run that USB-program.
Reuse the TYPE and S/N from the sticker underneath your W520 (without any dashes) and run UUID once.
Reboot and remove the USB-stick as soon as the logo shows, then press F1 to go into BIOS to check.
Switch off, reconnect your drives, reboot and press F1 instead of Vantage button.
Set your preferred boot-order and whatever.
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.

"Computers don't lie, but liars can compute." (Terry Hayes's I Am Pilgrim)

endriu
Posts: 6
Joined: Wed Oct 16, 2019 10:51 am
Location: Lima, Peru

Re: W520 - can't enter BIOS and boot menu after motherboard upgrade

#4 Post by endriu » Thu Oct 24, 2019 9:01 pm

Sorry, I should have mentioned that hitting F1 results in a similar behavior (black screen).

After a series of trial and error experiments I have found the source of the problem. Whenever I have my SSD connected to the primary slot, I cannot enter neither BIOS nor boot menu. When I disconnect the disk, I can enter both. I use the DVD bay as a slot for a second SSD, when it's connected it works as well. So only the primary slot causes the issues. I did some googling and found similar reports, mostly concerning Lenovo, though I didn't find any solution to this issue.
I would appreciate any ideas on how to resolve this.

EDIT: It actually fails with my old HDD connected as well.

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 21005
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: W520 - can't enter BIOS and boot menu after motherboard upgrade when SSD is connected

#5 Post by RealBlackStuff » Fri Oct 25, 2019 2:10 am

Does Primary (and BIOS) work if you remove the Ultrabay drive?
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.

"Computers don't lie, but liars can compute." (Terry Hayes's I Am Pilgrim)

endriu
Posts: 6
Joined: Wed Oct 16, 2019 10:51 am
Location: Lima, Peru

Re: W520 - can't enter BIOS and boot menu after motherboard upgrade when SSD is connected

#6 Post by endriu » Sat Oct 26, 2019 2:37 pm

No, the presence (or lack of it) of the Ultrabay caddy has no influence on whether I can enter BIOS / boot menu or not.
Also, when I remove the primary SSD and get to the boot settings I see plenty of old entries:

Image

I'm not very familiar with this aspect of the system, but since no drives are present I understand this data is stored somewhere in the BIOS itself. I already reconnected the internal battery various times, but it didn't wipe this data, so I assume it's stored in some non-volatile BIOS memory, right? Is there a way to bring it all to factory state?

dr_st
Moderator
Moderator
Posts: 8360
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: W520 - can't enter BIOS and boot menu after motherboard upgrade when SSD is connected

#7 Post by dr_st » Sun Oct 27, 2019 12:04 am

This is very strange, as this data should be dynamic. It says that you can 'Delete' entries; did you try that?
Thinkpad 25 (20K7), X1 Carbon (20HQ), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

endriu
Posts: 6
Joined: Wed Oct 16, 2019 10:51 am
Location: Lima, Peru

Re: W520 - can't enter BIOS and boot menu after motherboard upgrade when SSD is connected

#8 Post by endriu » Sun Oct 27, 2019 12:18 pm

I can delete _some_ of these entries, but not all. I would prefer to just get the NVRAM to the factory state instead, perhaps that would resolve that blockage of accessing BIOS caused by the presence of SSD/HDD too.

BillP
Sophomore Member
Posts: 169
Joined: Mon Jul 23, 2007 4:04 pm
Location: Woodstock, NY

Re: W520 - can't enter BIOS and boot menu after motherboard upgrade when SSD is connected

#9 Post by BillP » Sun Oct 27, 2019 12:25 pm

What happens if you press F9 - Setup Defaults
ThinkPad T60 1951-43U (with many upgrades)

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad W500/510/520 and W7x0 Series”

Who is online

Users browsing this forum: No registered users and 17 guests