Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Windows taskbar freezes for 30s after boot

X230 through X280, plus X390 series specific matters only
Post Reply
Message
Author
Jake.Werecat
Freshman Member
Posts: 83
Joined: Thu May 09, 2019 6:46 pm
Location: Cracow, Poland

Windows taskbar freezes for 30s after boot

#1 Post by Jake.Werecat » Sun Jan 26, 2020 4:54 pm

Hi everyone, I'm having a peculiar, very interesting, but very annoying problem. First of all, there are 4 different machines affected with this, belonging to me and my girlfriend.
T430 with i7-3520M
T430 with i7-3612QM
X230 with i7-3520M
X230 with i5-3320M
They all have 16GB each, 120GB SSD, and run OEM Windows 7 pro and all behave the same:
Windows boots in a matter of ~20sec. After typing in the password or scanning a fingerprint on a logon screen, desktop pops up almost immediately, but the taskbar tends to hang, and hang, and hang, sometimes for 20, sometime 40 s. I this time, the computers are totally responsive, have low CPU % usage, and you can start any software or folder from a desktop you like. But the taskbar is "freezed", it does not react to any clicks, neither to pressing Win key on a keyboard. Any Win+letter shortcuts like Win+R or Win+E doesn't work as well. There are no icons visable on it either. And then suddenly after mentioned 20-30 s it de-freezes, Access Connection, Power Manger applets and notification area icons pops-up and it's working absolutely fine ever after until the next reboot.
I can exclude any hardware-related issues, as there are 4 different laptops affected. It's not a virus, neither crapware, nor malware as the problems starts appearing after fresh windows and drivers install. Windows is installed from a genuine Microsoft image, it's legal and activated. Drivers are installed directly from Lenovo Support page, all up to date, BIOS on all 4 machines is updated to the newest version available. There are no suspicious entries in msconfig "Startup" Tab. I tried to do all the troubleshooting I could think off, but with no luck, so I just somehow accept the problem, though it would be absolutely great to get rid of it.

Thank you very much for all suggestions and hints.
Last edited by Jake.Werecat on Mon Jan 27, 2020 3:53 am, edited 1 time in total.
X61f, 2x X230, 2x T430

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 20769
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: Windows taskbar freezes for 30s after boot

#2 Post by RealBlackStuff » Mon Jan 27, 2020 3:30 am

All 4 from the same image?
Unless it's a KMS version, only one could be 'legal'.
If not KMS, they must have Slic2.1 in BIOS.

Aside from that, what happens if you just install the image, WITHOUT all the Lenono updates, still freezing?
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.

"Computers don't lie, but liars can compute." (Terry Hayes)

Jake.Werecat
Freshman Member
Posts: 83
Joined: Thu May 09, 2019 6:46 pm
Location: Cracow, Poland

Re: Windows taskbar freezes for 30s after boot

#3 Post by Jake.Werecat » Mon Jan 27, 2020 3:52 am

Ad.1) Two different images - my gf prefers Windows in a different language, so I use a separate image for her PCs.
Ad.2) Shame to admit not-knowing, but what does "KMS version" mean? Each laptop has a separate Win 7 PROF COA sticker under the battery, they all go smoothly with online activation.
Ad.3) Nope, clean install of windows boots in a blink of a moment, with no hangs. The problem starts after installing all the drivers and Lenovo applications.
X61f, 2x X230, 2x T430

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 20769
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: Windows taskbar freezes for 30s after boot

#4 Post by RealBlackStuff » Mon Jan 27, 2020 4:14 am

KMS = key management system, used by companies who use one main server with the M$-key, and all other machines are linked to that server to only activate WITHIN the company.
If they can't link to that server, Windows will not let you in.

You'll need to do Lenovo updates one by one and check after each update, until you find the 'sinner'.
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.

"Computers don't lie, but liars can compute." (Terry Hayes)

Jake.Werecat
Freshman Member
Posts: 83
Joined: Thu May 09, 2019 6:46 pm
Location: Cracow, Poland

Re: Windows taskbar freezes for 30s after boot

#5 Post by Jake.Werecat » Sun Feb 16, 2020 11:22 pm

Thanks for your reply & explanations. No, definitely no KMS - all 4 machines are home-used, I'm just putting in the windows key from COA sticker under the battery, and get the system activated. No greater magic involved.
So meanhwile the problem on one of X230 grew stronger, instead of frozen taskbar I got black screen with only the cursor. But everything has its advantages, it overcame my laziness and pushed me to do some investigation. The issue is definitely related to WWAN modem and Access Connections.
1) Only the machines with present SIM card are affected. When I take it off - no problem.
2) Only machines with Access Connections app installed are affected. After removing it, and inserting the SIM card - no problem.
3) Reinstalling of Access Connections fixed the problem partially. I mean it's better but it's still not good. The black screen & cursor issues is gone, and the instead of freezing there is what I'd call a small lag, but AcSvc.exe uses ~30% of CPU for ~15s after startup.
Now what I'm thinking. Not using Access Connection is an effective workaround. But I like using it, it gives nice signal strength indicator, ability to use profiles and gives a possibility of setting up hotspot. I'm installing the application from file on my HDD, I tried to to download a fresh installer from lenovo site, but I just can't find it anywhere! It used to be here: https://support.lenovo.com/us/en/solutions/ht037696
just few months ago, right on the top of the table, and now it's gone with no tracy.
Any help will be highly appreciated.
X61f, 2x X230, 2x T430

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 20769
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: Windows taskbar freezes for 30s after boot

#6 Post by RealBlackStuff » Mon Feb 17, 2020 3:18 am

Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.

"Computers don't lie, but liars can compute." (Terry Hayes)

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X230-X280 / X390 Series”

Who is online

Users browsing this forum: No registered users and 33 guests