Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

X230 a very strange story - lets troubleshoot!

X200, X201, X220 (including equivalent tablet models) and X300, X301 series specific matters only.
Post Reply
Message
Author
Matteone
Posts: 22
Joined: Thu Dec 28, 2017 10:06 am
Location: Germany

X230 a very strange story - lets troubleshoot!

#1 Post by Matteone » Tue Mar 31, 2020 2:24 pm

Hej Thinkpeople!

I encountered a very strange failure in my X230 yesterday. I would like to describe the story:

I traveled several kilometers by car with my Thinkpad in a sleeve. After a couple of days I turned the X230 on and the screen was turning on and off. Kind of randomly. I thought maybe the connection to the display connector was loose or something with my LCD screen was not working correctly. But when I started the OS I recognized that the laptop tried constantly to go to sleep.
It was like staying logged in and after a random amount of time the Laptop was logging of automatically. Even when I did not touch anything. It was not predictable (from 5sec - 5min).

I assume the reason for the behavior of my screen and the flickering was not caused by a faulty connection. Anyways I wanted to figure out if all connections are fine, if the RAM or the SSD or something else was faulty.

So I tried to start the X230 today. Nothing happened. Only the green back battery light turned on when I plugged the power cable in. Hmmm.

I opened the Laptop, tried first with no RAM, then one DIMM in one slot, one DIMM in the other slot etc. RAM was working in another device perfectly. Still nothing.
I swapped the keyboard for another one (classic keyboard mod). Still nothing.
I put out the SSD and all unnecessary connections.
Waited for 1 hour without CMOS connected. Nothing. Swapped the CMOS. Nothing.
Connected only the power cable without CMOS. Nothing.
Still no beep, black screen, no fan...

I reassembled everything and still nothing.

Now I am asking for support. What should I do next?

I opened around 20 Thinkpads in my life and everytime I fixed the failure they got. This time is different. I am really ashamed because I did not thought about the Thinkpad in my car for two nights and it was quite cold during the night (3-5°C) and during the day it was sunny (10-15°C). Maybe some moisture destroyed some components at my mainboard. Hmmm. I did not turn the machine on for another seven days after this happened. Then the ramdomly going to sleep started yesterday and today it is kind of dead.

Thank you very much!
:bow:

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 21173
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: X230 a very strange story - lets troubleshoot!

#2 Post by RealBlackStuff » Wed Apr 01, 2020 12:57 am

Begin with removing the battery.
Then try and boot in Safe Mode (press F8 at cold boot).
If you run W10, make sure it is fully switched off first: https://www.isumsoft.com/windows-10/2-w ... tdown.html
Try another HDD/SSD drive with a different OS.
Also, use an external CD/DVD-drive and run some Life-Linux to see if the problem persists.
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.

Matteone
Posts: 22
Joined: Thu Dec 28, 2017 10:06 am
Location: Germany

Re: X230 a very strange story - lets troubleshoot!

#3 Post by Matteone » Wed Apr 01, 2020 3:15 am

RealBlackStuff wrote:
Wed Apr 01, 2020 12:57 am
Begin with removing the battery.
Then try and boot in Safe Mode (press F8 at cold boot).
If you run W10, make sure it is fully switched off first: https://www.isumsoft.com/windows-10/2-w ... tdown.html
Try another HDD/SSD drive with a different OS.
Also, use an external CD/DVD-drive and run some Life-Linux to see if the problem persists.
Thank you for your reply and recommendations. The Laptop is not starting at all. No bootlogo, no fan movement, no beep... really nothing. Only the Battery LED is going on, when I plug in the power cable. Even without a hard disk nothing happened. I also tried to do a reset by taking out the CMOS for 1 hour. Still nothing.

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 21173
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: X230 a very strange story - lets troubleshoot!

#4 Post by RealBlackStuff » Wed Apr 01, 2020 5:15 am

Try standard "reset": remove charger, battery, CMOS-battery, HDD/SSD, RAM, wifi card, any USB stuff.
Just to make sure, remove/reseat the keyboard connector.
Then press and hold down the power button for ~20 seconds.
Attach only charger, try to start, it should beep 1-3-3-1 if any life left in the motherboard.
If not, look for another mobo.

If beep, disconnect charger, add 1 RAM and try boot.
Move RAM to other slot, try again.
Repeat with other RAM.
Repeat with both RAM.
Add 1 other item, try again, etc.
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.

axur-delmeria
Senior ThinkPadder
Senior ThinkPadder
Posts: 2598
Joined: Mon May 28, 2012 5:49 am
Location: Metro Manila, Philippines

Re: X230 a very strange story - lets troubleshoot!

#5 Post by axur-delmeria » Wed Apr 01, 2020 5:29 am

If it doesn't give a 1-3-3-1 error beep code when powered up without any RAM installed, it's very much dead.
Daily driver: X220 4291-C91 i7-2620M

Backup: X601 Core 2 Duo T8100
Toy: X60F Core Solo U1300
On loan: X220 4291-P79 i5-2520M
In pieces: two retired but working X61Ts
RIP: 760XD 9546-U9E; X61 7676-A24; and a BOE-Hydis HV121P01-100 in failed SXGA+ mod
:cry:

Matteone
Posts: 22
Joined: Thu Dec 28, 2017 10:06 am
Location: Germany

Re: X230 a very strange story - lets troubleshoot!

#6 Post by Matteone » Wed Apr 01, 2020 6:42 am

Yes. The X230 does not do anything. No beep without RAM. I thought the same. It is pretty much dead. Any options? Taking the mainboard out and test it without anything attached?

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 21173
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: X230 a very strange story - lets troubleshoot!

#7 Post by RealBlackStuff » Wed Apr 01, 2020 6:58 am

Just replace it.
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X200/201/220 and X300/301 Series”

Who is online

Users browsing this forum: No registered users and 12 guests