Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

x62 mobo not booting, flash bios?

Old(er) Thinkpads with New(er) Intestines: X62/T50/T70/X210/X330 etc.
Post Reply
Message
Author
Roch
Posts: 4
Joined: Fri Jan 10, 2020 7:05 pm
Location: Tucson, AZ

x62 mobo not booting, flash bios?

#1 Post by Roch » Tue Jun 09, 2020 2:09 am

Hey all

I have a 3rd batch x62 mobo that was running fine then stopped booting. On first plug in the fan will spin up very briefly then stop. Subsequent power off and power on only turns on power indicator leds. My t430s is a little long in the tooth so I'd like to revive this thing. I purchased a ch341 programmer (I also have a raspberry pi just in case) and got the latest bios from 51nb.

Are there things I should try before flashing? So far I've:
  • tried various ram sticks
  • tried connecting to external display
  • with battery/without battery
As this is my first bios flash via clips can someone point me in the right direction for pitfalls to avoid / which chips to flash?

https://imgur.com/a/Fb2U779 <--pics of the mobo

lulujyc
Freshman Member
Posts: 63
Joined: Sun Feb 09, 2020 7:08 am
Location: Beijing, CN

Re: x62 mobo not booting, flash bios?

#2 Post by lulujyc » Tue Jun 09, 2020 3:15 am

Roch wrote:
Tue Jun 09, 2020 2:09 am
Hey all

I have a 3rd batch x62 mobo that was running fine then stopped booting. On first plug in the fan will spin up very briefly then stop. Subsequent power off and power on only turns on power indicator leds. My t430s is a little long in the tooth so I'd like to revive this thing. I purchased a ch341 programmer (I also have a raspberry pi just in case) and got the latest bios from 51nb.

Are there things I should try before flashing? So far I've:
  • tried various ram sticks
  • tried connecting to external display
  • with battery/without battery
As this is my first bios flash via clips can someone point me in the right direction for pitfalls to avoid / which chips to flash?

https://imgur.com/a/Fb2U779 <--pics of the mobo
were you doing something related to the bios before the board dies? if not, it's very likely that the issue is not related to the bios. probably try asking your original seller to see if they can help.
X61HK (8250u, SXGA, 16+512+1t, macOS)
T4200s (10510u, 1080p, 16+256+1t, macOS)

Roch
Posts: 4
Joined: Fri Jan 10, 2020 7:05 pm
Location: Tucson, AZ

Re: x62 mobo not booting, flash bios?

#3 Post by Roch » Tue Jun 09, 2020 3:37 am

lulujyc wrote:
Tue Jun 09, 2020 3:15 am

were you doing something related to the bios before the board dies? if not, it's very likely that the issue is not related to the bios. probably try asking your original seller to see if they can help.
Thanks for the reply

I don't believe so, but tbh it's been years

I remember the problem came about gradually. First it would boot very slowly after a shutdown, black screen on power on then wait 20 secs, then 40 seconds. Then eventually no boot.

Kingair
Freshman Member
Posts: 83
Joined: Mon Apr 20, 2020 3:00 pm
Location: Mexicali, MX (Coachella)

Re: x62 mobo not booting, flash bios?

#4 Post by Kingair » Tue Jun 09, 2020 8:24 pm

lulujyc wrote:
Tue Jun 09, 2020 3:15 am

were you doing something related to the bios before the board dies? if not, it's very likely that the issue is not related to the bios. probably try asking your original seller to see if they can help.
I was thinking the same
Why not ship the mobo back and have it inspected ?
Probably not the cheapest and fastest solution these days but than the problem should be solved

Roch
Posts: 4
Joined: Fri Jan 10, 2020 7:05 pm
Location: Tucson, AZ

Re: x62 mobo not booting, flash bios?

#5 Post by Roch » Tue Jun 09, 2020 8:46 pm

Kingair wrote:
Tue Jun 09, 2020 8:24 pm
lulujyc wrote:
Tue Jun 09, 2020 3:15 am

were you doing something related to the bios before the board dies? if not, it's very likely that the issue is not related to the bios. probably try asking your original seller to see if they can help.
I was thinking the same
Why not ship the mobo back and have it inspected ?
Probably not the cheapest and fastest solution these days but than the problem should be solved
unfortunately this was a fleabay purchase, I might be S.O.L. on that front. Anything I can try beforehand?

lulujyc
Freshman Member
Posts: 63
Joined: Sun Feb 09, 2020 7:08 am
Location: Beijing, CN

Re: x62 mobo not booting, flash bios?

#6 Post by lulujyc » Tue Jun 09, 2020 9:10 pm

Roch wrote:
Tue Jun 09, 2020 8:46 pm
Kingair wrote:
Tue Jun 09, 2020 8:24 pm

I was thinking the same
Why not ship the mobo back and have it inspected ?
Probably not the cheapest and fastest solution these days but than the problem should be solved
unfortunately this was a fleabay purchase, I might be S.O.L. on that front. Anything I can try beforehand?
thats very likely to be a mobo problem. i guess you can either find a very trustworthy local board repair company or ship it back to shenzhen. 51nb guys in shenzhen only costs you 200 rmb (30usd) to fix the board most of the time but shipping is the huge part.
X61HK (8250u, SXGA, 16+512+1t, macOS)
T4200s (10510u, 1080p, 16+256+1t, macOS)

Roch
Posts: 4
Joined: Fri Jan 10, 2020 7:05 pm
Location: Tucson, AZ

Re: x62 mobo not booting, flash bios?

#7 Post by Roch » Tue Jun 09, 2020 10:08 pm

lulujyc wrote:
Tue Jun 09, 2020 9:10 pm

thats very likely to be a mobo problem. i guess you can either find a very trustworthy local board repair company or ship it back to shenzhen. 51nb guys in shenzhen only costs you 200 rmb (30usd) to fix the board most of the time but shipping is the huge part.
Thanks again,


Well that's unfortunate. What are the current channels to communicate with 51nb or an appropriate company that can repair? cnmod? xytech? 51nb forums?

lulujyc
Freshman Member
Posts: 63
Joined: Sun Feb 09, 2020 7:08 am
Location: Beijing, CN

Re: x62 mobo not booting, flash bios?

#8 Post by lulujyc » Wed Jun 10, 2020 1:28 am

Roch wrote:
Tue Jun 09, 2020 10:08 pm
lulujyc wrote:
Tue Jun 09, 2020 9:10 pm

thats very likely to be a mobo problem. i guess you can either find a very trustworthy local board repair company or ship it back to shenzhen. 51nb guys in shenzhen only costs you 200 rmb (30usd) to fix the board most of the time but shipping is the huge part.
Thanks again,


Well that's unfortunate. What are the current channels to communicate with 51nb or an appropriate company that can repair? cnmod? xytech? 51nb forums?
Both CNMOD and XYTECH are resellers if I'm not wrong. You can directly communicate with the 51nb customer services via Tencent QQ probably using translation softwares. My suggestion is to find a friend living in China or knows Chinese to help you send the board back to them. They use Alipay instead of Paypal to receive the cost of fixing the board
X61HK (8250u, SXGA, 16+512+1t, macOS)
T4200s (10510u, 1080p, 16+256+1t, macOS)

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “51nb and other modded Thinkpads”

Who is online

Users browsing this forum: No registered users and 11 guests