Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

No graphic signal on P50

P1/P40/P50/P70 Series
Post Reply
Message
Author
Renz
Freshman Member
Posts: 65
Joined: Sun Feb 07, 2016 8:07 pm
Location: Brunswick AU

No graphic signal on P50

#1 Post by Renz » Wed Sep 13, 2023 11:37 am

Hi,

It happened a couple of days ago, it was resting on the sofa, thought it was put on hold previously but one I grabbed it, I was surprised that it was feeling a little hot. No image on screen after the boot, however everything else seemed to go normally. Keyboard lits up, hear the SSD scratching but then it stops, which is perhaps normal.

Since this laptop has a dual graphics card, I plugged an external screen via HDMI and even then the screen would correctly detect that the cable was connected, I was informed that no signal was being sent to it.

I don't believe there would be anything wrong going on with the mounted screen as, since the secondary GPU would not be outputting either, then it made me think that the issue would be manifesting somewhere upstream. Whilst the MB seems to be doing it's job normally.

I have this other P50 that I use for parts, the motherboard won't start for some reason but the GPU parts can be used to troubleshoot. I had a go with Bing IA and went through the maximum of it's capabilities unfortunately, even though I did enjoy this experience.

If anyone has any idea regarding what I am supposed to do now as I am getting a little confused, probably because my knowledge was perhaps maxed out as I am not a specialist in PC hardware even though I did start a long time ago building my own desktops.

I would like to try to avoid to just replace the MB when the issue can perhaps get fixed easily since I have some parts available here and suitable agility to serve the purpose.

Thanks

TPFanatic
Senior ThinkPadder
Senior ThinkPadder
Posts: 2183
Joined: Thu Jul 30, 2015 11:29 pm
Location: Boston, Massachusetts

Re: No graphic signal on P50

#2 Post by TPFanatic » Wed Sep 13, 2023 12:00 pm

External video relies on the Nvidia GPU.

In my experience the Nvidia graphics driver likes to automatically update itself, and Windows likes to automatically update all sorts of things, and if something interrupts either of these processes things can break.

What happens if you try reinstalling the Nvidia driver?

Renz
Freshman Member
Posts: 65
Joined: Sun Feb 07, 2016 8:07 pm
Location: Brunswick AU

Re: No graphic signal on P50

#3 Post by Renz » Wed Sep 13, 2023 12:52 pm

How do I do that if I can't see what I'm doing?

How can I swap the GPUs between my MBs?

TPFanatic
Senior ThinkPadder
Senior ThinkPadder
Posts: 2183
Joined: Thu Jul 30, 2015 11:29 pm
Location: Boston, Massachusetts

Re: No graphic signal on P50

#4 Post by TPFanatic » Wed Sep 13, 2023 1:01 pm

My bad, I didn't read that part.

The GPUs are not swappable.

Renz
Freshman Member
Posts: 65
Joined: Sun Feb 07, 2016 8:07 pm
Location: Brunswick AU

Re: No graphic signal on P50

#5 Post by Renz » Wed Sep 13, 2023 2:07 pm

Why not?

What if I manage to remove the GPU of the other MB and insert it instead of the one possibly causing the issue? To my knowledge, all P50 MBs are equivalent or are they not?

TPFanatic
Senior ThinkPadder
Senior ThinkPadder
Posts: 2183
Joined: Thu Jul 30, 2015 11:29 pm
Location: Boston, Massachusetts

Re: No graphic signal on P50

#6 Post by TPFanatic » Wed Sep 13, 2023 4:01 pm

You can try. People have done transplants on BGA CPUs, why not a GPU? :D Please update if you're successful.

If it was me, going through the trouble of removing the motherboard anyway, I'd just replace in a working motherboard if I could get one for a good price, if I loved the laptop enough. Otherwise I'd get a new laptop.

Renz
Freshman Member
Posts: 65
Joined: Sun Feb 07, 2016 8:07 pm
Location: Brunswick AU

Re: No graphic signal on P50

#7 Post by Renz » Thu Sep 14, 2023 1:23 pm

There would be no stimulation if Iwould not, or would there

Renz
Freshman Member
Posts: 65
Joined: Sun Feb 07, 2016 8:07 pm
Location: Brunswick AU

Re: No graphic signal on P50

#8 Post by Renz » Sun Sep 17, 2023 5:29 am

Well, that was looking a bit too challenging for the kind of soldering equipment I have available here since the graphic chip is not mounted on a socket as I was expecting.

What I can do is to take it to a repair store however I may get charged for the quote so that's a bit risky, otherwise I can just order a new MB from Aliexpress, they seem to charge around $120 for them, but if I want to go that way, I would like to make sure I'm getting the exact same MB or something I can work with, more powerful would be good, otherwise, happy with whatever really.

Here are some shots I made from info on the board itself https://photos.app.goo.gl/wR91qNWePqAp74pE6

My impression is that there are no heat marks anywhere on the fan assembly that includes the copper housing, I've seen heat damage on pictures and my assembly has no marks from heat, so that's kind of strange.

Let me know, and yeah thanks for your help.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad P1/P40/P50/P70 and later Series”

Who is online

Users browsing this forum: No registered users and 8 guests