Windows 7 Hangs on Black Screen after Windows Welcome

Windows 7 on ThinkPads
Post Reply
Message
Author
Kaze22
Sophomore Member
Posts: 159
Joined: Sat Mar 24, 2012 1:38 pm
Location: Vancouver, Canada

Windows 7 Hangs on Black Screen after Windows Welcome

#1 Post by Kaze22 » Thu Apr 26, 2012 4:09 pm

Weirdest problem. Suddenly out of nowhere my Windows 7 is acting up on my W520.
It starts up fine, but hangs for like 2 full minutes on a blank black screen right after the windows welcome screen loads.
You can move the cursor around, but it won't login to Windows for like 2 minutes. It just stays frozen on a blank black screen.

I've never seen this before in my life. It's completely stumped me. I've done memory diagnostics, SSD diagnostic, even ran a full system scan using PC Doctor, seems like everything is fine. It's got to be an O.S issue. I would use system restore, but I deleted the restore files last week. Seems like Windows hasn't made a new restore point.

Anyone have any suggestions?
Thinkpad W520 | Intel i7 2.5 XM | 1920x1080 FHD 95% Gamut | 32 GB DDR3 | 128GB MyDigitalSSD mSATA SSD | 2GB NVIDIA QUADRO 2000M | UEFI WIN 7

killer
ThinkPadder
ThinkPadder
Posts: 1483
Joined: Mon May 28, 2007 5:26 am
Location: West Sussex, UK

Re: Windows 7 Hangs on Black Screen after Windows Welcome

#2 Post by killer » Thu Apr 26, 2012 5:31 pm

My instinct would be to use a Linux OS disk to get a working system so you can copy any files from windows to an external hard drive. Then I'd try using R&R to restore windows to an earlier date. If that doesn't work then, having backed everything up as in paragraph one using Linux, I'd do a factory restore. If you haven't created your factory restore disks you might be up the creek without a paddle.
T540p Win 7 Pro 64

X1 Carbon Win 7 Pro 64 for my wife.

Time flies like an arrow; fruit flies like a banana.

Dogs must be carried on the escalator. Where can I find a dog?

Kaze22
Sophomore Member
Posts: 159
Joined: Sat Mar 24, 2012 1:38 pm
Location: Vancouver, Canada

Re: Windows 7 Hangs on Black Screen after Windows Welcome

#3 Post by Kaze22 » Thu Apr 26, 2012 5:35 pm

It eventually loads windows just takes 2 minutes.
Very odd.
Thinkpad W520 | Intel i7 2.5 XM | 1920x1080 FHD 95% Gamut | 32 GB DDR3 | 128GB MyDigitalSSD mSATA SSD | 2GB NVIDIA QUADRO 2000M | UEFI WIN 7

Kaze22
Sophomore Member
Posts: 159
Joined: Sat Mar 24, 2012 1:38 pm
Location: Vancouver, Canada

Re: Windows 7 Hangs on Black Screen after Windows Welcome

#4 Post by Kaze22 » Fri Apr 27, 2012 1:43 am

Issue fixed. Found an old Rescue Recover Backup on one of my old HDD, and voila a clean image ghosting and the problem was solved.
Too bad, we will never find the root of the problem.
Windows is just so [censored] buggy.
Almost makes me wanna switch to Mac. :twisted:

Lesson to future Thinkpadders, always keep an old rescue recover backup of your system running in peak condition, you never know when Windows will crap out for no good reason.

Thank god for Thinkvantage tools.
Thinkpad W520 | Intel i7 2.5 XM | 1920x1080 FHD 95% Gamut | 32 GB DDR3 | 128GB MyDigitalSSD mSATA SSD | 2GB NVIDIA QUADRO 2000M | UEFI WIN 7

twistero
Senior Member
Senior Member
Posts: 851
Joined: Sun Feb 26, 2012 2:25 am
Location: Princeton, New Jersey
Contact:

Re: Windows 7 Hangs on Black Screen after Windows Welcome

#5 Post by twistero » Fri Apr 27, 2012 4:45 am

X60 tablet 6363-P3U, 3GB ram, 128GB SanDisk Extreme SSD, SXGA+ screen, Intel 6300
T61 Frankenpad in 15 inch T60 body, UXGA LED-lit AFFS LCD, T9300, 6GB RAM, NVidia NVS140m, Intel 6205, 128GB Crucial M4 SSD, 1TB HGST HDD + eBay caddy in Ultrabay
701c butterfly, 75MHz 486DX4, 40MB ram, 1GB CF card

Kaze22
Sophomore Member
Posts: 159
Joined: Sat Mar 24, 2012 1:38 pm
Location: Vancouver, Canada

Re: Windows 7 Hangs on Black Screen after Windows Welcome

#6 Post by Kaze22 » Fri Apr 27, 2012 10:55 am

These guys seem to experience a hang during the windows boot screen with the Windows Welcome Logo.
What I was experience was the blank black screen that comes after the Windows Welcome Logo has already loaded.

On a normal Win 7. There should be only a 1 second gap between the Welcome Screen ending and the Login Screen appearing, during this 1 second a blank black screen is shown.
Usually you won't even notice it cause it comes and goes so quick.

But for me the blank black screen was there for 2-3 minutes.
Thinkpad W520 | Intel i7 2.5 XM | 1920x1080 FHD 95% Gamut | 32 GB DDR3 | 128GB MyDigitalSSD mSATA SSD | 2GB NVIDIA QUADRO 2000M | UEFI WIN 7

SchlageR
Posts: 37
Joined: Thu Jul 14, 2011 10:58 pm
Location: Miami, Florida

Re: Windows 7 Hangs on Black Screen after Windows Welcome

#7 Post by SchlageR » Tue May 08, 2012 11:54 pm

From my experience, it is "Lenovo welcome". When I originally purchased my thinkpad it was installed and I noticed that problem. I did a clean install from retail disk and the problem was gone.
:banana: Thinkpads! :banana:

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “Windows 7”

Who is online

Users browsing this forum: No registered users and 3 guests