Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T420s no backlight

T400/410/420 and T500/510/520 series specific matters only
Post Reply
Message
Author
thinkspot
Posts: 4
Joined: Sun May 01, 2016 8:11 am
Location: Hamburg, Germany

T420s no backlight

#1 Post by thinkspot » Sun May 01, 2016 8:16 am

Hi,

i have a T420s, unfortunately the backlight is not working anymore.

I had this before on a T400s, soldering a fuse solved it.


Does anyone have an idea which are the backlight fuses on a T420s?

Here 2 photos:

http://s32.postimg.org/5beawzx2d/t420s_down.jpg

http://s32.postimg.org/75w7buqed/t420s_up.jpg


Thanks

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 20020
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Ireland
Contact:

Re: T420s no backlight

#2 Post by RealBlackStuff » Sun May 01, 2016 8:29 am

Why don't you measure those fuses with a multimeter?
Then solder a new one on top of the bad one, piggyback-style.
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!

thinkspot
Posts: 4
Joined: Sun May 01, 2016 8:11 am
Location: Hamburg, Germany

Re: T420s no backlight

#3 Post by thinkspot » Sun May 01, 2016 12:01 pm

RealBlackStuff wrote:Why don't you measure those fuses with a multimeter?
Then solder a new one on top of the bad one, piggyback-style.
Unfortunately i don't have a multimeter, but i will get one and post my result.
Thanks

thinkspot
Posts: 4
Joined: Sun May 01, 2016 8:11 am
Location: Hamburg, Germany

Re: T420s no backlight

#4 Post by thinkspot » Sun May 29, 2016 3:45 pm

I found the faulty fuse, it's F7 (see red circle on the photo).

Unfortunately i ripped of the capacitor (i think it is one) to the right (blue circle on the photo).

It still works though...anyone have an idea how important this capacitor is?

http://s33.postimg.org/ig3cnqr73/t420s_up_edit.jpg


MOD edit: Picture WAY too big, tags removed. Please read Forum Rules of the Road

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 20020
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Ireland
Contact:

Re: T420s no backlight

#5 Post by RealBlackStuff » Sun May 29, 2016 4:15 pm

Capacitor C313 = 1UF_25V (a.k.a X5R, size 1608)
http://www.mouser.com/search/ProductDet ... H104K080AA

I'd say replace it, something else might cause damage if it remains missing.

thinkspot
Posts: 4
Joined: Sun May 01, 2016 8:11 am
Location: Hamburg, Germany

Re: T420s no backlight

#6 Post by thinkspot » Sun May 29, 2016 5:01 pm

Thanks for the link!

The problem is my very basic soldering-equipment and poor soldering skills...

I still have the ripped of capacitor, i already tried to solder it back on but it's soooo small :-)

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T400/410/420 and T500/510/520 Series”

Who is online

Users browsing this forum: No registered users and 11 guests