Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Enabling advanced Touchpad features with registry

T4x series specific matters only
Post Reply
Senior Member
Senior Member
Posts: 927
Joined: Thu Jul 30, 2015 11:29 pm
Location: Boston, Massachusetts

Enabling advanced Touchpad features with registry

#1 Post by TPFanatic » Sat Dec 17, 2016 10:16 pm

Backstory: I realized there was something screwy when my Z60m's Windows 7 environment, cloned from my T410, had advanced Synaptics touchpad features: two finger scrolling, Chiral scrolling, and Application gestures visible and enabled in the user maintained through the migration. But when I made a new user, these options are invisible to toggle from the newly created user for that user with the Z60m's unsupported touchpad. But the features work 100%.

I did some researching and found that modding the registry can make these options visible on "unsupported" Touchpads like I just did on this T42p.

With the latest Thinkpad Ultranav driver, open regedit and navigate to

Code: Select all

Now the following features that were missing that I enabled were under the following subfolders:

Code: Select all

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPCpl\Controls\2Scrolling\1One-Finger Scrolling\3Chiral
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPCpl\Controls\2Scrolling\2Two-Finger Scrolling
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPCpl\Controls\2Scrolling\2Two-Finger Scrolling\1Vertical
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPCpl\Controls\2Scrolling\2Two-Finger Scrolling\2Horizontal
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPCpl\Controls\2Scrolling\2Two-Finger Scrolling\1Vertical
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPCpl\Controls\8Application Gestures
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPCpl\Controls\8Application Gestures\1Three Fingers Down
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPCpl\Controls\8Application Gestures\2Three-Finger Flick
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPCpl\Controls\8Application Gestures\30Four-Finger Flick
Can also see my images here:
https://s30.postimg.org/k8xe5ld4h/appli ... 8_to_0.png
https://s30.postimg.org/rdf7emkdt/chira ... 4_to_0.png
https://s30.postimg.org/6hsx3do6p/two_f ... 4_to_0.png

Now find the REG_DWORD called Visibility in all of these and change its value from 8 or 4 to 0. 0 will make them visible. You may to do the same for the subfolders to get the actual options visible as well.

There are also other gestures under \Controls like \3Pinch Zoom, \4Rotating, \4TwistRotate that I did not enable, but you could with the same method of setting Visibility value to 0.

This works on T42p. The only incompatibility I've found so far is with Horizontal 2 finger scrolling, enabling that in tandem with Vertical 2 finger scrolling makes any 2 finger scrolling impossible or requiring too much force so leave that disabled.

I quite like these features so with them enabled you can turn your T42p (or T60, Z60, T61, T500, anything with a Synaptics touchpad) into a Macbook... or a T410. You also don't need to install the HP driver that includes unsatisfactory Trackpoint controls, or go through the other best process of uinstalling your ultranav driver, use a USB mouse to install the HP driver, then install the Ultranav driver on top of that and hope it works. All the features exist in the latest driver, just do not make themselves visible on Synaptics touchpads older than T410's. This enables them.

Have fun.
lenovo T61 T7500, SXGA+, 8GB
lenovo T430 i5 3320m, HD+, 8GB
lenovo T500 P9700, WUXGA, 8GB
lenovo X201 i5 520m, WXGA, 4GB
lenovo T520 i7 2760QM, FHD, 8GB

Enable advanced features on older Synaptics touchpads with the registry: http://forum.thinkpads.com/viewtopic.php?f=2&t=122612

Posts: 1110
Joined: Tue Sep 22, 2015 10:59 pm
Location: Toronto, Canada

Re: Enabling advanced Touchpad features with registry

#2 Post by kfzhu1229 » Tue Dec 20, 2016 9:39 pm

I will try these settings. I have no idea how I got multi-touch on one copy of Windows 10 on my T43 but not other copies. There isn't even settings or anything but two-finger scrolling was just enabled by some kind of Windows update glitch or something
UPDATE: I tried to change the DWORD from 8 to 0 and indeed the menu shows up and works. However I am still NOT able to figure out why my other T43's system had it enabled. I checked the registers and they all look identical. Pretty weird, huh!
Patience, boys. All good things to those who wait. – Mother Gothel (Tangled)
T23 PIII 1.13ghz 1gb W7
2xT43 14.1" 2.26 SXGA+ 2gb 1*fp W10
T530i 15.6" i7 16gb fp W10
Flexview UXGA:
A30p PIII 1.2 1gb W7 (IDTech)
T43p 2.26 2gb fp W10

Post Reply
  • Similar Topics
    Last post

Return to “ThinkPad T4x Series”

Who is online

Users browsing this forum: No registered users and 10 guests