Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T41 WPA2 issues?

T4x series specific matters only
Post Reply
Message
Author
mrtaufner
Posts: 22
Joined: Thu Jun 21, 2018 4:29 pm
Location: Seville, Spain

T41 WPA2 issues?

#1 Post by mrtaufner » Fri Jun 22, 2018 3:50 am

I know, this has been a classic since the dawn of the T41.

Thing is: I got this pc for pretty cheap (17€ or ~$20). It's in great condition and I just did a fresh install of WinXP and all of them drivers (which i recovered from within the HDD before formatting it, and then upgraded them with the newest ones available here).

I actually don't need internet connection in this PC... In fact it was sold to me as it had no WLAN card

(but it actually does have one, since it shows in system tray and it actually finds some SSIDs within range, including mine at home which is WPA2... It tries to establish a connection after typing down the password, but it won't connect. But as an extra, it would be neat to make it work).

I've been lurking the forums but all the info I got is old and the links to the solutions are down everytime (even on Lenovo official forums). Also, Intel ProSET wont add my wlan to the avaliable interfaces.

What can i do?

dr_st
Moderator
Moderator
Posts: 7324
Joined: Sat Oct 29, 2005 6:20 am

Re: T41 WPA2 issues?

#2 Post by dr_st » Fri Jun 22, 2018 10:26 am

Is the XP updated to SP2 at least?

What is the wireless card?
Current: Thinkpad 25 (20K7), Yoga 14 (20FY), X220 4291-4BG, T410 2537-R46, T60 2007-QPG, T42 2373-F7G
Collectibles: T430s (IPS FHD + Classic Keyboard), X32 (IPS Screen)
Retired: X61 7673-V2V, T60 1952-F76, A31p w/ Ultrabay Numpad

mrtaufner
Posts: 22
Joined: Thu Jun 21, 2018 4:29 pm
Location: Seville, Spain

Re: T41 WPA2 issues?

#3 Post by mrtaufner » Fri Jun 22, 2018 1:27 pm

dr_st wrote:
Fri Jun 22, 2018 10:26 am
Is the XP updated to SP2 at least?

What is the wireless card?
Yes, I made a fresh install of Win XP SP3 actually.

The WLAN card is the Intel PRO WLAN 2100 3B Mini PCI Adapter.

Should I change it? Aparently the most recent drivers weren't installed (Date: 28/7/2004 - V 1.2.3.14)

mrtaufner
Posts: 22
Joined: Thu Jun 21, 2018 4:29 pm
Location: Seville, Spain

Re: T41 WPA2 issues?

#4 Post by mrtaufner » Fri Jun 22, 2018 2:06 pm

FINALLY!

I just got it working and I'm actually sending this post with the T41!

I had to completely (manually) remove the WLAN folder in order to install the new drivers and it finally worked.

Thanks!

PD: however I'm now experiencing continuous reconneting to the network. Maybe the WLAN card is loose?

Screamer
Freshman Member
Posts: 106
Joined: Sun Apr 15, 2018 7:15 am
Location: Singapore

Re: T41 WPA2 issues?

#5 Post by Screamer » Fri Jun 22, 2018 2:20 pm

It can't be the wireless card that is loose for sure, but I did hear about the Intel PRO/Wireless LAN 2100 3B card being a very unstable and a bad card in general. That may be the reason why the card keeps disconnecting and reconnecting to your network. Before I make any sort of assumption, did you get the latest drivers from Intel's website?

mrtaufner
Posts: 22
Joined: Thu Jun 21, 2018 4:29 pm
Location: Seville, Spain

Re: T41 WPA2 issues?

#6 Post by mrtaufner » Fri Jun 22, 2018 2:53 pm

Screamer wrote:
Fri Jun 22, 2018 2:20 pm
It can't be the wireless card that is loose for sure, but I did hear about the Intel PRO/Wireless LAN 2100 3B card being a very unstable and a bad card in general. That may be the reason why the card keeps disconnecting and reconnecting to your network. Before I make any sort of assumption, did you get the latest drivers from Intel's website?
Nope. Actually I got the drivers from here, in the drivers section (from 2006, actually).

I'm gonna check them out right now

Edit: There are no newer drivers afaik (after a brief search on the internet) AND Intel no longer hosts drivers for this WLAN card. They're either here or in Lenovo Support Center thingy (they're the same as mine, from 2006)

RealBlackStuff
Admin
Admin
Posts: 19132
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA
Contact:

Re: T41 WPA2 issues?

#7 Post by RealBlackStuff » Fri Jun 22, 2018 3:10 pm

To get a decent wifi speed on your T41, there's this TP-LINK TL-WN861N 300Mbps Wireless Mini PCI Adapter...

It does wifi a/b/g/n
Lovely day for a Guinness! (The Real Black Stuff)

Check out The Boardroom for Parts, Mods and Other Services.

jaspen-meyer
Senior Member
Senior Member
Posts: 824
Joined: Wed May 19, 2010 11:21 pm
Location: Pardubice, Czech Republic
Contact:

Re: T41 WPA2 issues?

#8 Post by jaspen-meyer » Fri Jun 22, 2018 3:56 pm

The Intel 2100 is only an 'B' card. If you PM me your address I can send you a better card, either an Intel 2200BG or something similar. You may need to flash bios to use it though.
T420 i7 3612QM seabios; T420 i7 3630QM; T400 Q9100 seabios; T61 P9600; T60 libreboot; x62; x60s libreboot, led; x24 xiphmont led

Screamer
Freshman Member
Posts: 106
Joined: Sun Apr 15, 2018 7:15 am
Location: Singapore

Re: T41 WPA2 issues?

#9 Post by Screamer » Fri Jun 22, 2018 5:27 pm

mrtaufner wrote:
Fri Jun 22, 2018 2:53 pm
Edit: There are no newer drivers afaik (after a brief search on the internet) AND Intel no longer hosts drivers for this WLAN card. They're either here or in Lenovo Support Center thingy (they're the same as mine, from 2006)
Darn, at this point I think you should opt for a new wireless adapter. I suggest getting an 802.11abgn wireless adapter, or a 802.11bgn wireless adapter. You can take up jaspen-meyer's offer if you don't mind slower speeds with the 2200BG, or go with RealBlackStuff's suggestion of getting a WN861N. My suggestion will be an Atheros AR9220, that is an 802.11abgn wireless adapter that I have personally used.

mrtaufner
Posts: 22
Joined: Thu Jun 21, 2018 4:29 pm
Location: Seville, Spain

Re: T41 WPA2 issues?

#10 Post by mrtaufner » Fri Jun 22, 2018 9:02 pm

RealBlackStuff wrote:
Fri Jun 22, 2018 3:10 pm
To get a decent wifi speed on your T41, there's this TP-LINK TL-WN861N 300Mbps Wireless Mini PCI Adapter...

It does wifi a/b/g/n
In the mean time I can stick to it or even use a USB Wifi thingy, that I barely use.
But yea. Yet still have options, It's not that urgent for me to have internet connection in that machine.

jaspen-meyer wrote:
Fri Jun 22, 2018 3:56 pm
The Intel 2100 is only an 'B' card. If you PM me your address I can send you a better card, either an Intel 2200BG or something similar. You may need to flash bios to use it though.
Sure do. Yet I don't need internet connection in that laptop, it was already way too cheap and it deserves better. I'm also looking for 1-2GB DDR sticks and maybe a cheap SSD. I'll make this machine work as it sure did on it's good old days.

Screamer wrote:
Fri Jun 22, 2018 5:27 pm
mrtaufner wrote:
Fri Jun 22, 2018 2:53 pm
Edit: There are no newer drivers afaik (after a brief search on the internet) AND Intel no longer hosts drivers for this WLAN card. They're either here or in Lenovo Support Center thingy (they're the same as mine, from 2006)
Darn, at this point I think you should opt for a new wireless adapter. I suggest getting an 802.11abgn wireless adapter, or a 802.11bgn wireless adapter. You can take up jaspen-meyer's offer if you don't mind slower speeds with the 2200BG, or go with RealBlackStuff's suggestion of getting a WN861N. My suggestion will be an Atheros AR9220, that is an 802.11abgn wireless adapter that I have personally used.
Yea, Atheros might be the best option, since it doesn't give that many problems when installing leenex :mrgreen: (which i will do on this T41 sooner than later). Broadcom cards are a pain in the [censored], tho

sdfox7
Freshman Member
Posts: 102
Joined: Mon Sep 01, 2014 10:06 pm
Location: Danbury, CT

Re: T41 WPA2 issues?

#11 Post by sdfox7 » Thu Jul 12, 2018 12:33 am

I've never had success connecting my T40 or T41 to WPA2 with the integrated 2100 card. I don't think the 2100 cards are compatible at all with WPA2.

I've been using Netgear USB N600 on these machines instead.
IBM ThinkPad 600E 2645-8AU (Win98), T23 2647-4MU (Win2000), T41 2373-7FU (WinXP)
My name is Stephen Fox. I am a '18 BBA and '20 MBA student at WCSU.
Disable Google Chrome End of Support Infobar on Windows XP/Vista

ajkula66
SuperUserGeorge
SuperUserGeorge
Posts: 16112
Joined: Sun Feb 25, 2007 11:28 am
Location: Brodheadsville, Pennsylvania, USA

Re: T41 WPA2 issues?

#12 Post by ajkula66 » Thu Jul 12, 2018 4:21 am

sdfox7 wrote:
Thu Jul 12, 2018 12:33 am
I've never had success connecting my T40 or T41 to WPA2 with the integrated 2100 card. I don't think the 2100 cards are compatible at all with WPA2.

I've been using Netgear USB N600 on these machines instead.
I've read conflicting reviews regarding 2100B and WPA2. Can't remember the last time I actually used the card in question, though.

With that being said, there's a number of mini-PCI cards that can be swapped in - TP Link 861N being my preferred one - and it only takes a couple of minutes with "no-1802" hack to get them working on these old systems...
...Knowledge is a deadly friend when no one sets the rules...(King Crimson)

Cheers,

George (your grouchy retired FlexView farmer)

AARP club members:A31p, T42, T43pSF

Abused daily: T61p

PMs requesting personal tech support will be ignored.

dr_st
Moderator
Moderator
Posts: 7324
Joined: Sat Oct 29, 2005 6:20 am

Re: T41 WPA2 issues?

#13 Post by dr_st » Thu Jul 12, 2018 9:02 am

WPA2, not WPA2... Most routers with WPA2 capability also support WPA; the biggest problem with the 2100B is the 802.11b speed (11mbps vs 54mbps on 802.11g and 150mbps+ on 802.11n).
Current: Thinkpad 25 (20K7), Yoga 14 (20FY), X220 4291-4BG, T410 2537-R46, T60 2007-QPG, T42 2373-F7G
Collectibles: T430s (IPS FHD + Classic Keyboard), X32 (IPS Screen)
Retired: X61 7673-V2V, T60 1952-F76, A31p w/ Ultrabay Numpad

mrtaufner
Posts: 22
Joined: Thu Jun 21, 2018 4:29 pm
Location: Seville, Spain

Re: T41 WPA2 issues?

#14 Post by mrtaufner » Mon Aug 06, 2018 9:54 am

ajkula66 wrote:
Thu Jul 12, 2018 4:21 am
sdfox7 wrote:
Thu Jul 12, 2018 12:33 am
I've never had success connecting my T40 or T41 to WPA2 with the integrated 2100 card. I don't think the 2100 cards are compatible at all with WPA2.

I've been using Netgear USB N600 on these machines instead.
I've read conflicting reviews regarding 2100B and WPA2. Can't remember the last time I actually used the card in question, though.

With that being said, there's a number of mini-PCI cards that can be swapped in - TP Link 861N being my preferred one - and it only takes a couple of minutes with "no-1802" hack to get them working on these old systems...
Do you know where can I find this "compatibles" list?

But yea, the laptop still connects to my network. The downside is that it loses connection every few minutes and downloading stuff may be (and in fact is) a problem.

Utwig
Junior Member
Junior Member
Posts: 310
Joined: Sun May 21, 2006 8:52 pm
Location: Slovenia/Europe

Re: T41 WPA2 issues?

#15 Post by Utwig » Mon Aug 06, 2018 5:23 pm

I remember I had b only card in my T42p and i couldn't enable WPA2 on the router, had to leave network at WPA only. Then I upgraded the card to Intel 2200bg (n was only becoming mainstream at the time) and always had stable wifi with my then WRT54GL.
T540p, T420s, T400, R61, X61t, T60p, T42p, A21p

RealBlackStuff
Admin
Admin
Posts: 19132
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA
Contact:

Re: T41 WPA2 issues?

#16 Post by RealBlackStuff » Tue Aug 07, 2018 5:02 am

As long as you apply the NO-1802 hack, you can install any wifi-card that fits in that slot.
As mentioned before, your best (and fastest) bet is the TP Link 861N. Up to 300Mbps
Cheaper/decent ones with WPA2 include the above Intel 2200BG. Up only to 54Mbps.

sdfox7
Freshman Member
Posts: 102
Joined: Mon Sep 01, 2014 10:06 pm
Location: Danbury, CT

Re: T41 WPA2 issues?

#17 Post by sdfox7 » Wed Aug 08, 2018 2:37 pm

RealBlackStuff wrote:
Tue Aug 07, 2018 5:02 am
As long as you apply the NO-1802 hack, you can install any wifi-card that fits in that slot.
As mentioned before, your best (and fastest) bet is the TP Link 861N. Up to 300Mbps
Cheaper/decent ones with WPA2 include the above Intel 2200BG. Up only to 54Mbps.
I've used the Intel 2200BG before, the only issue is that it won't connect to my iPhone's WPA2 hotspot.

It's been an issue for years and I have no idea why. I have a feeling that the 2200BG is simply too old for the iPhone's hotspot (which doesn't make sense since the 2200BG mysteriously connects to the WPA2 router in my home without an issue.)
IBM ThinkPad 600E 2645-8AU (Win98), T23 2647-4MU (Win2000), T41 2373-7FU (WinXP)
My name is Stephen Fox. I am a '18 BBA and '20 MBA student at WCSU.
Disable Google Chrome End of Support Infobar on Windows XP/Vista

shawross
Junior Member
Junior Member
Posts: 452
Joined: Mon Oct 28, 2013 5:48 am
Location: Perth Aus / Thailand

Re: T41 WPA2 issues?

#18 Post by shawross » Thu Aug 09, 2018 6:07 pm

Have you tried turning off your antivirus and then connecting to the hotspot?

I have had a similar thing happen which I think was my Avast stopping the connection.

Your antivirus might be stopping this because you are using XP.
Active --- Love the X series
X301 SU9400 IDA Mod - W 7 / X201 540M - W 7 / X220 2520 - W7

Nostalgia
X61 T7500 / T41 T42 T43 / A31

Rogue daily driver - Samsung RV511 15.6 " Screen - W 7

sdfox7
Freshman Member
Posts: 102
Joined: Mon Sep 01, 2014 10:06 pm
Location: Danbury, CT

Re: T41 WPA2 issues?

#19 Post by sdfox7 » Thu Aug 09, 2018 11:35 pm

shawross wrote:
Thu Aug 09, 2018 6:07 pm
Have you tried turning off your antivirus and then connecting to the hotspot?

I have had a similar thing happen which I think was my Avast stopping the connection.

Your antivirus might be stopping this because you are using XP.
I don't use antivirus. :lol:
IBM ThinkPad 600E 2645-8AU (Win98), T23 2647-4MU (Win2000), T41 2373-7FU (WinXP)
My name is Stephen Fox. I am a '18 BBA and '20 MBA student at WCSU.
Disable Google Chrome End of Support Infobar on Windows XP/Vista

shawross
Junior Member
Junior Member
Posts: 452
Joined: Mon Oct 28, 2013 5:48 am
Location: Perth Aus / Thailand

Re: T41 WPA2 issues?

#20 Post by shawross » Sat Aug 11, 2018 7:26 pm

Perfectly understandable not to run an antivirus. But I would install an older anti-malware program for occasional scans.

On my Win 98 T41 I use SpyBot 1 and on my Xp systems I install Malware-bytes 2.2.0.1024.

Even though my T41 and T42 don't connect to the internet the anti-malware programs are handy for scanning old software.
Active --- Love the X series
X301 SU9400 IDA Mod - W 7 / X201 540M - W 7 / X220 2520 - W7

Nostalgia
X61 T7500 / T41 T42 T43 / A31

Rogue daily driver - Samsung RV511 15.6 " Screen - W 7

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T4x Series”

Who is online

Users browsing this forum: No registered users and 8 guests