Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

W520 Win10 + Optimusless Nvidia M2000

W500/510/520 and W700/710 series specific matters only
Post Reply
Message
Author
thumperer
Posts: 4
Joined: Mon Aug 27, 2018 5:04 pm
Location: Haifa, Israel

W520 Win10 + Optimusless Nvidia M2000

#1 Post by thumperer » Mon Aug 27, 2018 5:15 pm

Hi all,

I could really use some assistance getting my Nvidia M2000 up and running on my newly installed Win10 Pro W520. I must say that getting Win10 onto this machine was a fight. Multiple failed installs. Had to tweak and fight multiple issue, but finally have it running smoothly. That is all except the Nvidia! :(

When I was running Win7 on this machine I shut off Optimus & manually set the M2000 in the BIOS. Found it to be much more powerful, and less glitches. I have not been able to do the same on this Win10 installation.
All drivers seem to be installed correctly. No unknown devices in the device manager. If I try shutting off optimus and selecting the Nvidia is the BIOS (now on Win10) I get bumped down to 1024 resolution with no option to set it to 1080. I have tried downloading driver from Nvidia directly, I have tried letting Windows device manager automatically select drivers, I have tried to find ThinkPad System Update (which used to install drivers under Win7) but have found that there is no version for Win10.

Help! I need my graphix performance back,
Matthew

ajkula66
SuperUserGeorge
SuperUserGeorge
Posts: 16224
Joined: Sun Feb 25, 2007 11:28 am
Location: Brodheadsville, Pennsylvania, USA

Re: W520 Win10 + Optimusless Nvidia M2000

#2 Post by ajkula66 » Mon Aug 27, 2018 9:24 pm

Welcome to the forum!
thumperer wrote:
Mon Aug 27, 2018 5:15 pm

Help! I need my graphix performance back
Reverting back to W7 comes to mind....
...Knowledge is a deadly friend when no one sets the rules...(King Crimson)

Cheers,

George (your grouchy retired FlexView farmer)

AARP club members:A31p,T43pSF

Abused daily: T61p

PMs requesting personal tech support will be ignored.

thumperer
Posts: 4
Joined: Mon Aug 27, 2018 5:04 pm
Location: Haifa, Israel

Re: W520 Win10 + Optimusless Nvidia M2000

#3 Post by thumperer » Tue Aug 28, 2018 4:10 am

I held on to my beloved Win7 till now. But sadly it is getting phased out. More and more thing seem to not be supported on 7. Years of updates were starting to break things... I finally made the jump, and the performance of 10 actually feels better than 7 thus far.

Has not one managed to get the GPU working well on Win10?

RealBlackStuff
Admin
Admin
Posts: 19311
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA
Contact:

Re: W520 Win10 + Optimusless Nvidia M2000

#4 Post by RealBlackStuff » Tue Aug 28, 2018 5:51 am

Nowadays, when I do a fresh installation, I still use Lenovo's W7/SP1 recovery disks, but immediately when the update question arises during install, I set it to "do not update"!
When the fresh W7 install is finished, I UNinstall all the bloatware, such as Adobe, Norton/Mcafee, Welcome, Warranty, Windows Life, Office, etc.
For antivirus I now use the free Bitdefender and also install free Malwarebytes, just in case.
Instead of Adobe's PDF-bloatjunk, I install the last Foxit Reader (V 7.2.8.1124) that can still display the Classic Mode and not that horrible space-wasting Ribbon.
Make sure to set the Edit/Preferences/Updater to Never, otherwise you lose the Classic Menubar!
Then I check the Device Manager for missing items, and also check around (if I don't have them already) for the best drivers for graphics and system.
And Windows itself doesn't get any update at all, ever (at least not from me...).
Remarkable how well everything runs!
And W7 will continue to do so for many more years after Micro$haft stops supporting it in 2020.
Look at XP, still going strong!
Lovely day for a Guinness! (The Real Black Stuff)

Check out The Boardroom for Parts, Mods and Other Services.

thumperer
Posts: 4
Joined: Mon Aug 27, 2018 5:04 pm
Location: Haifa, Israel

Re: W520 Win10 + Optimusless Nvidia M2000

#5 Post by thumperer » Tue Aug 28, 2018 5:57 am

I personally am on the different end of that spectrum. I usually accept all updates within a month or 2 of them being released (after researching that they are stable). I think there is good reason for the updates. They usually do fix things. But the current state of updates after a fresh Win7 install will bring probably several 100. Starting with the service pack usually helps to cut down most of that number :)

Regarding Adobe I cant agree with your more. I have found that digging through the View menu - you can get rid of the ribbon BS, and set the new view to default... this usually works great till the next major update.

pkiff
Moderator
Moderator
Posts: 1440
Joined: Wed May 05, 2004 9:17 am
Location: Toronto, Canada

Re: W520 Win10 + Optimusless Nvidia M2000

#6 Post by pkiff » Wed Aug 29, 2018 3:37 am

thumperer wrote:
Mon Aug 27, 2018 5:15 pm
When I was running Win7 on this machine I shut off Optimus & manually set the M2000 in the BIOS. Found it to be much more powerful, and less glitches. I have not been able to do the same on this Win10 installation.
I haven't tried configuring my W520 M1000 to use Optimusless nVidia graphics. But it could well be that some flexibility regarding that configuration has been lost under Windows 10. On the other hand, I've not run into any glitches by just letting Optimus decide when to use nVidia and when to use the built-in graphics onboard the Intel CPU. Though admittedly, I don't have very many needs that actually push my graphics card aside from very infrequent gaming.
W520 (dual-boot Windows 10/Ubuntu 15) · X61 Tablet SXGA+ · T60p UXGA · Legacy: X60T, 600X, 770Z
Thinkpad Media Centre: X61T running XBMC with Broadcom Crystal HD BCM970015, Creative X-Fi Surround 5.1 plugged into Cambridge Audio Sonata AR30 receiver

thumperer
Posts: 4
Joined: Mon Aug 27, 2018 5:04 pm
Location: Haifa, Israel

Re: W520 Win10 + Optimusless Nvidia M2000

#7 Post by thumperer » Wed Aug 29, 2018 4:16 am

I'm at the opposite end of that spectrum. I mainly use the W520 for 4K video editing - thus I have no need for the Intel graphics. I would rather due away with optimus, and just run the Nvidia.
I sure hope I can get this solved in order to have a backup system to run beside my upcoming P72.

Finding hard to believe that no one else ran into this before me, or everyone gave up and just went back to Win7

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad W500/510/520 and W7x0 Series”

Who is online

Users browsing this forum: No registered users and 2 guests