Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Bluetooth in a T601 Frankenpad

T60/T61 series specific matters only
Post Reply
Message
Author
zoltan87
Sophomore Member
Posts: 152
Joined: Mon Oct 24, 2016 12:16 pm
Location: Plymouth, United Kingdom

Bluetooth in a T601 Frankenpad

#1 Post by zoltan87 » Thu Nov 29, 2018 7:54 pm

Maybe I am missing something, but upon trying to assemble my T60-T61 Frankie build I just noticed, that there is no way to insert the Bluetooth module in. The connector for it on the T61 motherboard is slightly misaligned compared to the original T60 mobo position, and because of the magnesium rollcage there is no space there.

I googled this issue, but no-one mentions it, or talks about it. What am I missing? Or is it just a well known fact that bluetooth won't work in these T601 builds?

Also off topic, but in one of my spare Thinkpad T61 I noticed that there are 4 cables coming out form the lid, one for the WWAN, two for the Wi-Fi card, and there is a fourth white cable going under the wi-fi module into an insulated small white envelope, connected to nothing. Any idea why that white cable is there?
Laptops after the 4:3 aspect ratio era are non-existent to me.

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 19489
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA
Contact:

Re: Bluetooth in a T601 Frankenpad

#2 Post by RealBlackStuff » Thu Nov 29, 2018 10:15 pm

In a T60 (and T61) the Bluetooth module is located in the lid.
Not every LCDcable has the connector for it.
Remove the 3 screwcovers and screws along the bottom, then lift up the bottom-part of the LCD-bezel.
The BT-module sits left of the LCD-cable.
Check the HMM for exact details.
Lovely day for a Guinness! (The Real Black Stuff)

Check out The Boardroom for Parts, Mods and Other Services.

pkiff
Moderator
Moderator
Posts: 1457
Joined: Wed May 05, 2004 9:17 am
Location: Toronto, Canada

Re: Bluetooth in a T601 Frankenpad

#3 Post by pkiff » Thu Nov 29, 2018 11:00 pm

zoltan87 wrote:
Thu Nov 29, 2018 7:54 pm
[...]in one of my spare Thinkpad T61 I noticed that there are 4 cables coming out form the lid, one for the WWAN, two for the Wi-Fi card, and there is a fourth white cable going under the wi-fi module into an insulated small white envelope, connected to nothing. Any idea why that white cable is there?
A third antenna, maybe? Some Wifi cards have 3 antenna ports, so they might install three antennas even though the actual card that was delivered in your machine only has two ports. I'm not up on the technical rationale or practical differences between 2 antenna vs 3 antenna.
X1 Carbon Tablet (3rd Gen) · W520 · T60p UXGA · Legacy: X61T SXGA+, X60T, 600X, 770Z SXGA
Nostalgic for: 600X PIII 850MHz in a SelectaDock III with 64MB Voodoo 5 5500 and Sound Blaster Audigy 5.1.

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 19489
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA
Contact:

Re: Bluetooth in a T601 Frankenpad

#4 Post by RealBlackStuff » Fri Nov 30, 2018 6:23 am

The white cable is the 3rd antenna, for use with Wimax.

And the connector you cannot access because the chassis is in the way, is/was for the modem.

zoltan87
Sophomore Member
Posts: 152
Joined: Mon Oct 24, 2016 12:16 pm
Location: Plymouth, United Kingdom

Re: Bluetooth in a T601 Frankenpad

#5 Post by zoltan87 » Sat Dec 01, 2018 2:22 pm

RealBlackStuff wrote:
Fri Nov 30, 2018 6:23 am
And the connector you cannot access because the chassis is in the way, is/was for the modem.
Wow, I feel like a complete fool. In all this time I always thought that that was the bluetooth module.

Also surprised about that white cable that they thought about future proofing the antennas for 3 connectors. Especially that in the other hand they put a whitelist in the BIOS against most wifi cards.
Laptops after the 4:3 aspect ratio era are non-existent to me.

TPFanatic
ThinkPadder
ThinkPadder
Posts: 1133
Joined: Thu Jul 30, 2015 11:29 pm
Location: Boston, Massachusetts

Re: Bluetooth in a T601 Frankenpad

#6 Post by TPFanatic » Sat Dec 01, 2018 2:34 pm

There were some Intel 3 antenna wireless cards available at the time, at least T61 had them, not sure if they are the same.

The fastest 3 antennas now are Intel 6300 N used in ThinkPads from 2010-2012 and some 3 antenna Atheros.
lenovo X230 i5 3320m IPS 8GB
lenovo T430 i5 3320m FHD 8GB
lenovo T500 P9700 WUXGA 8GB


Enable 2 finger scroll on any Synaptics touchpads with registry: http://forum.thinkpads.com/viewtopic.php?f=2&t=122612

zoltan87
Sophomore Member
Posts: 152
Joined: Mon Oct 24, 2016 12:16 pm
Location: Plymouth, United Kingdom

Re: Bluetooth in a T601 Frankenpad

#7 Post by zoltan87 » Sat Dec 08, 2018 1:19 pm

Pretty much everything else is sorted now on my Frankenpad build, but I just can't figure out how to get the Bluetooth module to work on Windows 8.1. The funny thing is, it kind of works, as I can switch it on with Fn+F5, the Bluetooth LED under the screen is on, it's in the device manager too, but I just can't use it. I tried to find it with my phone's bluetooth, but my laptop doesn't show up. Also there is nothing on the laptop where I could initiate a search or something with bluetooth.

I tried to install the newest bluetooth driver for it (the one for Win 7 32, 64 bit with enhanced data rate), but it can't install stating it has compatibility issue. I tried to change compatibility to Win xp, 7, 8, but none of these changes helped.

It's so annoying, as the module shows up in device manager, and windows states it works correctly, but there is nothing I could do with it. Any ideas? How is it even supposed to work? Any of you use bluetooth on these older systems ? By the way, I have the EXACT SAME issue on my T60, I just remember I gave up on it a long time ago. But I really want it to work on my T601 build.
Laptops after the 4:3 aspect ratio era are non-existent to me.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T6x Series”

Who is online

Users browsing this forum: No registered users and 18 guests