Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T60p CPU upgrade: Now Laptop Won't Start

T60/T61 series specific matters only
Post Reply
Message
Author
Ya Dad
Posts: 20
Joined: Wed Dec 26, 2018 2:28 pm
Location: Greenwood, Central Indiana

T60p CPU upgrade: Now Laptop Won't Start

#1 Post by Ya Dad » Fri Jan 11, 2019 5:42 pm

Replaced the T2500 with a T7600 2.33ghz Core 2 Duo. Now when I power it on, the indication lights come on and the fan spins for a quick second, then stops and most of the indication lights turn back off. During this process, the screen never comes on; it just stays black, no light.

I'm hoping I simply forgot about something when assembling the 14" T60 back together...

Cigarguy
ThinkPadder
ThinkPadder
Posts: 1673
Joined: Thu Aug 09, 2012 3:08 pm
Location: Calgary, Alberta, Canada

Re: T60p CPU upgrade: Now Laptop Won't Start

#2 Post by Cigarguy » Fri Jan 11, 2019 6:09 pm

Either you got a bad CPU or the reassembly was not proper. At least now you know what the problem is. Happens to all of us. Most common for me is I forgot to tighten down the CPU in its socket.

Ya Dad
Posts: 20
Joined: Wed Dec 26, 2018 2:28 pm
Location: Greenwood, Central Indiana

Re: T60p CPU upgrade: Now Laptop Won't Start

#3 Post by Ya Dad » Fri Jan 11, 2019 7:14 pm

Cigarguy wrote:
Fri Jan 11, 2019 6:09 pm
Either you got a bad CPU or the reassembly was not proper. At least now you know what the problem is. Happens to all of us. Most common for me is I forgot to tighten down the CPU in its socket.
I'm trying to think of what cords I could have possibly forgot to plug back in. I got little grey cord and little black cord plugged back in near the screen (grey in the left, black in the right), got the little cord on the left plugged back in (CPU fan? Idk what it does but it's connected to the heatpipe/sink/CPU fan assembly), plugged in the keyboard, plugged in the trackpad...

Shredder11
Junior Member
Junior Member
Posts: 322
Joined: Sat Jun 30, 2012 6:25 pm
Location: Bradford, West Yorkshire, England

Re: T60p CPU upgrade: Now Laptop Won't Start

#4 Post by Shredder11 » Fri Jan 11, 2019 9:59 pm

Did you remember to flash your BIOS to the latest one? Been a long time since I did my three Z61p (same as T60p) in 2012, but I flashed the whitelisted version when I went from T2500 to T7600 CPU.
Z61p x3 (C2D T7600, 3GB, 500GB SSD, BCM70015, Advanced Dock x1, Mini Dock x2)
W520 (C2Q i7-2720QM, 8GB, 60GB SSD)
X61 (C2D T7500, 3GB, 250GB SSD, BCM70015)
X61s (2GB, 120GB SSD)
T43p (P M 760, 2GB, IBM Port Replicator II)
G41 (P4 3.46GHz, 2GB, 40GB)

Ya Dad
Posts: 20
Joined: Wed Dec 26, 2018 2:28 pm
Location: Greenwood, Central Indiana

Re: T60p CPU upgrade: Now Laptop Won't Start

#5 Post by Ya Dad » Fri Jan 11, 2019 10:29 pm

Had no idea I had to flash a bios when upgrading the processor :oops:

Cigarguy
ThinkPadder
ThinkPadder
Posts: 1673
Joined: Thu Aug 09, 2012 3:08 pm
Location: Calgary, Alberta, Canada

Re: T60p CPU upgrade: Now Laptop Won't Start

#6 Post by Cigarguy » Fri Jan 11, 2019 10:44 pm

Did you put the old CPU back in? If not then what are you waiting for? Once it's back in it should work as before. Take the opportunity to flash the BIOS at that time.

Ya Dad
Posts: 20
Joined: Wed Dec 26, 2018 2:28 pm
Location: Greenwood, Central Indiana

Re: T60p CPU upgrade: Now Laptop Won't Start

#7 Post by Ya Dad » Sat Jan 12, 2019 1:34 am

Cigarguy wrote:
Fri Jan 11, 2019 10:44 pm
Did you put the old CPU back in? If not then what are you waiting for?
For me to get back home because I started this thread before I left lol

Ya Dad
Posts: 20
Joined: Wed Dec 26, 2018 2:28 pm
Location: Greenwood, Central Indiana

Re: T60p CPU upgrade: Now Laptop Won't Start

#8 Post by Ya Dad » Sun Jan 13, 2019 2:29 am

It was the bios. I had version 1.xx. Upgraded to 2.27 and now it seems to be working. Thank you!

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T6x Series”

Who is online

Users browsing this forum: berrieds and 27 guests