Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

x220 not booting (no bios) after ssd swap. shorted mainboard?

X200, X201, X220 (including equivalent tablet models) and X300, X301 series specific matters only.
Post Reply
Message
Author
rhlee
Posts: 11
Joined: Sat Oct 09, 2010 12:45 pm
Location: London, England

x220 not booting (no bios) after ssd swap. shorted mainboard?

#1 Post by rhlee » Fri May 17, 2019 4:29 pm

I swapped out my SSD on my x220. It now no longer boots, no bios.

The original was an old Intel X-25M SSD. The replacement was a Crucial M4.

The x220 takes 7mm form-factor SSDs. So I removed the plastic spacer.

When I booted the machine, I only got blank screen. I heard a faint clicking noise, as if the fan was repeatedly attempting to spin up. However the noise seemed to eminate from the right side of the machine where the drive was. I do understand the idea of an SSD clicking is nonsensical.

I did have a usb stick connected at the time. So I did the usual process of elimination. With usb stick / without ssd etc. Can't remeber the exact order and results, but I attempted several boots with the SSD.

Now the machine no longer boots, even with no drives. No post beep, no bios splashscreen. Nada.

I get the feeling, by removing the spacer on the Crucial SSD, I created a short circuit and blew something on the mainboard. When I removed the spacer and reassembled the SSD the top plate was of by 1mm so may have bridged some contacts.

Something that lends credence to this theory is when I comapred the old intel SSD to the Crucial. I also removed the spacer on the Intel SSD, however the Intel has a plastic backing where the discrete SMD components are. I guessing this is where the power components are too, thus protecting them.

Funnily enough the Crucial SSD still works fine in another machine.

Have I burnt something out on the mainboard?

axur-delmeria
Senior ThinkPadder
Senior ThinkPadder
Posts: 2312
Joined: Mon May 28, 2012 5:49 am
Location: Metro Manila, Philippines

Re: x220 not booting (no bios) after ssd swap. shorted mainboard?

#2 Post by axur-delmeria » Sat May 18, 2019 12:52 am

Did you put insulation on the M4 SSD before installing it in the X220?
There's a blog post about modifying the M4 to fit 7mm drive bays and it explicitly mentions insulating the circuit board.
Daily driver: X220 4291-C91 i7-2620M

Backup: X601 Core 2 Duo T8100
Toy: X60F Core Solo U1300
On loan: X220 4291-P79 i5-2520M
In pieces: two retired but working X61Ts
RIP: 760XD 9546-U9E; X61 7676-A24; and a BOE-Hydis HV121P01-100 in failed SXGA+ mod
:cry:

rhlee
Posts: 11
Joined: Sat Oct 09, 2010 12:45 pm
Location: London, England

Re: x220 not booting (no bios) after ssd swap. shorted mainboard?

#3 Post by rhlee » Sat May 18, 2019 3:50 am

Wow, thanks for finding that article for me.
Honestly this is a poor effort from Crucial. If you give end users the option of taking the drive down to 7mm, at least provide the minimum insulation.
It's just a layer of plastic. It's a miniscule cost compared to the SSD itself.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X200/201/220 and X300/301 Series”

Who is online

Users browsing this forum: No registered users and 20 guests