Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

P51s not booting up

P1/P50/P70 and later specific matters only
Post Reply
Posts: 5
Joined: Sun Oct 07, 2018 12:48 pm
Location: Blacksburg, VA

P51s not booting up

#1 Post by adi92 » Thu Jul 11, 2019 2:24 pm

I have a Thinkpad P51s and I was running a dual boot system with Windows and Linux and it has a PCIe SSD.

My laptop was running fine and then Windows decided that it needed to update my system. I noticed that after the update my computer booted up by default into Ubuntu and froze. No biggie I thought and force restarted it. That's when the fun began.

Now my computer would boot halfway and give me an "ACPI_BIOS_ERROR". I tried reinstalling Windows 10 from a flash drive and even that installation would give me the same error.

Even more interestingly, my computer stopped charging using the official USB-C charger! I ordered the traditional charger and that would charge my system!

Alright, I researched the ACPI error and decided to restore BIOS to default. No dice. I then updated BIOS to the latest version. Still no luck. I then downgraded my bios to an older version and still nothing.

After a few tries, my system started giving me an Error 2102: SSD not found!
So I tried using a new PCIe SSD, still the same error.
I then tried changing the cable going from MB to the PCIe SSD and still the same error.

I finally bought a SATA cable to replace the PCIe cable (the cable that runs from the motherboard to the SSD) and tried to use a SATA ssd and it started working again!! I reinstalled Windows and made sure the driver for Thunderbolt was enabled. I also double checked that Thunderbolt was enabled in BIOS but my laptop still would not charge using the USB-C charger nor would it recognize any USB-C flash drive.

I figured at least I have a working system and put my back cover on and lo and behold I am getting the ACPI error again or just going into a boot loop! Most infuriating. I can run Ubuntu from an external hard disk just fine which is how I am writing this post!

So, what would you guess the issue is and what should I do now? Any help would be greatly appreciated!

What really tweaks my nipple is the fact that everything was fine before Windows update screwed it up! In a fair world, this would be on Microsoft.

Senior Member
Senior Member
Posts: 969
Joined: Sun Sep 13, 2015 9:51 pm
Location: Marissa, Illinois

Re: P51s not booting up

#2 Post by MikalE » Thu Jul 11, 2019 4:48 pm

I think the issue may be that Thunderbolt in enabled.

There was a thread a few months ago about machines being bricked with this feature enabled in the BIOS by the user. I think it was about the P series Thinkpads.

I would search for, and read through that thread.
T500 T9600 2055-BE9
T510 i5 4384-DV7
T510 i7 4349-A64
T520 i7 4242-4UU(CTO)

T520: i7-2760QM(2.40GHz),16GB, 500GB SSD/250GB SSD, 1600x900, 1GB NVIDIA, DVDRW, Smartcard, media card, FPR, Win7 Pro64, XP Pro64 whitelist BIOS, N 6300 AGN, German KB, BT 4.0.

Posts: 5
Joined: Sun Oct 07, 2018 12:48 pm
Location: Blacksburg, VA

Re: P51s not booting up

#3 Post by adi92 » Fri Jul 12, 2019 10:17 pm

I found those threds but they seemed to be for P50 laptops. I will however try turning it off and seeing if that helps

Post Reply
  • Similar Topics
    Last post

Return to “ThinkPad P1/P50/P70 and later Series”

Who is online

Users browsing this forum: No registered users and 4 guests