Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

x220 does not fully shutdown / power off (win10 1903)

Windows 10 on Lenovo hardware
Post Reply
Message
Author
franzk
Posts: 18
Joined: Mon Jul 29, 2019 8:03 am
Location: rome, italy

x220 does not fully shutdown / power off (win10 1903)

#1 Post by franzk » Sat Aug 24, 2019 3:29 pm

Hi,
My x220 (i5, w10 1903, msata ssd, 16gb) started to behave weirdly after a couple of updates, specifically Windows 1903 and the latest ME firmware.

50% of the time the shutdown / suspension does not work.
After the normal shutdown procedure the fan stays on and the power and sleep LEDs blinks.
Always after at least 10/20 min of work, if I shutdown the pc just after a reboot everything works fine.

Problems started after updating the IME and updating Windows 10 to 1903 (I've done a clean install later but nothing changed).
If I remember well the problem did not exist before, I'm pretty sure.
In the meantime I tried almost all the possible ME drivers (now on 7.1.21.1134 version ) and I downgraded to the previous version of the IME firmware too ( 7.1.52.1176 ).
The problem is now mitigated but is still present.
Also I removed, as suggested, all the IME related software (from intel or Lenovo).
Tried to disable the device too, nothing changed.

The notebook is dual booting with Linux, apparently there are no problems with it.

Any suggestions? Anyone with the same/similar problem?
Does anyone have the same problem with Windows 1903? I can't downgrade to 1809 right now (work to be done) but I will if this can solve the problem.

Thank you,
Frank

jdhurst
Admin
Admin
Posts: 5868
Joined: Thu Apr 29, 2004 6:49 am
Location: Toronto, Canada

Re: x220 does not fully shutdown / power off (win10 1903)

#2 Post by jdhurst » Sun Aug 25, 2019 5:36 pm

I have a spare X230 running V1903 Insider pre-release and that is working fine.

I suggest you update both BIOS and Chipset on your X220 followed by the PM Driver

See if that helps

franzk
Posts: 18
Joined: Mon Jul 29, 2019 8:03 am
Location: rome, italy

Re: x220 does not fully shutdown / power off (win10 1903)

#3 Post by franzk » Mon Aug 26, 2019 9:31 am

jdhurst wrote:
Sun Aug 25, 2019 5:36 pm
I have a spare X230 running V1903 Insider pre-release and that is working fine.

I suggest you update both BIOS and Chipset on your X220 followed by the PM Driver

See if that helps
Everything should be updated, except the IME driver.

Thanks,
Frank

plasturion
Posts: 5
Joined: Thu Nov 07, 2019 11:59 am
Location: Jaworzyna Slaska, Poland

Re: x220 does not fully shutdown / power off (win10 1903)

#4 Post by plasturion » Thu Nov 07, 2019 12:33 pm

[edited]

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “Windows 10”

Who is online

Users browsing this forum: No registered users and 1 guest