Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T60p screen mystery

T60/T61 series specific matters only
Post Reply
Message
Author
brucehe
Junior Member
Junior Member
Posts: 350
Joined: Sat Jan 06, 2007 5:25 pm
Location: Corvallis, Oregon

T60p screen mystery

#1 Post by brucehe » Fri Oct 11, 2019 12:57 pm

Hello all,

I have a T60 with a T60p ATIfireGL board installed. It runs fine but on boot up it exhibits some interesting markings on the boot up screens, horizontal lines, question marks and some vertical lines.

Once it boots up to W7 when you roll the cursor over text 6 short vertical lines follow the cursor.

Take a look: https://imgur.com/a/MZ9uneI

I connected it to an external monitor and it displays the same behavior. Is this a video chip problem on the system board? Ideas?

Thanks,

Bruce
W520 FHD Quadro 2000M, T60 XGA with T60p board (wife), HP 8710w IPS multimedia, Yoga 2 10 inch W10, X230T, X200s for sale
Under my care, T61 4:3, T400 Intel 8GB Ram 256GB SSD, 2X T410, T420, T430,

dr_st
Moderator
Moderator
Posts: 8061
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: T60p screen mystery

#2 Post by dr_st » Fri Oct 11, 2019 1:32 pm

Well, the video chip is soldered to the system board, so for all practical purposes, the two options are the same.

It certainly looks like a video chip problem, specifically corruption of the Video RAM; apparently, it's not an uncommon problem on T60/p ATI chips.
Thinkpad 25 (20K7), X1 Carbon (20HQ), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

ajkula66
SuperUserGeorge
SuperUserGeorge
Posts: 16650
Joined: Sun Feb 25, 2007 11:28 am
Location: Brodheadsville, Pennsylvania, USA

Re: T60p screen mystery

#3 Post by ajkula66 » Fri Oct 11, 2019 1:35 pm

dr_st wrote:
Fri Oct 11, 2019 1:32 pm
specifically corruption of the Video RAM; apparently, it's not an uncommon problem on T60/p ATI chips.
Agreed. That machine will need its board swapped out.
...Knowledge is a deadly friend when no one sets the rules...(King Crimson)

Cheers,

George (your grouchy retired FlexView farmer)

FlexView AARP club members:A31p, T43pSF, X60T

Abused daily: X200s


PMs requesting personal tech support will be ignored.

brucehe
Junior Member
Junior Member
Posts: 350
Joined: Sat Jan 06, 2007 5:25 pm
Location: Corvallis, Oregon

Re: T60p screen mystery

#4 Post by brucehe » Fri Oct 11, 2019 11:09 pm

Thanks Guys,

Interesting about the VRAM getting corrupted. This board was in my 15" t60p which I made into a Frankenpad and sold a few years go, then got moved into my wife's T60 to which she was pretty attached to. She is using a very nice X230T with IPS screen I found but really is not using the touch screen. So, if she wants her T60 back I guess i could put a T61 board into it. Is Tuus still selling T61old stock Nvidia boards?

Bruce
W520 FHD Quadro 2000M, T60 XGA with T60p board (wife), HP 8710w IPS multimedia, Yoga 2 10 inch W10, X230T, X200s for sale
Under my care, T61 4:3, T400 Intel 8GB Ram 256GB SSD, 2X T410, T420, T430,

ajkula66
SuperUserGeorge
SuperUserGeorge
Posts: 16650
Joined: Sun Feb 25, 2007 11:28 am
Location: Brodheadsville, Pennsylvania, USA

Re: T60p screen mystery

#5 Post by ajkula66 » Fri Oct 11, 2019 11:44 pm

brucehe wrote:
Fri Oct 11, 2019 11:09 pm

Is Tuus still selling T61old stock Nvidia boards?
I believe so. Send him a PM.
...Knowledge is a deadly friend when no one sets the rules...(King Crimson)

Cheers,

George (your grouchy retired FlexView farmer)

FlexView AARP club members:A31p, T43pSF, X60T

Abused daily: X200s


PMs requesting personal tech support will be ignored.

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 20288
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: T60p screen mystery

#6 Post by RealBlackStuff » Sat Oct 12, 2019 2:00 am

Find TuuS's NOS T61 mobos here: https://www.theboardroom.info/t61mobo.html
See the remark in blue near the bottom of that page.
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.

H-Atkinson
Posts: 33
Joined: Tue Sep 10, 2019 10:27 pm
Location: Glendale, CA

Re: T60p screen mystery

#7 Post by H-Atkinson » Sun Oct 13, 2019 4:36 pm

Board is cooked for sure. I had a T60p that did that (ended up frankenpadding it). Best I can understand, over time the BGA degrades, and it loses contact. I think the issue was likely accelerated by the subpar cooling of the T60.
T43p (15" UXGA, SATA-modded)
T601p (14.1" LED)
T601 (dead, 14.1" LED)
T601 (15" SXGA+ FlexView)
T60p DEMO-2007OVU (15" UXGA FlexView, ATI's prototype machine)
X230 (i7, 16gb RAM, 500 gb SSD, IPS)
P53 (RMAed for dead pixels

ajkula66
SuperUserGeorge
SuperUserGeorge
Posts: 16650
Joined: Sun Feb 25, 2007 11:28 am
Location: Brodheadsville, Pennsylvania, USA

Re: T60p screen mystery

#8 Post by ajkula66 » Sun Oct 13, 2019 5:55 pm

H-Atkinson wrote:
Sun Oct 13, 2019 4:36 pm
Board is cooked for sure. I had a T60p that did that (ended up frankenpadding it). Best I can understand, over time the BGA degrades, and it loses contact. I think the issue was likely accelerated by the subpar cooling of the T60.
Actually, when one starts seeing question marks and other letters/symbols on a scrambled screen, that's VRAM corruption, nothing to do with the BGA failures.
...Knowledge is a deadly friend when no one sets the rules...(King Crimson)

Cheers,

George (your grouchy retired FlexView farmer)

FlexView AARP club members:A31p, T43pSF, X60T

Abused daily: X200s


PMs requesting personal tech support will be ignored.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T6x Series”

Who is online

Users browsing this forum: Bing [Bot] and 19 guests