Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T520 - Problem with external monitor

T400/410/420 and T500/510/520 series specific matters only
Post Reply
Message
Author
freeagent
Posts: 16
Joined: Wed Oct 01, 2014 9:35 pm
Location: Kingston, Canada

T520 - Problem with external monitor

#1 Post by freeagent » Fri Nov 08, 2019 9:57 pm

I noticed that my normally snappy T520 seemed to have become sluggish. Most operations, but especially when a website contains video. For example News sites like CNN/Fox.
The T520 is a model 4243WD1 with 1920x1080 screen. (i5-2540 with 8Gb). I have an external ASUS VP228 monitor connected via HDMI. (also 1920x1080) Currently running Win 7 and Nvidia graphics.
I ran the Windows Experience app on Win7. The graphics rating was 6.5 with the laptop only but dropped to 5.1 when the external monitor was connected.
I have had this laptop for about 5 years and because it has worked so well, have forgotten a lot about it. I seem to recall that there were two graphics options. How do I switch those? Do I have to go into BIOS?
And would moving to Win10 help at all?

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 20344
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: T520 - Problem with external monitor

#2 Post by RealBlackStuff » Sat Nov 09, 2019 1:32 am

Go into BIOS/Config/Display to change nVidia to Integrated.

If HDD, then upgrade to SSD.
Upgrade RAM to 16GB also comes to mind.
Cleaning out your temp files may be helpful.
Swapping out your Chrome browser for Firefox will be very beneficial.

Don't make the mistake of switching to W10, you are going to regret it.
Keep or refresh W7, or upgrade to W8.1, or take the plunge and switch over to Linux.
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.

freeagent
Posts: 16
Joined: Wed Oct 01, 2014 9:35 pm
Location: Kingston, Canada

Re: T520 - Problem with external monitor

#3 Post by freeagent » Sat Nov 09, 2019 4:37 pm

I thought I had the problem fixed. I was using a Displayport-->HDMI adapter. Seeing laptop worked fine with the problem video streams, figured problem was something to do with how the video got from laptop to Monitor. Bought a DP-->DP cable and video problem has gone. At least at first checks. But I now see it is still there. Stuttering in videos such as off CNN news.

Regarding the Windows experience score - That still goes down to 5.1 when using the external monitor. Can only assume that is due it using the Nvidia gpu. Apparently the nvidia is just an extra layer over an above the Intel gpu, which would still be in use. So more processing to do may slow things down? Not sure if there is a way around this or if I should even try.

I did look at and try some of your suggestions. Added some comments.
Go into BIOS/Config/Display to change nVidia to Integrated.
I tried all the settings without an improvement. (I have some questions, but will post them separately)
If HDD, then upgrade to SSD.
Have SSD
Upgrade RAM to 16GB also comes to mind.
Expensive option ;)
Cleaning out your temp files may be helpful.
Done regularly
Swapping out your Chrome browser for Firefox will be very beneficial.
The Windows Experience app doesn't use a browser, so not likely the problem. I have both as well as IE.
Don't make the mistake of switching to W10, you are going to regret it.
I had it on the T520 (dual booting), but decided to stay with Win7. Wife has Win10. Never really had any problems with it. Have to go there sooner or later! Have Linux on an old XP machine - But seems to me it's not ready for everyday use. Fun to play with.

freeagent
Posts: 16
Joined: Wed Oct 01, 2014 9:35 pm
Location: Kingston, Canada

Re: T520 - Problem with external monitor

#4 Post by freeagent » Sun Nov 10, 2019 11:11 am

Go into BIOS/Config/Display to change nVidia to Integrated.
BIOS gives three options Optimus, Discrete & Integrated. Also has option to disable Optimus.

When I set it to Integrated with Optimus enable or not, system does not find the external monitor.
If I have it set to integrated and enable, next time I go to BIOS, Optimus is already now chosen. If I save and reboot, them I am back with nvidia functional and able to use external monitor. So seems I have to just choose Optimus and enable Windows to use it.

Despite new cable, still having stuttering, even although it is reduced. Have a few other things to try, but welcome any input :) No more hair to pull out!

OK, so I did a fresh download of Firefox and tried it. No stuttering! OK, why would that be. I have a number of add-ons to Chrome and possibly they were the problem? I disabled the prime suspects, but that did not help. Nothing against Firefox - used it for years, but seems to me that I have trouble with one or two sites when I use the newer versions. But will stay with it for now and see if problem re-appears.

freeagent
Posts: 16
Joined: Wed Oct 01, 2014 9:35 pm
Location: Kingston, Canada

Re: T520 - Problem with external monitor

#5 Post by freeagent » Sun Nov 10, 2019 1:48 pm

As posted above, no stuttering video with Firefox, but still happened on Chrome.

I reset Chrome which put it back to original config with no extensions or add-ons. Also no cookies or cache. And video on external monitor still stuttered!

Finally, I turned off "Use hardware acceleration when available" in settings . No more stuttering in Chrome!

Don't know why this is only needed when external monitor is being used, but it worked it seems!

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T400/410/420 and T500/510/520 Series”

Who is online

Users browsing this forum: No registered users and 7 guests