Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

X230 lost WLAN connectivity Win 10 1903

X230 through X280, plus X390 series specific matters only
Post Reply
Message
Author
albacore
Posts: 3
Joined: Sun Sep 27, 2015 4:41 am
Location: Lancashire, UK

X230 lost WLAN connectivity Win 10 1903

#1 Post by albacore » Wed Jan 15, 2020 3:44 pm

I just updated my X230 to Win 10 x64 version 1903 - unwisely it seems, as I no longer have wifi.

The WLAN card is an Intel N 6205 and It's showing an error 38. Presumably it needs a new driver, but there does not appear to be one available.
Is there another decent card I can install with the existing Bios or what other options do I have? Am I likely to find anything else that doesn't work, in which case perhaps it would be better to revert to earlier version from back up?

Lance
Current: T420, X230
Past: X60, T60, T30

JPOESQ
**SENIOR** Member
**SENIOR** Member
Posts: 234
Joined: Sun May 16, 2004 2:26 pm
Location: San Francisco, CA
Contact:

Re: X230 lost WLAN connectivity Win 10 1903

#2 Post by JPOESQ » Wed Jan 15, 2020 7:09 pm

You can try the following which are easy first steps:

1. Completely shutdown the computer (command prompt, run as admin, type "shutdown /s /f /t 0" and hit enter). Power up to see if the memory just needed to be flushed.
2. Run the network troubleshooter (right click on the wireless icon in the systray). This solves a lot of problems.
3. See if Lenovo's system update tool has a driver update. If not, go to 4.
4. Go to the device manager and update the driver. If an updated driver is not available, go to 5.
5. Go to the device manager and rollback the driver.

You can also upgrade to an Ultimate-N 6300 without modding the bios. Or, you can flash the bios with Ivyrain, remove the whitelist, and install an AC-7260.
John P. O'Banion, JD, PE, BSEE
Registered Patent Attorney
http://www.intellectual.com

600, X220 (McDonnell bios, Linux), X230, T530 (1vyrain bios), X1 Carbon 5th Signature Edition

albacore
Posts: 3
Joined: Sun Sep 27, 2015 4:41 am
Location: Lancashire, UK

Re: X230 lost WLAN connectivity Win 10 1903

#3 Post by albacore » Fri Jan 17, 2020 3:49 am

Many thanks for your reply - very useful and I will try your suggestions.

One thing I didn't originally mention is that I am using the Microsoft wireless display adaptor v2. If I do need a new WLAN card is this likely to still work with the two models you mentioned?

Lance
Current: T420, X230
Past: X60, T60, T30

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X230-X280 / X390 Series”

Who is online

Users browsing this forum: No registered users and 18 guests