Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

[SOLVED] X41 SSD "works" but won't boot - next steps?

X20/X21, X30/X31, X40/X41 Series
Post Reply
Posts: 1
Joined: Sat Jul 11, 2020 3:49 pm
Location: Seattle, WA

[SOLVED] X41 SSD "works" but won't boot - next steps?

#1 Post by brancusi » Sat Jul 11, 2020 4:21 pm

UPDATE: It dawned on me that using the drive via the USB -> PATA adapter meant the drive wasn't actually a USB drive as the icon was for a regular IDE drive, so I tried again with the SSD mounted in the X41. Same problem, didn't work - BUT now I took it OUT of the plastic case that was supplied and tried again - SAME problem - but I noticed that the LED lights on the SSD were not on, so wondered if this was just an alignment problem - and YES, after taking some more care to insert it naked into the chassis, the lights came on and everything now works as expected!! Basically the tolerance of the plastic case were far enough out to push the pins to one side leading it not to connect properly at all. Guess I'm lucky this didn't fry anything - but all is now working and leaving this here in case it helps others using the same adapter set. :P


I hate being defeated by a computer, but I'm out of options and not sure what my next course of action should be. I've been reading the forum posts here about SSD adventures and have tried various options, but I'm now officially stuck :-(

I'm trying to upgrade the HDD on my Thinkpad X41 running windows XP pro. I've upgraded the BIOS to the latest version 2.09 and also the embedded controller to version 1.02. I'm using a PATA -> mSata adapter from https://www.ebay.com/itm/mSATA-SSD-to-h ... 1762518210 (switched to 3.3V when in the laptop, switched to 5V when using in a USB -> PATA adapter) and the mSata drive I'm using is the 60GB version of https://www.amazon.com/gp/product/B07JPKDHT5/. The USB adapter that I have is [url]https://www.amazon.com/gp/product/B01E7EPKUO/ and that just lets me mount a collection of PATA drives that I have as I've been going through upgrading multiple other computers (with varying success).


I have a clone of the HDD I made with Clonezilla on a USB stick but when I tried to restore it to the SSD fitted internally to the laptop, the SSD wasn't being recognized, Clonezilla would complain about "ata1: SRST failed (errno=-16)" on booting from the CD and when trying to do the restore it wouldn't find the SSD at all.


This time I've connected the SSD to my USB adapter and re-cloned the HDD using Macrium reflect. The SSD is clearly working fine with this adapter, I can clone to it, mount it on different computers and everything looks OK, but I can't persuade the X41 to boot from it as a USB mounted drive (wanted to get this working first in case it was a pin connection problem when I swap out the actual HDD). I've enabled USB boot in the bios of course and when I reboot and hit F12 for boot options, I see the HDD and the USB drive listed. If I select the HDD it works as expected, if I select the USB mounted SSD, I get a blank screen with a flashing cursor and no error message.

1) I have used a disk hex editor to inspect the MBR on both drives and they are identical except for the disk signature bytes.
2) I have tried using MBRFix to generate a new MBR for Windows XP, exactly the same problem on boot

Does anyone have thoughts on how I could proceed or what the problem might be? I don't mind buying new adapters etc if it's proven to be working on an X41 but I'm reluctant to give up as the hardware seems to all be working in a different configuration and this smells like a silly config issue that I can't track down.

Help appreciated!


Posts: 16
Joined: Thu Oct 03, 2019 3:13 pm
Location: Elizabeth, NJ

Re: [SOLVED] X41 SSD "works" but won't boot - next steps?

#2 Post by Sudos » Mon Aug 17, 2020 10:42 am

Leaving this to help others down the line, as it's what I went through for my X31, which is a different beast altogether, but still absolutely relevant to the subject at hand since it's dealing with a clone.

You'll want to track down MiniTool partition Wizard 10.3, clone the disk using the "Migrate OS to SSD/HD" option WITHOUT A RESIZE. copy it part for part, do not fill up the entire SSD unless the drive you're copying from is bigger. Honestly I'd recommend getting a cheap used Samsung PM841 mSATA 128GB SSD instead.

Once the clone is done and the SSD has been placed inside the machine, it SHOULD boot successfully. if it DOES NOT, try the clone again. After you get into Windows, you'll want to immediatlely run a chkdsk without fixing from the command prompt (just chkdsk C:) and make sure it doesn't find any issues. Once this is done, reboot. if you don't get a corrupt system32\config, you're good, but get into Windows again and load up something bloaty, like Firefox or iTunes, use it for a few minutes, close the application and shut down, then do a cold boot. At this point you can load up HDTune Pro and do some bandwidth tests to make sure you're saturating the IDE bus. in my X31, the max I can go is about 77-80MB/s, which is more than fast considering the almost instant response time.

Don't forget to turn off system restore, and look up the guide for how to disable prefetching on boot, so it doesn't write unnecessarily to the SSD all the time, thus killing it faster. once in a while, let it sit idly at the login screen for a couple hours plugged in so the jmicron chipset has a chance to do garbage collection (I believe it does the TRIM command in that time) so to extend the life of the SSD.
600 PII-400 MMC-1/416MB/No HDD
600E PII-400/416MB/40GB, XP SP3, WPC600N
X31 Banias 1.7/2GB/128GB SSD, XP USP4, BCM43222 WiFi, X3 Ultrabase, 2x DVD Multi
Thinkpad Dock w/GeForce 4 MX 440 64MB PCI
T500 Switching Graphics, T9600 2.8/8GB/250GB SSD + 1TB Ultrabay, WUXGA

Post Reply
  • Similar Topics
    Last post

Return to “ThinkPad X20/X30/X40 Series incl. Tablets”

Who is online

Users browsing this forum: No registered users and 10 guests