Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T500 with XP x64

T400/T410/T420 and T500/T510/T520 Series
Post Reply
Message
Author
OS923
Posts: 12
Joined: Thu Dec 16, 2021 10:33 am
Location: Dendermonde, Belgium

T500 with XP x64

#1 Post by OS923 » Thu Dec 16, 2021 10:59 am

I installed XP x64 SP2 on a T500.

I read that I should have pressed F6 to install the AHCI drivers. Can I still install these drivers or do I have to reinstall XP?

I tried 13-1-legacy_xp64_dd_ccc_whql.exe for the Radeon HD 3650 and I have the correct screen resolution and hardware acceleration even though it complained that I don't have .NET 3.0.

I tried 6ea303ww.exe for the Conexant Audio chip, because I had read here that it would work because the W700 has the same chip. It works.

Now I have 13 missing drivers. I wonder whether I will find 64-bit drivers for all these things or could it work with a 32-bit driver.

Image

The same devices in the same order:

PCI\VEN_1180&DEV_0592&SUBSYS_20CA17AA&REV_11\4&8365E1C&0&04F0
PCI\VEN_1180&DEV_0843&SUBSYS_20C917AA&REV_11\4&8365E1C&0&03F0
PCI\VEN_1180&DEV_0852&SUBSYS_20CB17AA&REV_11\4&8365E1C&0&05F0
USB\VID_0BDB&PID_1900\3541430233863600
PCI\VEN_8086&DEV_10F5&SUBSYS_20EE17AA&REV_03\3&B1BFB68&0&C8
USB\VID_08FF&PID_2810\5&2FF31994&0&1
HDAUDIO\FUNC_02&VEN_14F1&DEV_2C06&SUBSYS_17AA2122&REV_1000\4&2B9C4D19&0&0102
PCI\VEN_8086&DEV_4237&SUBSYS_12118086&REV_00\4&318470AD&0&00E1
PCI\VEN_8086&DEV_2A47&SUBSYS_20EC17AA&REV_07\3&B1BFB68&0&1B
PCI\VEN_8086&DEV_2A44&SUBSYS_20E617AA&REV_07\3&B1BFB68&0&18
PCI\VEN_8086&DEV_2930&SUBSYS_20F917AA&REV_03\3&B1BFB68&0&FB ACPI\IBM0068\5&2890D699&0
ACPI\INTC0102\1

axur-delmeria
Senior ThinkPadder
Senior ThinkPadder
Posts: 3134
Joined: Mon May 28, 2012 5:49 am
Location: Metro Manila, Philippines

Re: T500 with XP x64

#2 Post by axur-delmeria » Thu Dec 16, 2021 12:08 pm

Any PCI device that starts with VEN_8086 is Intel.
DEV_10F5 is the Intel 82567LM gigabit LAN
DEV_4237 is the WiFi 5100
DEV_2A47 and 2A44 are parts of Active Management Technology
DEV_2930 is probably the SMBus controller

The VEN_1180 ones are the Ricoh card reader, Cardbus, and Firewire devices.

The HDAUDIO one is the Conexant dialup modem.

ACPI\IBM0068\ is the Thinkpad's Power Management controller.


As for drivers, try the Vista x64 ones. 32-bit drivers will definitely not work.
Daily driver: X220 4291-C91 i7-2620M

Backup: X601 Core 2 Duo T8100
Toy: X60F Core Solo U1300
On loan: X220 4291-P79 i5-2520M
In pieces: two retired but working X61Ts
RIP: 760XD 9546-U9E; X61 7676-A24; and a BOE-Hydis HV121P01-100 in failed SXGA+ mod
:cry:

OS923
Posts: 12
Joined: Thu Dec 16, 2021 10:33 am
Location: Dendermonde, Belgium

Re: T500 with XP x64

#3 Post by OS923 » Mon Dec 20, 2021 12:29 pm

I went to the BIOS. I disabled everything that I won't use: AMT and all ports except USB, UltraBay and parallel, because I use a matrix printer. I reinstalled Windows without AHCI. I installed the Radeon, Conexant and power management drivers. Then there were 2 things left:

PCI\VEN_8086&DEV_2A44&SUBSYS_20E617AA&REV_07\3&B1BFB68&0&18
That would be "Intel Mobile 4 Chipset MEI Controller". MEI is Management Engine Interface.
I’ll try this because they say clearly XP x64.

PCI\VEN_8086&DEV_2930&SUBSYS_20F917AA&REV_03\3&B1BFB68&0&FB
That would be "Intel ICH9 Family SMBus Controller".
Here they say that 2056wwl should work for XP x64.

OS923
Posts: 12
Joined: Thu Dec 16, 2021 10:33 am
Location: Dendermonde, Belgium

Re: T500 with XP x64

#4 Post by OS923 » Wed Dec 22, 2021 10:02 am

Yikes, that was terrible.

DEV_2930 = Intel ICH9 Family SMBus Controller is one of the things that is installed by g1ic09ww.exe

DEV_2A44 = Intel AMT - Management Engine Interface is installed by 7vr308ww.exe

Summary of what I installed:

XP x64
XP x64 SP 2
Conexant audio features XP 3.64.8.50 = 6ea303ww.exe
Intel AMT - Management Engine Interface 4.2.0.1008 = 7vr308ww.exe
Intel chipset support for Windows 2000&XP&Vista&7&8 9.3.0.1021 = g1ic09ww.exe
Lenovo power management driver 1.67.4.5 = gtku09ww.exe
Mobility Radeon HD 3650 = 13-1-legacy_xp64_dd_ccc_whql.exe (drivers but not the pesky CCC program because it requires .NET framework 3.0 and this isn't available anymore)

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 22606
Joined: Mon Sep 18, 2006 5:17 am
Location: Wexford, Éire
Contact:

Re: T500 with XP x64

#5 Post by RealBlackStuff » Wed Dec 22, 2021 11:04 am

Check this out: viewtopic.php?f=11&t=128170
They have T400/T500 XP Pro there, available after you've been on your best behaviour!
Lovely day for a Guinness! (The Real Black Stuff)
Covid-19: Stay safe, so still Mask it or Casket!

OS923
Posts: 12
Joined: Thu Dec 16, 2021 10:33 am
Location: Dendermonde, Belgium

Re: T500 with XP x64

#6 Post by OS923 » Wed Dec 22, 2021 12:06 pm

That’s probably the 32-bit version of XP for T500. I have XP Pro SP2 x64.

OS923
Posts: 12
Joined: Thu Dec 16, 2021 10:33 am
Location: Dendermonde, Belgium

Re: T500 with XP x64

#7 Post by OS923 » Wed Dec 29, 2021 12:24 pm

7kss73ww.exe installs the multi-card reader, but you have to point the new hardware wizard 3 times to the correct folder.

I enabled everything in the BIOS and started over.

First I tried to install the built-in graphics chip and then the Radeon couldn’t be installed. The order in which you install the drivers seems to make a difference.

In the end these things didn't get installed:

Image

In the same order:

PCI\VEN_8086&DEV_2A42&SUBSYS_211417AA&REV_07\3&B1BFB68&0&10
USB\VID_0BDB&PID_1900\3541430233863600
PCI\VEN_8086&DEV_10F5&SUBSYS_20EE17AA&REV_03\3&B1BFB68&0&C8
USB\VID_08FF&PID_2810\5&2FF31994&0&1
HDAUDIO\FUNC_02&VEN_14F1&DEV_2C06&SUBSYS_17AA2122&REV_1000\4&2B9C4D19&0&0102
ACPI\INTC0102\1
PCI\VEN_8086&DEV_2A43&SUBSYS_211417AA&REV_07\3&B1BFB68&0&11

What I like is that it's clearly faster than 32-bit XP. But there are 30 programs that I can't use anymore.

At this moment I evaluate Ubuntu. The installation was effortless and everything works. My first impression is good.

I’ll try my software on my HP EliteBook 2530p with Windows 10 x64. If I don’t have to discard too much then this may be goodbye to Windows XP.

OS923
Posts: 12
Joined: Thu Dec 16, 2021 10:33 am
Location: Dendermonde, Belgium

Re: T500 with XP x64

#8 Post by OS923 » Wed Jan 05, 2022 2:15 pm

I installed a triple boot:
- XP Pro SP3 x86,
- Windows 8.1 Pro x64,
- Ubuntu 21.10.

On XP I’ll run DVD43 and Acrobat 6.
Ubuntu’s HFS+ support could be more practical compared to MacDrive 9 on XP.

OS923
Posts: 12
Joined: Thu Dec 16, 2021 10:33 am
Location: Dendermonde, Belgium

Re: T500 with XP x64

#9 Post by OS923 » Fri Jan 07, 2022 11:25 am

It worked for one day. I could boot every system several times. Then XP disappeared from the menu and W8 changed its partition letter to C.

W8 was a disappointment. I couldn’t install a single driver.

But, as we say here in Belgium, I’m not at the end of my Latin.

OS923
Posts: 12
Joined: Thu Dec 16, 2021 10:33 am
Location: Dendermonde, Belgium

Re: T500 with XP x64

#10 Post by OS923 » Sun Jan 09, 2022 5:54 am

I tried all sorts of installs.
For example, I had a dual boot Windows 8 and Ubuntu.
I had a dual boot Windows 10 and Ubuntu while running XP in VirtualBox.

I've been reading on Wikipedia.
All partitions have to be created in the right order because they are counted in order of creation.
Windows can only be installed in a primary partition.
If you use XP then all your partitions have to follow the CHS partition scheme which causes alignment to the cylinders.
In other words, if the partitions are created by the XP installer or by XP's disk management then they will be fine.

If you use the XP installer to create a second partition then you risk that it will be a logical partition in an extended partition.
Thus create only one partition.

Then I started over.

I used Partition Magic to remove the partition table by creating a new "msdos" partition table.

I ran the XP installer.
I created one partition of 10 GB and formatted it as NTFS.
I installed XP here.

The first time XP started I went to disk management to create primary partitions of 60 GB, 37 MB and 23.12 GB.
I did this without assigning a drive letter and without formatting.
60 GB is for Windows 8.
37 MB is for an EFI partition for Ubuntu.
23.12 GB is for Ubuntu.

Image

I ran the W8 installer.
I formatted the partition of 60 GB (NTFS is chosen automatically).
I installed W8 here.

When I restarted I had a boot menu that looks a bit more pleasant compared to the plain terminal multi boot menu of XP.

I chose to start W8.
It showed a block with W8 and a block with "Older versions of Windows".
I clicked on the blocks until "Older versions of Windows" was set as a default.
I thought that this would prevent it from disappearing from the menu like it did last time.
Then I clicked the block with W8.

From then on it worked like you would expect.
Just one difference:
In XP I see only "C".
In W8 "C" is called "D", while the W8 partition is now called "C".

I ran the Ubuntu installer.
I chose the 37 MB partition to be EFI.
I formatted the 23.12 GB partition as ext4.
I installed Ubuntu here.

When I restarted it showed a GRUB menu with Ubuntu and "Windows 8".
If I choose here "Windows 8" then I get the pleasant menu with W8 and XP.

From then on it worked like you would expect.

Image

Then I did some optimizations like stopping the indexing service and deleting the virtual memory in XP since it can use only 3 GB.

Now I have uninstalled devices in W8:

Image

In the same order:

PCI\VEN_1180&DEV_0852&SUBSYS_20CB17AA&REV_11
PCI\VEN_1180&DEV_0843&SUBSYS_20C917AA&REV_11
PCI\VEN_1180&DEV_0592&SUBSYS_20CA17AA&REV_11
USB\VID_0BDB&PID_1900
USB\VID_08FF&PID_2810
PCI\VEN_8086&DEV_2A47&SUBSYS_20EC17AA&REV_07
PCI\VEN_8086&DEV_2A44&SUBSYS_20E617AA&REV_07
ACPI\IBM0068

ajkula66
SuperUserGeorge
SuperUserGeorge
Posts: 17247
Joined: Sun Feb 25, 2007 11:28 am
Location: Brodheadsville, Pennsylvania, USA/Belgrade, Serbia

Re: T500 with XP x64

#11 Post by ajkula66 » Mon Jan 10, 2022 1:06 am

A couple of things here...

Lenovo - and most other manufacturers - never bothered much with developing drivers for XP 64. This means that just about every install is likely to be buggy and unstable at best.

If you want a stable system, W7 64 in *any* flavour is your friend here, especially on a machine as old as yours.
...Knowledge is a deadly friend when no one sets the rules...(King Crimson)

Cheers,

George (your grouchy retired FlexView farmer)

One FlexView to rule them all: A31p

Abused daily: T520, X200s


PMs requesting personal tech support will be ignored.

OS923
Posts: 12
Joined: Thu Dec 16, 2021 10:33 am
Location: Dendermonde, Belgium

Re: T500 with XP x64

#12 Post by OS923 » Wed Jan 12, 2022 9:53 am

I had to reinstall XP:
- Some updates couldn't be installed in Dutch XP.
- The Conexant chip wasn't detected because of my Logitech Z-5 speakers, even after I unplugged them.
- 10 GB was soon too small. XP is only 1.6 GB, but the drivers were 1.2 GB and with all the .NET frameworks and MSVC++ redistributables installed there wasn't much free space left.

This caused that all the rest had to be reinstalled too.

I installed English XP SP3 x86.

I installed the frameworks.

Image

I had 16 uninstalled devices.

Image

I ran these installers:

1. Audio
- Conexant audio features 3.64.15 = 6ea118ww.exe

2. Chipset
- Intel AMT 4.2 ME firmware update utility 4.2.60.1060 = 7ur6cdww.exe
- Intel AMT 4.2 local manageability service and serial over LAN driver 5.4.1.1016 = 7vr408ww.exe
- Intel AMT 4.2 management engine interface for Windows 4.2.0.1008 = 7vr308ww.exe
- Intel chipset support for Windows 2000&XP&Vista&7&8 9.3.0.1021 = g1ic09ww.exe

3. Display and video graphics
- ATI Catalyst install manager 3.0.790 = 7yd128ww.exe
- Presentation director = 7zua31ww.exe
- ThinkPad monitor file for Windows 2000&XP&Vista&7&8 4.38 = 79oi30ww.exe

4. Keyboard and mouse
- Synaptics ThinkPad UltraNav driver 16.2.19.14 = 6hgx81ww.exe
- ThinkPad UltraNav utility 2.13 = 7vgq14ww.exe
- ThinkPad keyboard customizer utility = 7kkd03ww.exe

5. Networking LAN (Ethernet)
- Intel PRO 1000 LAN adapter software for Windows XP 10.1.17 = 7vra23ww.exe
- WAT Enable WOL from S3 for Energy Star 1.8 = osfj09ww.exe

6. Networking wireless LAN
- Intel wireless LAN (11abgn) 14.3 = 8aw217ww.exe

7. Networking wireless WAN
- Ericsson wireless module = Vodafone and AT&T wireless WAN (HSPA) driver 1.0.1046.229 = 7uwc49ww.exe
- ThinkPad Lenovo mobile broadband for Windows XP&Vista 3.4.71 = 7twa71ww.exe
- ThinkPad UNDP Wireless WAN driver 6.0.7 = 7xwc27ww.exe

8. Storage
- Intel matrix storage manager driver for Windows XP&Vista 32bit&7 32bit 8.9.2.1002 = 6iim10ww.exe
- WAT Disabling tool for Intel turbo memory = 7kip05ww.exe

9. BIOS
- ThinkPad BIOS settings Windows 3.3 = 83ts04ww.exe

10. BlueTooth and modem
- ThinkPad Bluetooth with enhanced data rate software 5.5.0.9700 = 7vba20ww.exe
- ThinkPad modem adapter 7.80.8.50 = 6imb06ww.exe

11. Card reader
- Ricoh 4-in-1 card reader driver for Windows Vista&XP = 7kss55ww.exe
- SmartCard reader 4.0.0.8 = 7kxx13ww.exe

12. Fingerprint scanner
- Fingerprint software 3.3.2.50 = setup32_xpv.exe

13. Power management
- ACPI device driver = c1acp12us17.7z
- Lenovo power management driver 1.67.4.5 = gtku09ww.exe
- Power manager software 5.20 = ghu704ww.exe

14. TPM
- TPM device driver 1.0.4.15 = q5tpm04us13.exe

Some tips:

ATI Catalyst install manager 3.0.754
-> Don't change the proposed path.

Ricoh 4-in-1 card reader
-> Point the new hardware wizard 3 times to the folders in DRIVERS\WIN\4IN1: MS, SDMMC en XD.

SmartCard reader
-> Point the new hardware wizard to DRIVERS\WIN\SCREADER.

AHCI
-> Follow these instructies from www.experts-exchange.com
1. Start the BIOS Setup Utility menu.
2. Select Config.
3. Select Serial ATA (SATA).
4. Select Compatibility.
5. Install Windows XP and Service Pack 2.
6. Download Intel Matrix Storage Manager Driver from the Web site and extract the driver to C:\DRIVERS\WIN\IMSM.
7. Run Intel Matrix Storage Manager Driver. To do this, go to C:\DRIVERS\WIN\IMSM\PREPARE, and double-click install.cmd.
8. Turn the computer off and then on again.
9. Start the BIOS Setup Utility menu.
10. Select Config.
11. Select Serial ATA (SATA).
12. Select AHCI.
13. Start Windows XP. The Welcome to the Found New Hardware Wizard appears.
14. Click No, not this time and click Next.
15. Select Install from a list or specific location(Advanced), then click Next.
16. Select Search for the best driver in these locations. Then select Include this location in the search:, specify the path, C:\DRIVERS\WIN\IMSM, and click Next. The Completing the Found New Hardware Wizard appears.
17. Click Finish.
18. When the System Settings Change window appears, click Yes. The computer
restarts.

Image

In Windows 8.1 the following devices are not installed:

Base system devices:
PCI\VEN_1180&DEV_0852&SUBSYS_20CB17AA&REV_11
PCI\VEN_1180&DEV_0843&SUBSYS_20C917AA&REV_11
PCI\VEN_1180&DEV_0592&SUBSYS_20CA17AA&REV_11

Ericsson F3507g Mobile Broadband Minicard Composite Device:
USB\VID_0BDB&PID_1900&REV_0000

Fingerprint Sensor:
USB\VID_08FF&PID_2810&REV_1703

PCI Serial Port:
PCI\VEN_8086&DEV_2A47&REV_07

PCI Simple Communications Controller:
PCI\VEN_8086&DEV_2A44&SUBSYS_20E617AA&REV_07

Unknown device:
ACPI\IBM0068\5&2890D699&0

Another problem: I don’t have the correct screen resolution.

I haven’t installed a thing yet in W8.

OS923
Posts: 12
Joined: Thu Dec 16, 2021 10:33 am
Location: Dendermonde, Belgium

Re: T500 with XP x64

#13 Post by OS923 » Fri Jan 14, 2022 1:04 pm

NET 4.0 could be installed in XP SP3.

I installed in Windows 8:
- Ericsson wireless module = Vodafone and AT&T wireless WAN (HSPA) driver 1.0.1046.229 = folder WWANER = 7uwc49ww.exe
- Lenovo power management driver 1.67.4.4 = folder PMDriver = gtku07ww.exe
- Ricoh 4-in-1 card reader driver for Windows Vista&XP = folder 4IN1 = 7kss55ww.exe
- Synaptics ThinkPad UltraNav driver 16.2.19.2 = folder UNAV = 6hgx73ww.exe
- ThinkPad Lenovo mobile broadband for Windows XP&Vista 3.4.71 = folder 7twa71ww = 7twa71ww.exe
- ThinkPad modem adapter software 7.80.8.50 = folder ModemOM = 6imb06ww.exe

There are 3 devices left + the Radeon + IMSM/AHCI.

Fingerprint Sensor:
USB\VID_08FF&PID_2810&REV_1703

The 2 pieces of AMT:

PCI Serial Port:
PCI\VEN_8086&DEV_2A47&REV_07

PCI Simple Communications Controller:
PCI\VEN_8086&DEV_2A44&SUBSYS_20E617AA&REV_07

Summary:
- AMT.
- Fingerprint sensor.
- IMSM/AHCI.
- Mobility Radeon 3650 HD.

OS923
Posts: 12
Joined: Thu Dec 16, 2021 10:33 am
Location: Dendermonde, Belgium

Re: T500 with XP x64

#14 Post by OS923 » Sun Jan 16, 2022 6:08 am

The Radeon is installed by 13-1-legacy_vista_win7_win8_64_dd_ccc.exe

OS923
Posts: 12
Joined: Thu Dec 16, 2021 10:33 am
Location: Dendermonde, Belgium

Re: T500 with XP x64

#15 Post by OS923 » Wed Jan 26, 2022 9:59 am

The following parts could not be installed in Windows 8.1:
- Intel AMT 4.2 local manageability service and serial over LAN driver 5.4.1.1016 = 7vr408ww.exe
- Intel AMT 4.2 management engine interface for Windows 4.2.0.1008 = 7vr308ww.exe

But they could be installed in Windows 10 in Windows 7 compatibility mode.

That’s how I wanted Windows XP Pro SP2 x64 but I ended up with a dual boot Windows XP SP3 x86 and Windows 10 Enterprise x64 with all devices installed except AHCI and the fingerprint reader that doesn’t work with Windows Hello.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T400/T410/T420 and T500/T510/T520 Series”

Who is online

Users browsing this forum: Bing [Bot] and 10 guests