Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

OS X on Thinkpad T40

OS-X on ThinkPads
Post Reply
Message
Author
ok2
Posts: 1
Joined: Mon Oct 27, 2008 10:32 am
Location: Toronto Canada

OS X on Thinkpad T40

#1 Post by ok2 » Mon Oct 27, 2008 12:03 pm

Hello, this is my first post. I've tried to read all of the rules and FAQ's and what not.

At any rate I've noticed a couple of user's have mentioned that they have successfully been able to boot into OS X on thier T40. I've had a difficult time getting things going. I've been attempting to install the Kalyway version of OSX. I've attempted both 10.5.1 and 10.5.2 to no avail. The issues have run the gamut, the can't find boot.plist issue, black screen, the apple logo loading screen going forever.

I've checked the OSX86 board and the HCL for previous successul installs but the details are pretty limited. So I'm hoping that someone with a t40 on this board could lead me in the direction of a successful install. The goal here for me is to get Logic express up and running... even if it's v7 with an apple support external usb sound/midi inferface. So IR doesn't matter to me much nor does wifi, but wired LAN needs to work.

At anyrate if any of you who hve gotten a successful install on a t40 could let me know which version of osx86 you used and what options you selected for the install and what kext's you had to manually install and how you went about that I would really really appreciate it.

Thanks,

Jason
T40, T61, Macbook Pro, Dual 1.8ghz G5 Powermac
Toronto

Isaac000
Posts: 27
Joined: Fri May 28, 2004 3:56 pm

#2 Post by Isaac000 » Wed Nov 05, 2008 11:49 pm

I used a Kalway 10.5.1 I found and plopped it onto my T40p, which I assume is close enough to your T40.
I'm afraid I can't remember the exact steps I took (anything I found online wasn't detailed enough). The only catch is right at the very beginning when you have to select ... I think it was EFI or MBR or something like that. If I recall, there were 4 possible combinations of settings, and it isn't the "best" setting that worked.

After that, just let things happen and do be aware there is a couple of stages where it waits A LONG time (30-60 min.?). There isn't any manual hacking I have to do. Only catch is ... no WiFi, but I understand 10.5.2 solves that.

waltsu
Posts: 3
Joined: Wed Nov 05, 2008 1:21 pm
Location: Oulu, Finland

T43 and iDeneb

#3 Post by waltsu » Fri Nov 07, 2008 1:25 pm

Hi,

I used iDeneb 10.5.5 for my T43. iDeneb works for most hardware really nice. First you need to disable SpeedStep form BIOS and I disabled also all "legacy" devies like serial prot and floppy. You need to use MBR bootsector in OSX setup. Then in Customize use:

AC '97 Audio (use Azalia if you get no sound)
ICH fixed
9.2.0 SpeedStep
AppleBC5751 (Broadcom NetXtreme)
ACPI-Fix
PowerManagement

If you do not disable Speedstep, you cannot boot without the power cable and if you get an "no parking traffic sign" on boot on top of the gray Apple logo,you have an wrong kernel or the BSD Unix does not fid the HD. Most likely it's the kernel.

If you get the "looping welcome screen" google it and you will find the answer quick. It is done in single user mode by few command in terminal.

Hope this helps. I think the basic components are about the same between several T4- series altough the T43 has DDR2 while T40 has DDR memory. I did have some trouble with T42 on those setings but I did not really try too much. T43 work pretty well but I do not have CI/QE video.

Best Regards,
- Waltsu
IBM: 600E, T20, T22, T42, T43. Lenovo T61 & X60s all working great. X60s working nicely with Leopard.

Isaac000
Posts: 27
Joined: Fri May 28, 2004 3:56 pm

#4 Post by Isaac000 » Wed Nov 12, 2008 1:41 am

Back to my T40p...

I tried iDeneb 10.5.5, well, first try didn't work. Some error on boot after install, it was immediate. Something about MBR...

Anyways, back to Kalyway 10.5.1, I re-installed:
- Reformat the entire drive, single partition, HFS journaled, case sensitive. Make sure it is set up for MBR
- During the installation, the ONLY things I select are "SSE2" and set the booter to "MBR", not EFI, GUID or something else. Do not select anything else.

After install and reboot, it should work without intervention. However, be aware that the boot "hangs" for a very long time, so be patient and wait. Watch some TV. Eventually it will boot ...

You will have to manually edit a file with text editor to force the resolution to the 1400x1050 that my machine is capable of.
The only thing that doesn't work is networking. The wired connection appears to be detected, but won't acquire IP. As for the WiFi (this machine has an Atheros, ID'd as 0168C, 0012), no luck. There were suggestions on line as to how to edit a certain text file an add an entry, but appears it's not for this version of the WiFi. On boot up, if I add the entry, it appears to detect and try to load the driver, but it fails.

So, one "perfectly" working Thinkpad T40p with OS X, except no networking ...

Any tips appreciated. (I am assuming this will never happen, that Atheros chipset is older so I doubt newer release of OS X would support that chip, but I'd be happy to be proven wrong).

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “OS-X Questions”

Who is online

Users browsing this forum: No registered users and 8 guests