Hitachi HTS541010G9AT00 on T43

T4x series specific matters only
Post Reply
Message
Author
farhaddad
Posts: 16
Joined: Thu Mar 19, 2009 3:04 pm
Location: Amman, Jordan
Contact:

Hitachi HTS541010G9AT00 on T43

#1 Post by farhaddad » Fri Mar 20, 2009 9:36 pm

Hi everyone,

First of all, I want to thank the forum family, admins, mods and members for making this place such a great place to be. I've been reading here for a while now and I've always got great answers to all my questions using the search feature.

I have been reading up on all the threads but as there is none talking about HTS541010G9AT00 specifically, I decided to open this thread.

After reading about all the T43 hard disk upgrade problems, I decided to buy Fujitsu MHV2100AH, which I found here. After contacting the seller and making sure that what they have is the same exact HD model number as listed on their website, I ordered the HD.

Unfortunately, when I got the HD it was Hitachi HTS541010G9AT00 instead! The seller simply told me that this is the same HD but with a different brand and that it is a PATA drive and should work! Seriously! Like I needed someone to tell me it's PATA :roll:

Anyway my question now is: Can I upgrade the firmware for this exact model and get rid of the 2010 error? or should I return it.

Thank you very much

Image

ajkula66
SuperUserGeorge
SuperUserGeorge
Posts: 15897
Joined: Sun Feb 25, 2007 11:28 am
Location: Brodheadsville, Pennsylvania, USA

Re: Hitachi HTS541010G9AT00 on T43

#2 Post by ajkula66 » Fri Mar 20, 2009 10:25 pm

Welcome to the forum!

Firmware update is tricky and may or may not work. Personally, I'd return the drive.

Good luck.
...Knowledge is a deadly friend when no one sets the rules...(King Crimson)

Cheers,

George (your grouchy retired FlexView farmer)

AARP club members:A31p, T43pSF

Abused daily: T61p

PMs requesting personal tech support will be ignored.

farhaddad
Posts: 16
Joined: Thu Mar 19, 2009 3:04 pm
Location: Amman, Jordan
Contact:

Re: Hitachi HTS541010G9AT00 on T43

#3 Post by farhaddad » Sat Mar 21, 2009 6:44 pm

Thank you for replying. Any Idea what HD I should get? Also, I'm not very comfortable with the website's return procedures. Can I post their reply here?

ajkula66
SuperUserGeorge
SuperUserGeorge
Posts: 15897
Joined: Sun Feb 25, 2007 11:28 am
Location: Brodheadsville, Pennsylvania, USA

Re: Hitachi HTS541010G9AT00 on T43

#4 Post by ajkula66 » Sat Mar 21, 2009 9:38 pm

Any newer Fujitsu drive will work, such as MHV2080AH, MHV2100AH or MHV2120AH...they are 80, 100 and 120GB on 5400rpm respectively, and don't trigger the "2010 error".

Good luck.
...Knowledge is a deadly friend when no one sets the rules...(King Crimson)

Cheers,

George (your grouchy retired FlexView farmer)

AARP club members:A31p, T43pSF

Abused daily: T61p

PMs requesting personal tech support will be ignored.

farhaddad
Posts: 16
Joined: Thu Mar 19, 2009 3:04 pm
Location: Amman, Jordan
Contact:

Re: Hitachi HTS541010G9AT00 on T43

#5 Post by farhaddad » Sat Mar 21, 2009 10:22 pm

Again, thank you for replying.

Any idea where I can get one of these harddrives (if it's allowed to do so).

Thanks

ajkula66
SuperUserGeorge
SuperUserGeorge
Posts: 15897
Joined: Sun Feb 25, 2007 11:28 am
Location: Brodheadsville, Pennsylvania, USA

Re: Hitachi HTS541010G9AT00 on T43

#6 Post by ajkula66 » Sat Mar 21, 2009 10:35 pm

Google the part numbers, or try eBay...

Good luck.
...Knowledge is a deadly friend when no one sets the rules...(King Crimson)

Cheers,

George (your grouchy retired FlexView farmer)

AARP club members:A31p, T43pSF

Abused daily: T61p

PMs requesting personal tech support will be ignored.

Harryc
Moderator Emeritus
Moderator Emeritus
Posts: 13228
Joined: Thu Apr 12, 2007 8:23 am
Location: Upstate New York

Re: Hitachi HTS541010G9AT00 on T43

#7 Post by Harryc » Sat Mar 21, 2009 10:36 pm

MHV2120AH is not easily found for less than $80 shipped in the US at this point. If anyone finds a less expensive source please post it.

farhaddad
Posts: 16
Joined: Thu Mar 19, 2009 3:04 pm
Location: Amman, Jordan
Contact:

Re: Hitachi HTS541010G9AT00 on T43

#8 Post by farhaddad » Sat Mar 21, 2009 10:50 pm

Thanks ajkula66.
Harryc wrote:MHV2120AH is not easily found for less than $80 shipped in the US at this point. If anyone finds a less expensive source please post it.
Thank you for replying Harryc.

Actually that's what I've paid for it, $90 for MHV2100AH including UPS shipping... But unfortunately the seller was't honest and what I've received was something else as mentioned above! So I don't mind paying $100 for MHV2120AH or even MHV2100AH.

I was excited about this MHV2100AH but the shop reviews are really bad... even though the shop I bought from had some good reviews and my experience with them says the opposite. :?

schen
moderator
moderator
Posts: 1541
Joined: Thu May 06, 2004 11:01 am
Location: Forney, Texas

Re: Hitachi HTS541010G9AT00 on T43

#9 Post by schen » Sun Mar 22, 2009 2:35 am

farhaddad wrote:I was excited about this MHV2100AH but the shop reviews are really bad... even though the shop I bought from had some good reviews and my experience with them says the opposite. :?
Right at 2 months ago, I bought 2 Fujitsu MHV2100AH from eBay from a seller who's ID is "starblues102" from San Jose, CA. They have a an eBay store-front; I've already checked and they don't seem to have any of those drives at this time. I might have bought the last 2 that they had, but I can say that they were considerably less than what you guys are talking about.

I bought them to go into my box of "rainy day" box of PATA drives (which apparently has at some levels at least), has come to pass. :eek: Good luck on this.
Family Daily Drivers- T430s, T530, X220
Work- Sadly, the ThinkPads have gone away...... and replaced by HP ProDesk SFF drone machines :(
Other Projects- Edge 15, Z61m (Titanium)
Historic Retired ThinkPads- T42p, X20, A31p, 701c, 760XD, WorkPad C505

Harryc
Moderator Emeritus
Moderator Emeritus
Posts: 13228
Joined: Thu Apr 12, 2007 8:23 am
Location: Upstate New York

Re: Hitachi HTS541010G9AT00 on T43

#10 Post by Harryc » Wed Apr 01, 2009 5:03 pm

ajkula66 wrote:Any newer Fujitsu drive will work, such as MHV2080AH, MHV2100AH or MHV2120AH...they are 80, 100 and 120GB on 5400rpm respectively, and don't trigger the "2010 error".

Good luck.
As an additional data point, I ordered an MHV2080AH as a result of this thread and others, and the drive does throw a 2010 error on boot in a T43P. It will not take a flash from the IBM firmware upgrade disc.

ajkula66
SuperUserGeorge
SuperUserGeorge
Posts: 15897
Joined: Sun Feb 25, 2007 11:28 am
Location: Brodheadsville, Pennsylvania, USA

Re: Hitachi HTS541010G9AT00 on T43

#11 Post by ajkula66 » Wed Apr 01, 2009 6:25 pm

Harryc wrote:
As an additional data point, I ordered an MHV2080AH as a result of this thread and others, and the drive does throw a 2010 error on boot in a T43P. It will not take a flash from the IBM firmware upgrade disc.
This is a piece of bad news indeed. I've never installed an 80GB one, but had 100 and 120GB Fujitsu working without errors, and any firmware update...so I assumed 80GB would work too...well, we all know what assuming does to you and me...sorry Harry... :oops:

On another note, I've just installed a 80GB/5400rpm Hitachi with a FRU and got the error on one of my machines... :flame:
...Knowledge is a deadly friend when no one sets the rules...(King Crimson)

Cheers,

George (your grouchy retired FlexView farmer)

AARP club members:A31p, T43pSF

Abused daily: T61p

PMs requesting personal tech support will be ignored.

Harryc
Moderator Emeritus
Moderator Emeritus
Posts: 13228
Joined: Thu Apr 12, 2007 8:23 am
Location: Upstate New York

Re: Hitachi HTS541010G9AT00 on T43

#12 Post by Harryc » Wed Apr 01, 2009 9:19 pm

Thanks George. I wasn't trying to direct blame, but rather to warn others. I did an extensive amount of research on this topic and yours was not the only recommendation to try the MHV2080AH drive. I also found at least one more mention of the MHV2120AH not working for someone. So apparently it is a crap shoot with no explanation as to why one Fujitsu drive might work where another does not.

ajkula66
SuperUserGeorge
SuperUserGeorge
Posts: 15897
Joined: Sun Feb 25, 2007 11:28 am
Location: Brodheadsville, Pennsylvania, USA

Re: Hitachi HTS541010G9AT00 on T43

#13 Post by ajkula66 » Wed Apr 01, 2009 10:03 pm

Well, the buyer for the T43 mentioned in the above post had me install a brand new 160GB Hitachi which initially triggered the error, then insisted on downgrading the BIOS, and the error was gone, although fan started sounding very odd and unhealthy...will keep you guys and gals posted on the fate of that particular unit...

The whole Fujitsu thing makes zero sense to me...I must have installed at least 40-50 of them, never an issue....
...Knowledge is a deadly friend when no one sets the rules...(King Crimson)

Cheers,

George (your grouchy retired FlexView farmer)

AARP club members:A31p, T43pSF

Abused daily: T61p

PMs requesting personal tech support will be ignored.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T4x Series”

Who is online

Users browsing this forum: No registered users and 6 guests